Can't load some kexts after macOS upgrade

I’ve been working on a problem for a few weeks and so far it has stumped everyone. I cannot load certain kexts on my work iMac after upgrading from MacOS 10.13.6 to 10.14.6. I suspect that the problem is limited to FUSE based kexts.

2017 iMac with fusion drive, so the upgrade included conversion from HFS+ to APFS. After the conversion I checked the boot drive and Disk Utility came up with many APFS errors. I was able to fix the errors after booting in recovery mode and running Disk Utility from the terminal, the command used by the Disk Utility app on the recovery partition didn’t see the problems.

I noticed that Google Drive File Streaming (GDFS) was not working, I could not get G Drive
to show up on the desktop because the GDFS app will not allow me to log in. It will not even bring in up the log in dialog. I later noticed two other apps had problems, VMware Fusion and ExtendDrive. In both cases they use kexts based on FUSE. And VMware loaded all of its other kexts.

I cleared the kext cache. This can be done either from the terminal or with Onyx.

Another complication is that I use the Mosyle MDM to manage kexts on our company’s Macs. This means that I approve kexts centrally, users never see the message in Security & Privacy in System Preferences to approve a kext. I tried again by removing my Mac from Mosyle (so all of the related profiles were deleted) and deleted the kext cache. I was asked to approve the Dropbox kext but never the GPFS kext.

My next option is to clone the drive, wipe it, rebuild it from scratch, and then migrate my home folder and some other files back over. I have some time to try out other approaches if someone comes up with a great idea. I am working from my home most of the time and my time is a bit short, I won’t have time to rebuild my iMac’s hard disk for around 2 weeks. So I am hoping to fix this problem before September before going nuclear.

I don’t see in your report that you tried reinstalling the software that relies on these kexts. That’s where I’d start, under the suspicion that something happens at install that was wiped when you upgraded to Mojave.

Good question. I didn’t include all of the steps I took.

I tried booting into another account… I even created a new account on the iMac.

I uninstalled GDFS following directions and even found more GDFS files to remove. Then reinstalled.

I uninstalled ExtenDrive. I don’t need it.

Next is to uninstall VMware. Someone once said they had problems if they had more one one app using a kext based on FUSE installed. They coexisted on 10.13.6 and I think a conflict under 10.14.6 would have been detected and fixed by now.

I suspect there is some corrupted file somewhere preventing the kext to attempt to load or preventing permissions from letting it load

You could reinstall macOS before you wipe the drive and restore. Worth a try.

Thanks for the idea. I will try that approach.