Can't change permissions to be able to modify Applications folder without entering password

In preparation for Catalina, I am cleaning up the many ancient 32-bit apps in my Applications folder on my Mac (MacOS Mojave 10.14.6).

For every change, it asks for my system password. I want to let the system know, “hey man, it’s me, no worries.”

So I use Get Info, Sharing and Permissions, unlock the padlock. I click the + to add my username to permissions, click the username, click Select and it tells me, “The operation can’t be completed because you don’t have the necessary permission.” I try to give Read and Write permission to Everyone and I get the same message.

I tried various remedies I found online, e.g. involving “Apply to Enclosed Items.” Nothing works. Scratching my head… Any wizards out there know the right magic?

I don’t know the answer to your actual question, but since Catalina marks 32-bit apps with a slash through their icons, wouldn’t it be easier to select multiple icons at once and then trash them all with one Command-Delete?

You could also use Go64 to identify the apps and then trash them from within Go64.

1 Like

It’s not a good idea to change permissions for the Applications folder, or the individual applications. It can cause apps to become less secure, or break. The system is preventing you from doing what you want on that particular folder.

If you don’t have backups of the apps and/or their installers, you may want to avoid trashing them yet anyway, especially any that you’ve used to create files, or rely on to open old files. Make certain that whatever you replace them with can open all of the relevant older file types properly first. There are two ways to continue to run 32 bit apps–keep an older mac for the purpose, or run an older system in a virtual machine. But neither of those solutions will help rescue data later if you discover a problem if you don’t still have a copy of the necessary app. Leaving the old apps in place for awhile will cause no trouble.

1 Like

I’ve been annoyed by the exact same thing. Yet every single time I want to do something in /Applications/ I get a dialog asking me to authenticate. Good thing on this system I’m not using my 40-character password. :wink:

I am the admin on this box. I should be able to modify /Applications/* if I want. If I don’t want a user to do that, they are not made admin. And if something really needs to be hidden away from user interaction then /System is where that happens.


You won’t be able to do what you are attempting without disabling the System Integrity Protection (SIP) and even then I’m not certain it’s possible.

1 Like

Thank you for the great replies. The strategies you suggested are smarter than my manual method. And for the manaul removals I am doing, I can just change my password to something like zz temporarily so at least it’s easy to type.

As Al Varnell noted, the increased security provided by SIP overrides simple Unix permissions and ACLs. More than once, I have had to perform SIP magic to enable deletion and subsequent new user directory tree creation in order to do a data-only migration, effectively discarding ~/Library which contained the root cause of inexplicable problems ranging from inability to open a Network preferences to mysteriously sluggish performance, all account-specific problems.

After performing the magic and migration, the contents of Notes, Calendars, Contacts, and IMAP mail accounts auto-restored while On-My-Mac mail folders were restored courtesy of Time Machine.

The real lesson for users is to avoid trying to ‘clean up’ their systems because Go64 or similar programs report 32bit apps. Unless the applications occupy many gigabytes (cough, Adobe) it isn’t worth the effort. New updated versions usually overwrite or delete older version and the macOS upgrade process is unaffected by old applications. It will become obvious after upgrading to Catalina what works and what does not. A better investment of time would be creation of a second Administrative account (see note below) as an emergency tool, along with both Time Machine and CCC or SuperDuper! clone backups.

For any new OS install on a blank system, create the emergency administrative account first, update the OS and applications, and then, as needed, migrate user accounts and, possibly, system configuration. Migration Assistant is your friend and works over many kinds of connections, including WiFi.

Most of all, have patience. Upgrading an new 2018 Mini to Catalina today, I nearly had to slap someone’s hand away while the seemingly dead system was busy upgrading firmware and rebooting several times. After then migrating the user account and system settings from an old Mini, miraculously everything the user wanted was there. It just worked™.

1 Like