Binding an app to 2nd monitor


(Nick Pappas) #1

I have a 27" iMac and a second display extending my desktop. There are apps that I use occasionally and briefly during the day (Messages, Contacts, 1Password), and I like to have their windows on the 2nd display while I do my main work on the primary display. When I launch apps, some seem to know that I want them on display #2 (e.g. Address Book) and always open there. Others (Messages, 1Password) always open on the primary display.

I have tried various things to get apps to bind to display #2 (e.g. open them with the desktop active on that display, make sure the app is on that display and in the foreground when I quit) to no avail.

Anybody know a technique for binding the app to a specific display when you launch it?

Nick Pappas


(Alan Forkosh) #2

When you have defined multiple desktops (done implicitly with multiple displays), it is easy to fix an app to a particular desktop. WIth the application foregrounded, go to the dock and control-click on the dock icon for the app. Select the ‘Options’ item and choose “This Desktop” as the “Assign to” option.

I actually don’t use this for multiple monitors, but have multiple desktops assigned to separate my email, browser, iTunes, and general workspace desktops. I use a 4-finger swipe gesture on the trackpad to move from one to another.


(Tommy Weir) #3

Exactly as @aforkosh says. If you want some more flexibility you can use an app like Moom to move windows around with keystrokes.

https://manytricks.com/moom/


(Nick Pappas) #4

I had never noticed that option. Thanks


(Diane D) #5

What OS does that start in, I don’t see it in Sierra.

Diane


(Alan Forkosh) #6

The option to fix an app to a particular (desktop) space has been there ever since OS X supported Spaces, later simplified to Mission Control. I was never able to get my head around Spaces, but when they simplified it, I understood. According to https://en.wikipedia.org/wiki/Spaces_(software), Spaces support was introduced with OSX 10.5 (Leopard) in 2006 and was superseded by Mission Control with OS 10.7 (Lion).


(Diane D) #7

Ok thanks - the obvious reason then is because I’m not plugged into my external monitor. I’ll try it later, thanks for the tip!

Diane