Big Sur & Touch ID — anybody else having trouble?

So I’ve installed Big Sur on my 2020 13" MBP (Intel) and I can’t seem to get Touch ID to work at all. It was working just fine before on Catalina. Whenever a password dialog comes up I have to type it in by hand, there’s not even an option for Touch ID. Touch ID prefs showed boxes checked at first. After a reboot login boxe shows unchecked, but password autofill still checked. Checked login box too, was asked to enter password, password accepted, closed prefs. Still nothing. Go back to prefs and see boxes showing unchecked again. WTH?

Also noted, cannot check box for iTunes Store. It will simply not accept a click and put in a checkmark. It’s not grayed out or anything, just won’t react to clicking.

:confused:

This just got even more odd. I noticed that to unlock my Security Pref pane I cannot use my password. I enter the exact same password I used to log on to my Mac and it’s simply refused. I checked for typos, wrong keyboard layout, etc. It;'s none of that. This is an admin password that works fine for logging on to the Mac, sudo, etc. but the Sys Pref pane will not accept it. ???

Tried a safe boot. Same issue there, Touch ID wouldn’t work and could not get checkbox selection to persist.

Next weirdness: Apple Pay/Card cannot be activated in Sys Prefs.

Turns out several other folks were experiencing the same issue. A simple SMC reset indeed fixed all the issues I was seeing (had to set up Apple Card from scratch though).

:sweat_smile:

1 Like

Crazy! I hate hearing stories like this so often these days… :roll_eyes:

I’m not going to complain too loudly about this because to my great relief the fix turned out to be very simple.

The one thing I just don’t get is, if the Big Sur update needs an SMC reset to work reliably (at least on some systems), why doesn’t Apple just have the updater itself trigger the process? Heck even a popup telling me to do an SMC reset to complete the update successfully would have been better.

1 Like

That’s my point. There are so many things like this happening these days, more with each new update, that I’m left wondering if they even do any real quality control anymore. I’m self-employed as a solo Apple-specific support person, so I see it all, and it’s seriously out of control. YMMV, of course… :nerd_face:

When I got my first MacBook with Touch ID (M1, yeah!) and Big Sur, I wondered why I still had to type the admin password for installing things and was never asked to use Touch ID. It turned out that to use Touch ID for acting as an admin, your user account needs to set up as an administrator. Pretty obvious, but it tripped me up at first.

I’ve seen some suggestions that the M1-based Macs do away with SMC, or at least the need for resets. Apparently NVRAM is monitored on every boot and reset automatically if necessary. It’s entirely possible that Apple agrees with you, but it was too hard to do within the Intel platform.

I don’t know how it could be related, but I just tried (from a user account) to run sudo in Terminal and it would not accept the admin password. (I entered “sudo admin” and “sudo - admin”, each of which had worked before, and entered the password incorrectly three time, according to Terminal.) I gave up and switched user to the admin account and logged in just fine, then ran the sudo command from there.

I was on an M1 MBA that had been restarted earlier today. Any suggestions?