Big Sur: Software update hangs (from my account)

I’m seeing a problem that I’m sure others have seen, but web searches don’t seem to be fruitful.

The Apple menu indicates that Software Updates has an update. But when I go there, the Software Update window just hangs. I see the spinning pinwheel and “Checking for updates…”, but nothing more.

If I log out and log in to my administrator account, it works fine (and I found an update to install). No problem from my account if I boot into safe mode. But when I do a normal boot to my own account, no luck.

I already tried deleting the Software Update preferences file (/Library/Preferences/ I also found a local copy (~/Library/Preferences/ and deleted that. Rebooted. No change.

And today, when connecting my iPod, I got the usual popup about needing to install a driver, but instead of completing quickly, it has also hung. Over an hour staring at:

Screen Shot 2023-09-13 at 18.40.26

I’ve only got one item in my Login items (Stickies). My LaunchAgents doesn’t seem to have anything suspicious (iMazing, Adobe’s updater, Microsoft’s updater and something from VirtualBox).

Any tips about what I might be able to do to fix this (aside from the obvious, like “install your updates from your admin account”, “install your updates from safe mode” and “upgrade to Ventura”).

If there’s some way to figure out what’s blocking the Software Update service from running on my account, I would really like to know what it is.

1 Like

And, as with Software Updates, after rebooting and logging in to my admin account, it installed fine. I couldn’t try that update from safe mode, because it seems macOS doesn’t detect connected iOS devices in that mode.

There’s something strange going on and none of the advice I found on line seems to have helped. It’s definitely not a network issue, because the problem doesn’t occur in safe mode or if I log in to a different account.

I’m assuming that there is some kind of local cache or preference file or other bit of per-user data that has gotten corrupt, but I don’t know what it might be.

Also, when searching for other SoftwareUpdate files in my Library, I found these two, but deleting them and rebooting didn’t change anything:

  • ~/Library/Preferences/ByHost/
  • ~/Library/Preferences/ByHost/

I’ve experienced the same spinning pinwheel in Software Update, also on Big Sur.

I just tried the trick of logging in as admin, to no avail. Still spinning. So that may work, but it doesn’t seem guaranteed.

Still looking …

Logging in as admin only seems to work after a reboot. If I try to update from my account (so it hangs) and then log out/in to admin, then it hangs there too.

So the background service may be getting wedged on something, but it is strange that it doesn’t happen from all accounts.

The command-line softwareupdate -l command also hangs on a “Finding available software” message.

Which isn’t surprising to me. I assume the command and the System Preferences tool are accessing the same internal service.

Do you have enough free space on your device? I’ve seen similar behavior when trying to update VMs that were getting a little tight. I try to have at least 40 GB available for installing “modern” versions of macOS.

Not a problem here. My boot volume has over 900 GB available.

But that is still surprising. Although running out of space might make it impossible to download or install an update, that shouldn’t prevent the OS from simply showing me the list of what’s available (in my case, the link to upgrade to Ventura, since I’ve already installed all the Big Sur updates).

Someone just sent me email to recommend a comment in a Howard Oakley article for this problem. Comment #8.

CleanShot 2023-09-14 at 10.12.17


That worked great. And now to bookmark that link for later reference!

That worked a treat! Thanks!

As @Shamino says, bookmark that link!


I also was very surprised. In addition to seeming to be stuck on the “Finding available software” step, I noticed a consistent cpu usage pattern where softwareupdated would be at >10% cpu for a few moments after logging in or killing and relaunching, but then would drop quickly to ~0.4% cpu and remain there indefinitely while failing to complete the “Finding available software” step. The problem disappeared when I enlarged the VM volumes.

If I ever run into it again, I will try the launchctl method mentioned earlier.

What’s even more surprising is that after using that launchctl command to forcibly restart the software update daemon, and then checking for updates, it seems to have unblocked whatever was wrong in my account.

Several days later, a normal check for updates worked (presented the Ventura upgrade link), and then after a reboot, it continued to work.

So restarting the daemon cleared some cache that didn’t get cleared by booting into safe mode. I’ll probably never know what it was, but I’m glad that it seems to be fixed.

The launchctl command came from Apple several months ago to assist business/education ITs with the problem and went into routine use back then. But recently Apple said they felt they had fixed the problem on their end and asked that it no longer be routinely used.

Your experience mirrors what ITs are experiencing, that although the problem has lessoned, it still pops up occasionally.