AppleID Woes

I live in Thailand, but have a home in the US state of Oregon. I have two AppleIDs; one for getting stuff from the US stores and one for getting stuff from the Thai stores. Starting a month or so ago I’m bugged constantly on my Apple TVs to enter the password for the ID I use for the Thai stores. This ID uses a Gmail address:

But, when I enter the password that I know is correct (it is stored in 1Password) it is rejected:

I check Settings on the Apple TV to make sure I’ve got the right ID:

Next step is to go to Apple’s “I Forgot” page to set a new password for that Apple ID. But then this happens:

After that I’m with Apple support via both iMessage and the phone for several hours. No one really has a clue.

Anyone else experience anything like this?

I had a somewhat similar experience with an app for my iPhone called Circuit. I needed to install it for some work I was doing with a company for which I was using a gmail address. In order for the app to work, it needed my email address, so I tried to use the gmail email address that I was using for the job. Circuit kept telling me that either the address or the password was incorrect. I use both 1Password, and the Apple keychain, so I know I was entering everything correctly. When I used a different, non-gmail address, everything worked immediately. There must be something about gmail that caused my problem and it may be related to your problem.

Hmmm. I wonder if any of the problematic Gmail addresses have dots in. Gmail ignores any dots when delivering email - see Dots don't matter in Gmail addresses - Gmail Help. But I wonder if the other systems involved here do not, and so would be treated as a different account to


I’ve been using that same Gmail address as an Apple ID for quite some time. I originally set it up almost a decade a go when I needed a Thai store ID to download Garmin’s maps of Thailand. It’s relatively recently that the problems started.

[Edit] I checked 1Password and found that the entry for the Gmail Apple ID was created on November 3, 2010 and last used to log in on November 12, 2021. So, I used it for over a decade before the problems started.

The Apple support specialists with whom I spoke didn’t mention anything about there being a known problem with Gmail addresses. Perhaps its rare enough that they don’t know about it.

I did try entering the Gmail address without the dots. That didn’t change things.

[Edit] I also tried to recover the Apple ID using my name and Gmail address but got the following:

I do have yet-another Apple ID, based on a Yahoo address, that I only use with the iPhone store to download Thai government apps (mostly Covid related) that are not in the US store.

When the US football season is over (I’m afraid of losing the NFL Game Pass app on my Apple TVs) I’ll remove the Gmail address from the ATVs and try the Yahoo Apple ID.

FWIW, there are no dots in my gmail address that failed with Circuit. However, that email address has been used as the underlying delivery address for business email addresses that weren’t gmail addresses but that gmail managed.

I think Apple might have introduced a bug recently. My HomePods are complaining that my Apple ID and password are incorrect, but I know the information is correct because it works everywhere else. It sound like you might have run into similar behavior on your Apple TV. Can you log into anything using that Apple ID?

I have had trouble with initial log in, to the App Store and Apple ID when my Pihole (network-wide adblocker) is active. I disable it temporarily, and it works after that.

I tried to log in to but was told the password was incorrect. Same as on the Apple TV.

Oddly, and for the first time in a couple of months, I was not asked for my Gmail Apple ID password yesterday when I used my Apple TV.

Can Apple verify that that email address is an Apple ID still? I wonder if the email address on your account was changed, perhaps by someone who somehow broke into your account.

When I was on the phone with Apple support they were able to confirm that the Gmail address is still an Apple ID. But, they couldn’t explain why I can’t reset the password.

Maybe related to a more generalized iCloud problem?

I suppose it’s possible. It was about November that I first started getting the “enter password” notices on my Apple TVs. I didn’t get those notices yesterday.

[edit] I just tried to log in with the Gmail Apple ID and known correct password. It didn’t work. I tried to go to “I Forgot” but am still told that the Gmail address is not a valid Apple ID.

I’ve seen things like this happen occasionally, going back many years. Sometimes rebooting your computer seems to work. Other times, nothing works, but the problem magically resolves itself a day or two later (strongly implying that it was a server-side problem).

1 Like

Going off at a tangent, I’m a Brit living in France so I occasionally have to switch between the UK and French app stores.
You can do all that without changing your Apple ID by altering Country/Region in Media & Purchases. You might also have to change your payment method for purchases in the appropriate currency.

I’m aware of that, but I’ve had problems doing that in the past. That’s why I set up the second Apple ID. When I spoke by phone to the Apple support person he said having a second ID was a good it would avoid some of the problems he’s encountered assisting other Apple customers.

As I recall, using one ID in more than one store caused some problems with app updates. Perhaps Apple has fixed all that.

I firmly believe that there are some odd things going on behind the scenes with iCloud/Apple ID accounts.

My Apple ID dates back to the original iDisk/.Mac accounts and my email address works with, and A few years ago I stopped receiving iCloud email altogether. It took about two weeks and an escalation to Apple Engineering to resolve the issue. They never explained what the issue was, but it had them scratching their heads for a while.

More recently I had an issue where Mac Mail would crash downloading messages from my iCloud account. Once again, Apple Engineering got involved, but never found a fix. I was able to resolve the issue by most of the email messages that were stored in the iCloud account.

1 Like

On Friday, during the iCloud outage, I received no requests to enter my Google Apple ID password on my Apple TVs. Yesterday, I was stuck in a seemingly Infinite Loop of password requests. After repeatedly dismissing the dialog box I was finally able to use the Apple TV.

Just for kicks, I decided to try to set up an Apple ID using the same Google email address, but without the dots.

So, now I have two Apple IDs using the same Google email address; one with dots and one without.

Sometimes I think AppleID exists just to stress-test users :wink:


Yep, multiple repeated password rejections before finally getting accepted, always cut and paste from my pwd manager so not typos. Accompanied by several different popup security code offers and an automated phone call giving me a different security code to try.
I assumed someone had a robot trying to crack my account, but could just be Apple screwing up.

1 Like