Apple Watch stops unlocking MacBook Pro

I don’t know whether there are reports of this problem starting to surface, but it took four calls to Apple Support before I finally reached someone who said: “It is a system-wide problem, we will let you know when we have a solution.”

I have a six-month-old Apple Series 5 watch (with cellular and GPS) which for the first five months of its life was consistently and regularly unlocking my 15” Retina MBP with Touch Bar. Suddenly - that stopped working. I was too busy to look into it immediately, but finally started trying to track it down this past Monday. First call was dispatched to a watch specialist, who had me delete all content and restore from backup.
That actually took two calls (a call and a call-back) since the restore took two forevers. Third call went to a lady who was clearly in over her depth, she couldn’t even answer simple watch interface questions (What does it mean when the dot over the 12 o’clock pip turns green? What dot, is it glowing?) I got impatient and broke off the call, my mistake - I should have asked for second level support. I called a forth time, and finally talked with someone who put me on hold while they talked to second and third level support. The final answer was what I reported above - and I’ve been promised a call-back next week, with at least an update.

Of course, in the meanwhile, I’m unlocking with the finger print reader, which isn’t too reliable on my ancient dry skin.

Sure would appreciate anyone else with similar issues confirming my experience (with the watch, not with Apple support, which in general has been excellent).

Bill

My watch still reliably unlocks my MacBook Air (I haven’t used the iMac since watchOS 7, but I’ll try it later), but I saw somebody in Reddit who posted the same issue yesterday. He’s tried a number of things, still no solution.

See https://www.reddit.com/r/AppleWatch/comments/j7jq2h/unable_to_make_apple_watch_unlock_mac/

Thanks for sharing this.

We know that after a reboot, we have to enter a password again. But there are many times, on both my iMac and my MacBook Air, when there has been no reboot and yet my unlocked Apple Watch will not unlock the Macs. I have to type in the password.

SOMETIMES going into Settings -> Security and toggling the Apple Watch checkbox makes it start working again. But sometimes not.

And the problem seems to have gotten WORSE sometime in the last 30-60 days.

Both Macs are running the latest Catalina, and my Apple Watch Series 4 is on the latest OS.

Maybe the new WatchOS made it worse?

Very annoying not to be able to rely on this.

I find that my Apple Watch is inconsistent in whether or not it will unlock my work or home iMac.

Replying to say that the watch is unlocking the iMac reliably as well. With the MBA, there are times when it doesn’t unlock, and you can tell based on how long it’s taking when it will not work (and then I just enter the password). This happens maybe once every week or two.

Both Macs are running the latest version of Mojave, the watch is on watchOS 7.0.1.

Well, I came across this recipe in the Apple forum. It sounds plausible, although I haven’t tried it yet. I’ll wait to see if Apple gives me the promised call-back. The “happy to report it fixed it for me” is someone else - not my comment.

Fixing Unlock Problem

A:

Happy to report what fixed it for me, following steps originally posted here Mac auto unlock stopped working after wat… - Apple Community by user stoska992, then adding a couple of steps added by others:

FIRST, this procedure:

Steps (follow at your own discretion)

  1. Open “Keychain Access”
  2. In “View”, enable “Show Invisible Items”
  3. Search for “Auto Unlock”
  4. You should see a whole bunch of application passwords for “Auto Unlock: XXXX’s …”
  5. Select all records and delete (this will reset/disable auto unlock on other Macs if you use multiple Macs)
  6. Whilst still in “Keychain Access”, search for “AutoUnlock” (no space)
  7. There should be 4 entries for “tlk” “tlk-nonsync” “classA” “classC”
  8. Select 4 records and delete (don’t worry if they re-appear, the system repairs this automatically)
  9. Open “Finder” and navigate to “~/Library/Sharing/AutoUnlock”
  10. There should be two files “ltk.plist” and “pairing-records.plist”
  11. Delete both files
  12. Open “System Preferences” and try enabling auto unlock. You may need to enable it twice, the first attempt will fail.

THEN, this command in terminal provided by contributor “isprainedmyuvula” ( …a breathtakingly creative silly handle):

sudo rm /Library/Preferences/com.apple.Bluetooth.plist && sudo shutdown -r now

…Which will restart your Mac.

THEN #12 above again. And just like stoska992 writes, it indeed took the second attempt at checking the box, and out worked instantly!

1 Like

I’ll be curious to hear if that works. I’ve seen intermittent Apple Watch unlocking problems on my old and flaky 2014 27-inch iMac, but since I upgraded to the 2020 27-inch iMac, it has been rock solid.

Holy cow!!

Bottom line: With one additional step, I was able to get it working again.

First my setup is iMac (Retina 5K, 27-inch, 2017) running Mojave, iPhone 7 and Watch Series 4, all fully up-to-date, including today’s watchOS 7.0.2. I had previously fixed the battery drain problem by un-pairing and re-pairing the watch a couple of days ago, but wanted everything on latest release versions before starting the process.

I had this problem a year or so ago, which was solved by simply deleting those files from the Keychain, but that wasn’t enough this time. When I tried to enable it in System Preferences, I would see the gear spinning for many seconds and then the failure dialog urging me to make sure the iPhone and Watch were awake and I was wearing the watch, all of which were true.

After going through all the steps outlined, I got a new notification immediately after checking the box saying it could not reach my watch. I disabled and enabled both WiFi and BlueTooth on my watch and that worked.

I’ve had this issue since replacing my original Apple Watch with a watch SE…

Happy to report the first step fixed the issue! Thank you so much! I’d tried everything so far with resetting wifi, or decoupling my watch etc.

The only thing I had to do different is by default I could not delete the files mentioned as they’re protected files under Catalina and Mojave to fix this I followed these instructions to allow Terminal edit rights to protected files: Fix Terminal “Operation not permitted” Error in MacOS Mojave

I recommend removing Terminal access after you’re done to keep the level of Mac OS security on high

Again thank you, this has been bugging me for a week!