Apple Watch not displaying text message notifications

My iPhone 13 Pro Max is running iOS 17.1. Somewhere in the v17+ releases, I’ve lost notification sounds for text messages unless the screen is unlocked. There is a long thread in the Apple Community Discussions forum on this topic, but no definitive solution. I do have an Apple Watch (Series 8, watchOS 10.1) paired with the phone, which seems to be common among those reporting the problem.

Anyone else experiencing this? If so, any solutions?

With an Apple Watch, unless you have turned off the default notification options (by doing Watch app, Notifications / Messages / Custom, then “Notifications Off”; Watch app / Messages saves the step of choosing “Notifications” first), this has been the standard from the beginning - notifications make sound and/or haptics on an unlocked watch unless the phone is unlocked, and only then they sound and/or vibrate there.

See Notifications on your Apple Watch - Apple Support

(To answer the question: no, nothing has changed for me with iOS 17/watchOS 10 for message notifications. Reading through the first page of the discussion thread you linked, I have always had banners, Lock Screen, and Notification Center turned on, though.)

I read the article you linked (thanks). Apparently at some point Sound alerts were turned off on my watch, but Haptic is on. So either I’m not feeling the haptic notification when a text message is received, or I have a bigger problem. I’ve turned Sound back on; we’ll see if that effectively solves my “silent phone” problem.

But I’m still confused. For one, If the solution is as simple as that, it’s hard to believe the reports (in the thread I linked above) of engaging with senior support staff at Apple without being able to resolve the issue. For another, I’ve had an Apple Watch for over five years, and while I wouldn’t stake my life on it, I’m pretty sure I used to get text message notifications on my phone, regardless of whether they also came to my watch. But age and memory are fickle things…

Almost 7 years for me. And it has always been this way since I’ve owned my first, the Series 2.

Unless I am forgetting something, the only exceptions are phone calls, which ring on both devices (at least they do for me).

To be honest, this is one of the things I wish I had more control over. I want notifications to go to my watch whenever it’s unlocked always, even if the phone is active. It would be easier for me to just have one device that gets the notifications by default. And I know that many people would like to have discrete control - messages always to the phone, mail always to the watch, etc. I don’t mind the current system as the default for the majority of users, but would love more options for power users.

But, wouldn’t most of us, for lots of other Apple devices.

OK, I’m not going crazy. Something is definitely askew. If I receive a text and my phone is unlocked, I get the notification sound and haptic vibration on the phone. If I receive a text and my phone is locked, I get nothing on my watch. There is no notification on screen, no sound, and no haptic. There’s not even a red dot indicating something in the notification center. Messages notifications on the Watch app are set to “Mirror iPhone”.

Very strange. I’ve restarted both the phone and the watch, the watch reports it is successfully paired with the phone, yet no text message notifications on the watch. I’ve checked all the settings I can find, and they all look normal. Guess I need to call Apple.

And just to close the loop on this, after 45 min. on the phone with Apple support, the final thing that ended up restoring text message notifications on my Apple Watch was unpairing and re-pairing the watch with my phone. The rep did her job very well, went through all the options from least invasive upwards. She also mentioned they’re getting lots of similar complaints at the moment, although she didn’t specifically say “since watchOS 10”.

Also, thanks @ddmiller for setting my memory straight on where the notification is supposed to appear depending on the phone lock status. I think I’ll change the name of the topic so that it more clearly reflects reality. :slight_smile:


Sigh. I really wanted a happy ending for this thread, but alas, the “fix” lasted less than an hour. Back to no text message alerts on my watch. At least I know all the settings are correct, and there is no hardware failure on the watch (as a result of my time with Apple support). But it’s a real bummer, since my phone is in my pocket and locked pretty much 90% of the time. That means effectively I get no notification of text messages unless I happen to be sitting at my desk (where the notifications do appear in macOS’s Notification Center), or I take a look at my phone.

Aha. What happens if you turn off message notifications on the Mac? I didn’t think to ask about that, but I believe if the Mac thinks you’re actively using it, it may also silence notifications on the watch. For reasons that I don’t particularly agree with, Apple wants to sound a notification on the watch only if nothing else is being actively used. I noticed that behavior long ago and turned them off on the Mac myself.

Thanks. It was worth a try, but unfortunately did not work.

1 Like

Ok, I’ve seen enough people on Reddit and on other forums, in addition to you, complaining about not getting haptic or sound notifications with watchOS 10 (including on 10.1.1) that I think that it’s a thing.

Perhaps the best thing to do is to try turn off message notifications on the watch (watch app / Notifications / Messages / Custom / Notifications Off) and just use the phone for message notifications for now. (And do the same for any other app notifications that you think you may be missing.)

I’ll also confirm in testing this, though, that if I have message notifications turned on for my Mac, and I am actively using it, and my phone is unlocked, that the notifications will go to my Mac and not to my phone. I suppose that’s fine if I am actively using the Mac, but I worry about the times when I’ve stepped away long enough that the Mac has not locked but I am far enough to not hear the sound (I have the sound on my Mac set very low.)

Thanks. So just to clear up any lingering misunderstanding, I do not get text message notifications on my Apple Watch, period. They are not in the Notification Center on the watch, they don’t appear on the screen, they don’t play a sound, and there is no haptic vibration. OTOH, all notifications other than text messages do all of the above. I do get the message itself: if I open the Messages app on the watch, I see the message. It seems that the watch is just failing to generate a notification, despite receiving the message.

I do get text message notifications on my phone. If the phone is locked, they just go to the iOS Notification Center. If it is unlocked, I get them on screen, with sound and haptic vibration. In addition, text message notifications are forwarded from my phone to the Messages app on my Mac, where they appear in the macOS Notification Center and make the appropriate sound whether the phone is locked or not, or whether the Messages app is running or not.

Right, and what my recommendation will do is make sure that you get notified of the messages at the very least - take the watch out of the notification loop for messages altogether.

You’d think that would work, right? The phone should say “Oh, look, text message notifications are turned off for the watch. Guess I’d better start showing them whether I’m locked or not.” Unfortunately, there is no change for me if I turn off text message notifications on the watch. I even tried turning the watch off, but still no joy. (I assume text message notifications show on locked phones for people who don’t have an Apple Watch?)

While I was typing this, I got a notification (visual, sound, and haptic) on my locked phone about a missed phone call. So at least phone call notifications show on a locked phone. I guess I could un-pair my watch again and then see if I start getting text message notifications on my locked phone. But, even if I did, it’s not like I can leave it un-paired.

[So I did discover how to “fix” the problem: Turn the watch off and back on. I will subsequently get one (and only one) text message alert. After that, nada. Until I turn the watch off and on again. :crazy_face:]

I guess it’s time to call Apple and try to escalate this issue. Clearly their last suggestion to unpair and re-pair didn’t help.

Though I might also suggest one more big thing to try, if you have the time: unpair, backup the phone, factory reset the phone, restore the phone, and pair the watch - and I’d also suggest not restoring the watch from backup, but set up from scratch. This is mildly annoying - it drains battery on the phone for a few days as it indexes everything again, and you need to add Apple Wallet cards again to both the phone and watch, and even log in to apps all over again.

I’ve just noticed this issue today - I was messaging to and fro with my daughter and my watch wasn’t displaying/sounding notifications.

I’m sure there’s an watch update to do so I’ll do it tonight and see if it rectifies the problem.

The latest (afaik) is 10.1.1. And unfortunately, at least in my case, it doesn’t address this issue. But I hope it works for you.

The nuclear option? :slight_smile: Yeah, there’s always that. But, at least for now, I’m going to wait on Apple for a fix. If it gets to be a big enough problem for me, I may go that direction. But I appreciate your help.