Apple Watch automation fails with 'Remote user isn't registered'

I have an Apple Watch SE and an iPhone 7, both running the latest OSes. I thought I would try a simple automation for the watch to turn silent mode on in the evening and off in the morning so I wouldn’t be wakened by a phone call at night. I set it up and when it ran, it failed with the error message ‘Remote user isn’t registered.’ Huh?

A search of Apple support turned up nothing. No surprise. I didn’t find anything in Apple discussion forums either. A general web search turned up a few mentions. I then understood that the ‘remote user’ was the Apple Watch. But what does ‘registered’ mean? I’ve never seen this word used in any documentation, Apple or otherwise.

Nothing like using straightforward language in an error message.

The few recommendations on the web were basically about rebooting, with one person saying he had to reset his watch and then restore from a backup. I rebooted the phone, but that got me nothing but pestered to enter my Apple ID password for the umpteenth time.

However, rebooting the watch has solved the problem, and the automation has been running successfully for several days.

One time, I also got the failure message ‘Cannot send with an inactive account.’ Well, ‘cannot send’ implies the problem is on the sending device, the iPhone. But what account? Apple ID? Mine is not inactive.

This error didn’t happen again, so it may have been in the interim between when the phone pestered me to enter my Apple ID password, and when I actually did that, with all the resulting headaches that causes.

Yesterday, I downloaded to my phone a third-party app that brings WhatsApp to the watch to my iPhone, then installed the watch app. Opening the app on the watch is supposed to create a QR code that you scan with WhatsApp on the iPhone to connect the two devices, as you would if you want to run WhatsApp on a Mac. The watch repeatedly failed to do that until, yes, I rebooted the watch. The connection worked.

So I guess anytime you need to set up a new interface between the phone and the watch, reboot the watch to get it to work.

I mention this here primarily to document it for others to find if they run into this problem.

2 Likes