Apple Wallet not working at checkout in stores

Hello. I have an iphone 6s plus with latest IOS and for some time, I have not been able to use “wallet” at any store. At first I thought it was only one store, but it’s any store that I go to. I used different credit cards and even deleted and added again. Any ideas?

Not sure I can help, really. I know certain stores I go to are very consistent about me being able to use ApplePay. Some are very consistent about me not being able to use it.

For a while, for me, ApplePay wasn’t working anywhere. If you haven’t done one lately, I recommend deleting the existing cards, doing a warm reset of your phone, and adding back at least one card. Then try it out at a store that has reliably accepted ApplePay in the past.

There also is the possibility that something somewhere got jostled in a drop/fall. Anything like that happen coincidentally?

Can you provide more detail about what “not working” means? How does it fail? Do the cashiers say that other people have used Apple Pay? Etc…

I’d really consider contacting Apple. There may be some failure with the NFC system (which I believe they can diagnose, even remotely if you can’t get a Genius Bar appointment), or they may have other steps you can try to fix it. I hear that trying to get support by chatting while using the Apple Support app in the App Store works really well compared with calling in, etc.

Today I down graded my iPone 8 Plus from the Public Beta to 13.5.1 after a long session with Apple Support. Went to try to pay for my dinner at the Takeaway and the POS refused to react. Both cards tried after they were reinstalled and verified by my Bank. Something here is broken. I made the suggestion to the support guy that it would be nice to be able to try a dummy transaction. Reply - ‘interesting idea’ PT

Thank you Steve. I will follow up. Appreciate your time.

When I hold up my iphone to the cashier’s pay mechanism, nothing happens. I have a few cards and try each one to no avail. I have tried other cards and gone to other stores. I deleted a card and added again. It didn’t work.

Yes. I am having the same problem. I am able to add cards but they just don’t work at any POS

There you go. I will try Apple support. Thank you.

You have not said whether paying with your wallet cards ever worked. You mentioned you were running a beta IOS when it did not. Had it worked before that?

Russell, I am using the latest IOS and yes, it worked before.
Thanks for asking.


A senior tech at Apple Cork has taken all the logs and screen shoots and sent them to engineering for analysis. Next chat will be on Tuesday

I’ll try to keep you posted


Mine only works 50% of the time. Took me three tries at one store this week. I think it is one of those technologies that is not end-to-end ready for prime time.