Apple Updates tvOS and HomePod Software to 15.5.1 to Address Music Bug

Originally published at: Apple Updates tvOS and HomePod Software to 15.5.1 to Address Music Bug - TidBITS

Apple has issued a small update for Apple TVs and HomePods to fix a bug that could make music stop playing.

1 Like

I didn’t notice any problems with 15.5 and, so far, 15.5.1 hasn’t introduced any problems. :crossed_fingers:

1 Like

I have been struggling with a very specific problem involving a HomePod for months and have spent many hours in conversation with Apple’s engineers in California, uploading all sorts of logs. I hope this update finally fixes it.

The problem arises when using Airplay 2 from the Music app to play music from my M2 MacBook Air to its internal speakers and the HomePod (original) simultaneously. It works fine at first but if I put the MBA to sleep, when it reawakes, music no longer comes from one source or the other and eventually the MBA freezes up completely. Only a restart gets things working again. They said they were working on a fix, so fingers crossed! I’m currently on vacation, so can’t verify it yet.

The Original Homepod suffers from irritating wifi issues. Try assigning a static IP address via your router settings. There are some more Homepod/wifi tips that I have assembled here:

(some tips are now out-of-date)

Homepod wifi issues …
I just installed a new wifi router because I have been having intermittent problems with my ISP Telstra-supplied device.
I thought I would be clever and disable the Telstra router wifi operation and assign the same SSID and password to the new router (which is connected to the Telstra router via ethernet).
That worked surprising well - my Macs, iOS and Homekit devices were connected straight away.
The only major problem that I had was that my Apple TV 4K no longer connected to stereo Homepods. I tried restarts without success. Then I realised that the Apple TV was networked by ethernet. I unplugged that cable and connected by wifi. It then found the Homepods and worked well.
I then plugged the ethernet cable back in and the setup still works - phew!
So… it seems that devices must be (initially) connected by wifi for linking to Homepods. This makes sense since it is Airplay.
Update 2: my wifi change has also affected iOS devices finding Airprint printers. I just found I needed to unplug the ethernet cable on one printer so it connected by wifi then I could print to it from iOS.

Just a quick update on my message last week:

Having now returned home and applied this latest update to my HomePod, it does indeed seem to have cured the problem I was experiencing before.

I have just found out that the Movie app is no longer working with Apple TV. It is a blank screen. The only way I can see “iTunes” movies is via the AppleTV app. Bizarrely the TV Shows (iTunes) app still works,

Strange you’re just seeing this: it’s been like this for me for a while now. (A couple of years at least?)

I don’t own many movies or tv shows, but I either access them from the TV app or from the computer app using Home Sharing. (And I haven’t done that for a while, either.)