Apple TV audio & HomePod Siri woes

The recent Apple TV update (tvOS 16.6) & Homepod OS update (16.6) have wrecked some audio features for me:
a) My stereo original Homepods no longer respond to any Siri requests (but a Homepod Mini still responds)
b) the Siri Remote Mute button no longer works and, for many ATV apps, the volume cannot be reduced to zero with the down-volume button (as as alternative to muting)

I am hoping this is not Apple neglecting (i.e. not beta-testing legacy hardware - the original Homepods) but it is also a concern that Siri Remote features are not working.

1 Like

Update: Homepod Siri problem solved! The update seems to have turned the Listen for Siri setting off. Switching it back on worked. :wink:

I’ve had this problem with the Mute button too.
Restarting the remote has fixed this issue for me.

Thank you for the link.
Unfortunately restarting the Siri Remote has not fixed the problem.
During my experiments I also switched the default audio output to the TV and the same issues occurred - limited volume control and no mute function. So the issue seems to be due to the latest tvOS.

Further experiments…
I realised that mute and volume control were only working on the right-hand Homepod of the stereo pair. Thinking the left-hand Homepod was faulty I replaced it with a spare Original Homepod. But that didn’t solve the problem.
So it is further evidence that tvOS has caused the problem.

1 Like

In Apple Discussions users are reporting the same issue with Homepod Minis so it is further indication of a tvOS bug.

I decided to reset the Apple TV. For now that has fixed the problem of volume control of stereo Homepods.
During the reset I came across an issue where the Apple TV did not recognise the Siri Remote - I couldn’t go past the first step of selecting a language.
Eventually I remembered the Apple TV came with an earlier remote model. Luckily I found it in a cupboard, charged it up and managed to get it to talk to the ATV. After the ATV was set up I connected the Siri Remote with this advice from Apple:

Perhaps I could have used this method at the start of the setup process?

Hmmm … the volume control bug reappeared for no apparent reason. I did another reset of the ATV and the first thing I did was pair the Siri Remote and that worked for setting up the ATV.
Downloaded and signed into various apps (again!) and tried to connect to the stereo Homepods. This time volume control was faulty but after restarting (not resetting) the ATV and Homepods volume control was restored.
BTW - the easy way to check for this bug is to press the Mute button on the Siri Remote. If one Homepod keeps playing then the bug is present.

The problem reoccurred for me this morning and I think I have found a temporary fix for my system.
Change the Apple TV default audio output to the TV (i.e. not stereo homepods)
Turn the power off for the homepods
Restart the Apple TV
Power up the homepods
Change the Apple TV audio output to the stereo homepods
Start playing some audio and press the mute button on the Siri Remote see check that both homepods are muted
If this doesn’t work try resetting the Apple TV.
Also try renaming the stereo homepods in the iOS Home app while they are not the default output