Apple Squashes Bugs with iOS 17.1.1, iPadOS 17.1.1, macOS 14.1.1, macOS 13.6.2, watchOS 10.1.1, and HomePod Software 17.1.1

Originally published at: Apple Squashes Bugs with iOS 17.1.1, iPadOS 17.1.1, macOS 14.1.1, macOS 13.6.2, watchOS 10.1.1, and HomePod Software 17.1.1 - TidBITS

If you have experienced issues with Apple Pay after wirelessly charging your iPhone 15 in your car, update problems with M-series MacBook Pros or the M3 iMac, Apple Watch battery drain, or Siri not paying attention on your HomePod, these updates promise to help.

I count on you to be pretty plainspoken since you are a technical writer at the core, but since I’ve been reading you for decades now, I have to admit it delights me when you drop it and crack wise every now and then, specifically the crack about flipping a light switch “like an animal.”

I totally laughed out loud at that HomePod remark. I never LOL, though.


…for everyone thinking about upgrading from Sonoma: macOS 14.1.1 ist still not compatible with GPG eMail encryption.

Guess it was BMW, not Lamborghini. Bummer.

Glad you liked it. I’m not a natural, like Andy Ihnatko, so I stick to when it feels easy. :smile:

I did find an issue with updating Original Homepods. A stereo pair that is default audio output for an Apple TV 4K got stuck updating. I found I had to disconnect them from the Apple TV and reset them in order for the update to complete. The system is now working as intended.
Another pair of Orginal Homepods that are not linked to an Apple TV updated without issues.
So my suggestion is to remove Original Homepods from the Apple TV audio settings before attempting the 17.1.1 update.

Howard Oakley has done some more digging on what changed in this update and why. Interesting read.



Thanks for the link to Howard’s article. I have an M3Pro MacBookPro arriving this week. It will be interesting to see what is actually installed on it.

1 Like

I’ve just received my new M3Pro MacBookPro. It was shipped on November 7 and was preloaded with Sonoma 14.1, which, I believe, was the current release at shipping time and is only 0.0.1 behind the current release.

I do a LOT of timers & alarms (helped by being able to use Siri to get them going). When iPad17 first hit I found an issue, the system would simply go dead for 5-6 seconds AFTER the timer ran out, then would play the wrong audio notification. 17.1 seems too now honor my selected audio notification but not the delay in sounding the alarm. I know it may seem silly to be kvetching about this (what is annoying is I use timers doing stretching exercises so the music stops then 6 seconds later the alarm goes off) BUT to me it’s indicative of their focus elsewhere. These 2 bugs have never existed before and I suspect I’m going too have to live with the delay.

I’ve just received my new M3 iMac (all the way from Shanghai, via DHL), and it was indeed loaded with Ventura. But I upgraded to 14.1.1 today without problem.

since upgrading my 2020 27" (16gb of RAM) iMac to MACOS 14.1.1 and my Apple Watch series 5 to 10.1.1 my watch will no longer UNLOCK my Mac. Any suggestions?

This happens to me frequently after running updates, particularly on macOS. It doesn’t happen with every update, but it does happen a lot. Really the thing that always works for me is toggle the setting off and back on. If toggling the setting back on gives an error message about not being able to contact the watch (rare for me), then try restarting (power off/power on) the watch (and the Mac if you want) and see if that fixes it.

1 Like

That worked. Thanks. I had to, in addition to restarting both my Apple watch and my iMac, sign my iPhone out of and then back into again iCloud. Annoying but at least it worked. Thanks again.

Apparently, there are wireless charging problems with some GM cars too.