Apple Releases iOS 14.5, iPadOS 14.5, macOS 11.3, watchOS 7.4, and tvOS 14.5

I haven’t seen that problem and we too have a Good Night scene that we invoke via the HomePod every night.

The big win of the new HomePod Software is that when we tell Siri to “turn out the dresser light,” there’s no more voice feedback saying “The dresser light is off.” That was always annoying because it was painfully obvious that the light was off.

So while scenes still get feedback responses, all standard on/off commands for lights at least just happen without feedback for us.

the update for the mac appears to fix a PDF print issue I was having. I print a lot to PDF, and in many apps, “Save as PDF” was causing a beachball or the app crashed. My workaround was to open the content in preview and save there.

Thanks for that Adam. I did the reset and its working as usual. You are lucky, as when I tell Siri to turn the livingroom on, the lights come on, and she responded, “Ok, the livingroom lights are on”. When I would say, Hey Siri, goodnite. She would say, “the scene is set, good nite”.
Cavaet: my setup is troubling in that both Homepods are located up on a beam (that has power receptacle). I had to remove the Homepods (reset) from the Home app, then unplug them. Then plug them back in, one at a time, then each would be discovered and I would setup, and assign to the “Kitchen”. Add the 2nd one this time was simple, when adding to same room, it suggested it I wanted Stereo option, I did, and can pick which speaker if L or R. I had to re-assign the voice (for fun, I had English (Irish) set) and all back to “before” the latest iOS update with update to Homepod 14.5. And UI had to do all this while up on a ladder.

My understanding is that Homepod Siri does not announce lights turning on or off if they are in the same room as the Homepod*. Maybe your lights or the Homepod were not set to the same room?

14.5 does seem to have introduced an irritating bug for me. I have an LIFX “reading” light in the lounge (same room as Homepod). When I ask Siri to turn the light on it responds that it cannot connect to the light. However about 20s later the light turns on.

There have been negative changes to Homekit. A few years ago I could set a time that a light remained on in Automation settings. I cannot find that feature anymore.

Update on iOS 14.5
Our two iPhone 8s seem to be draining the battery much more after the 14.5 update. I will monitor how they perform over several days as it might be that housekeeping from the update is causing the issue.

Ah, that does seem to be a refinement with HomePod Software 14.5 since it always used to give us feedback for lights in the same room. And it makes sense, since if the HomePod and the light are in the same room, you can tell the light is on or off, whereas you may not be able to if it’s in another room. I was able to confirm this room-based refinement this morning.

That’s still available to me for my outlets in the Home app (I have no lights myself.)

Not in same room. Using a Wemo plug in another room, “Living room” and setup in the GoodNight routine

14.5.1 is out. iTunes doesn’t see it, but my iPhone sees the update. This update fixes an issue with App Tracking Transparency where some users who previously disabled Allow Apps to Request to Track in Settings may not receive prompts from apps after re-enabling it. This update also provides important security updates and is recommended for all users. I think the active Webkit exploit is fixed in this…
Update: after connecting iPhone and iTunes not seeing 14.5.1, I manually started over-the-air update and now iTunes says update available. LOL.

My mistake - the Turn Off options appears when I toggle the accessory to “on”. Thank you.

14.5.1 already! I should have followed the tips elsewhere in these discussions to wait until the “.1” version of a major update is released.
When installing I briefly saw a message that the update was about 350Mb so at least it is not a complete replacement for 14.5.

I saw my first today (this was after updating to 14.5.1).

According to this story on 9to5mac, Facebook will be rolling out the tracking notification to users of Facebook and Instagram (and I assume WhatsApp) over the next few days and weeks, so you may not see it just yet. You do need to update to their latest version in the App Store first.

3 Likes

After upgrading to 14.5.1 this evening, I got the request as soon as I opened Facebook.

… and with the BBC app just now too.

I’ve been opening Facebook and Instagram daily purely to test this (and have made sure everything is up to date), and I still haven’t gotten prompts from them. I finally did get one from NextDoor and the Stealth Fitness app, and they appear properly in Settings > Privacy > Tracking now.

I also got it from NextDoor and a few other apps I mentioned, in addition to FaceBook. I didn’t get separate ones from Instagram or Messenger though.

And I just got one of those messages from Instagram.

By the way, I’ve been denying them tracking access in all cases. How about you all?

Hell yes. I can’t see any reason why anyone would ever knowingly allow an app to track.

4 Likes

If you don’t you might have to (bumm bumm bummmmmm) PAY FOR FACEBOOK. :flushed:

1 Like

Has anyone tried sharing music/video (some apple, some not) with and OLD (v3) Apple TV with these updates? I’ve kept my ATV updated, but currently running everything from Yosemite to Catalina and iOS 11 → 12.x

**Despite it’s warts, still I’m seriously missing iTunes in Catalina.

What’s the status of AppleScript in the Latest Big Sur version.