Apple Releases iOS 14.5, iPadOS 14.5, macOS 11.3, watchOS 7.4, and tvOS 14.5

Yeah…but as we all know…from both the woke PC aspect as well as the HW and SW aspect…Apple is gonna do what they’re going to do and rarely do they listen to us common users. It’s simple really…they know that they know better than us in all these things. They do a lot of things I find annoying like the PC voice 1 instead of male or female and the incessant from the top down espousal of progressive causes…but I don’t buy their products because of their political opinions…I buy them for the integration, privacy, and it just works (mostly) and because they’re way ahead of either Windows or Android in the things I care about.

Fair warning, I will delete any future posts in this thread that stray from the topic of the technical aspects of these specific operating system releases.

1 Like

In this article it says, “For example, if you open up an app like Facebook, you’ll see a prompt seeking permission from you to track your activity across other apps and websites.”
I haven’t gotten that prompt yet on my iPhone running 14.5. Anybody else see that?

I haven’t, but I have Settings / Privacy / Tracking / Allow Apps to Request to Track turned off. I believe you need that turned on in order to get the tracking prompt.

I do have that turned on. But no prompt. I wonder what the big deal was.

I don’t understand such things (and I use few apps), but is this what Joy of Tech is discussing?

1 Like

No, and I’m quite confused about it. I’ve opened (gingerly, since I consider them icky) every social media app I’ve ever downloaded and not a single one has asked to track me, even though I have that setting turned on as well.

So far no issues with any of the updates - Mojave, iOS, iPadOS, tvOS & HomepodOS. No noticeable changes with the user interfaces.
It is fortunate that Adam has documented the main improvements.
I did breath a sigh of relief when Homesharing continued to work with the ATV. I am always concerned that Apple will “neglect” it as it avoids paid streaming services.

I agree. Homesharing is essential to my Mac use.
Take that away and I would never upgrade again…On Mojave now, but a move to Big Sur is coming soon.

I updated to to macOS 11.3 (Mojave) a few days ago. This morning when I connected my iPhone (via USB) I was prompted to install additional Mac software in order to access my iPhone (from iTunes - although iTiunes was not open). This might have been associated with the security update that I installed yesterday ( Security Update 2021-002 Catalina and 2021-003 Mojave - #4 by andkim1974 ).
There was no explanation of the extra software update - just a prompt to install it.

I got the unexplained “software update” dialog on plugging in an iPad yesterday too, but it was before I applied the Mojave security update.

I think that’s the standard device communications update that’s necessary any time you update an iOS device and then connect it to the Mac. I saw it last time I connected my iPhone to the Mac too.

@ace is right. It’s required to get your Mac up to date in terms of syncing to an iOS device that’s running a newer version of iOS.

But it’s really annoying Apple doesn’t properly inform users about it and just throws up some generic yet unusual update panel. And because of that, this question comes up here after every. Single. iOS. Update. /sigh

It’s bad style too. In this day and age, you really don’t want to train users to install stuff they don’t have a clue about and don’t know how to vet (reminds me of corporate Windows drones users just clicking on every popup trusting that “IT” will keep them safe [and sane]). Apple should point out exactly why this is happening (could be as simple as iOS device got updated, so Mac now needs to follow) giving people the possibility to vet what they are being prompted about.

Not even the carrier settings update on iPhone (you know, the one that pops out of nowhere and offers no additional info, let alone how to get back to it later if you click no now) has been implemented this poorly.

1 Like

Ages ago (in pandemic time) I discovered if I just pull down the top of my mask to uncover my nose, FaceID works just fine. It literally takes half a second to pull the mask down, glance at my phone, and put the mask back. Since it’s got an elastic band, it just snaps back in place.

I do this 3-4 times while I’m at the grocery store to check my shopping list app, etc. I can’t imagine doing so increases the risk of covid spread in any way since my mouth is covered and that’s where most droplets come from. (Yes, I am touching my mask with my fingers, but I have to do that to put it on, so a few extra finger touches can’t be a big deal.)

I haven’t tried the new watch mask unlock yet as I haven’t upgraded 14.5 yet, but I’m not in a rush for that feature, especially since it doesn’t unlock 1Password.

It does - you’re breaking the seal, and possibly breathing in and/or out.

I wouldn’t worry too much about touching your mask. CDC says direct contact is not really the transmission vector it was once feared to be. Yet in spite of that, we’re still disinfecting like madmen (my university is particularly bad about relaxing this old habit), when what we really should be doing is focusing on distancing and masking, especially indoors.

Pulling down your mask, however, is probably not a great idea, especially indoors. Even if it’s only for a brief moment, that is nevertheless opening up the number one path to infection.

There is no seal – it’s a disposable mask. And I don’t breath in or out while I’m doing it, and it’s probably not even half a second – very fast.

Before the latest tvOS, I was using a particular resolution in the Apple TV settings: 768 vertical, to avoid overscan. Since installing this tvOS update (14.5), that resolution is no longer available to choose. I noticed that there was overscan, because Netflix etc menus were being cut off at the sides. None of the available resolutions/frequencies prevents overscan on this TV.

It’s an old hand-me-down 30" LCD TV, so more recent TVs are probably safe. Apple TV 4K first generation. I’ve tried the Reset Video Settings function.

I have had similar overscan problems with a projector connected to TV 4K for a few years. The (un)helpful ATV prompt is to adjust your TV’s settings. Fortunately I no longer use Netflix so it is not a big deal for me - but irritating.

:neutral_face: Anyone else have issue with HomePod after iOS 14.5 update? I’ve two HomePods (for stereo sound) and after the update, that night I tell Siri to run Good Night (lights out, she says Good night). Since, it doesn’t work, and Siri responds, I am having some difficulty, one moment… this goes on without no further feedback or indication. Even Home app isn’t indicating (found the restart Home pod but doesn’t help). I resolved it by power cycling both Home Pods.
When updated from iOS 13.x to iOS 14, the same thing happened and resolution was- powercycle.
Well, that was short lived. Asked Siri about weather and nothing…working on it. There seems to be a problem… sigh.
Helpful Apple Homepod link,