App store "Update All" missing

Another puzzle with the new iPhone SE:

Even though all settings are identical (uploaded to the new phone directly from the old phone), the new model’s App Store app doesn’t show options for updating my many apps. The “Available Updates / Update All” option doesn’t appear at all. Compare these two screenshots. (Note: I’ve tried it with “Automatic Downloads” enabled and disabled. Cellular data is enabled for the App Store on both phones. And I’ve restarted several times. And I’m signed in on both phones.)

Any counsel, wise folk?

On both my iPhone 11 Pro and iPad Pro, I have found that I often need to force a refresh of the account screen to see the latest updates. For example, just before typing this message, I accessed the screen on my iPhone and saw no recent updates. After forcing a refresh (a quick downward drag of the window), 59 updates became available,

1 Like

Same here.

And I’m afraid to many users, downward drag may not be obvious. It’s for sure by far not as obvious as an ‘Refresh’ button. But Apple seems to detest those.

Hah! That worked. (Why’s this necessary with the new, but not the old SE, I wonder? Did I miss a setting somewhere?)


I’ve always detested “drag to update”. First, as Simon says, it’s not at all obvious in general, and once you learn about it, it’s still not obvious on a per application basis, you have to remember to try it when an application doesn’t seem to be working. It’s particularly bad in App Store IMO, as the place you have to do it isn’t the normal “list of items” page, like Mail or Twitter. And on “list of items” pages, I find I inevitably end up tapping on an item until I figure out the right place to tap, how long to hold, and how far to drag (all of which I have to figure out again next time I use it). I can only imagine how frustrating such pages must be to people with motor control issues.