Anyone else having major problems after updating to Firefox 85?

I updated to Firefox 85. Since then, at random times, if I quit Firefox and reopen it, it will freeze with a spinning beachball, and I have to Force Quit it. I have already followed the steps to “Refresh Firefox”, but it still happens.

With the help of a Firefox help article, I have found a fix, but it is only temporary, and I don’t recommend that anyone else try it unless they know what they’re doing. I have to go into my Firefox profile and delete any files or folders whose names begin with “sessionstore”. It is very strange. Before I shut down for the night last night, I opened Firefox again. It worked just fine. I closed it and shut down.

When I booted back up this morning, I thought Firefox was going to work, but it immediately froze once more. I am wondering if anyone else is seeing similar behavior with Firefox 85. If not, the next thing I need to do is figure out how to export all my bookmarks and start over with a truly fresh profile. Something is clearly corrupt, but I’m not sure what.


PS: Forgot to mention I’m still on 10.14.6, just as a data point.

I’ve been running Firefox 85.0 without any problems so far. Sorry I’m no help. (I’m on Big Sur 11.2.)

I’m also having no problems with Firefox 85.0, so it does sound like you have something corrupted. On exporting/importing bookmarks, Firefox has that builtin. Choose Show All Bookmarks from the Bookmarks menu. At the top of the window are three menus, the last of which is an up arrow and a down arrow. Click on that, and you can backup and restore bookmarks, and also export and import bookmarks to HTML. I haven’t tried any of those so you’ll want to experiment before deleting the problematic profile, but hopefully they’ll work as expected.

No worries. :slight_smile: It’s probably just me, but I wanted to see if anyone else was experiencing it, just in case.

I have been having the same problem with the last 2 or 3 updates of Firefox. Have to force quit. Then it won’t restart again until after a restart. Thinking it is actually Catalina cause I have a little other random funkiness. Late 2015 27" iMac. Going to upgrade to Big Sur probably this weekend

I’ve had no problems with FF, neither now, on Catalina, nor before.

I use Firefox, and it sometimes locks up in macOS but not in Linux. Have you tried running it in Safe Mode to eliminate bad extensions or other variables?

You should also be aware that Mozilla is a mess behind the scenes. They recently laid a bunch of people off. I saw just last night that one of their developers is leaving for the Safari team at Apple. I’m holding on for now because of the excellent cross-platform sync and the fact that the mobile version lets me use a custom search engine.

Adam and I really like Brave, which is a fork of Chrome without the Google stuff, and a built-in adblocker and other privacy features.

1 Like

While I occasionally use Firefox, most of the time I’m satisfied with Safari. I’m curious about why you prefer Brave over Safari.

I will hold off updating Firefox but that means I will get the nagging update notification window over the Firefox window. It appears several minutes after starting Firefox which is all the more annoying. Firefox forums have tales of people trying to disable the notification, without success.

I do use Safari most of the time but it also has a bug where it sometimes freezes when I try to do a File Save As for a displayed PDF file (I find it best to open PDFs in Preview and then save them).

Hi @jcenters,

Your reply inspired me to try Safe Mode, which ended up having no effect. Interesting to hear of the turmoil at Mozilla…so sad. I like Brave a lot, too, and if I switch, that’s probably where I’ll go. Given the number of people replying with no problems with Firefox, I assume it’s just a corruption of my end. I have exported my bookmarks, and will try creating a fresh profile.

I wish OmniWeb were still under development… I was also a fan of the original Opera browser, with its proprietary engine. It’s nice to see Vivaldi carrying the torch, but it’s a shame that it’s related to Chrome, like just about every other browser these days. There’s also iCab, but it has some rough edges.

1 Like

Might be a corrupted or damaged Firefox user profile based issue. Create a new macOS user account and test Firefox there. If the problem goes away then it’s something in your user data that’s damaged. If you use a FireFox sign-on account you can likely nuke everything and start fresh and your user settings will download when you sign in again.

~/Library/Application Support/Mozilla
~/Library/Application Support/Firefox

Then re-install Firefox, launch it and sign back on and hopefully the issues go away. You could alternatively just delete the Library files and that might be enough to fix the issue but a full removal and re-install is just as easy.

If you don’t sign-in to a Cloud FireFox account, backup the Library files and then you’ll have to try to import the data back, etc. which can be frustrating. Might only be able to import the bookmarks then need to re-install your extensions and redo your configurations, etc.

I used to make it a point to try Safari with every new macOS release, but I’d always find something that didn’t work as expected. And now that Apple has locked down extensions and limited ad-blocking extensions, I don’t even bother. Chrome is much more robust, but I dislike Google and their spyware. Brave does everything Chrome does minus Google’s spyware, and it adds additional privacy tools like a built-in adblocker and anti-fingerprinting.

You know how Safari now shows statistics about all the stuff it’s blocking? Brave was doing that years ago. :slight_smile:

Making a new macOS user account seems a little extreme for this. I did, however, make a new Firefox profile, and the problem hasn’t shown up since. It would seem that I have found the definitive answer to the original question of this post. :slight_smile:

I tried Brave, but ended up going back to Firefox, because of a number of little things, and one big thing.

  • Things didn’t get off to a good start during the import phase of the initial setup. Brave recognized I have two Firefox profiles, but the list just contained Mozilla Firefox twice, with no way to tell which was which. While this is a one-time thing, and it’s easy to do another import, it’s an annoying bit of sloppiness (particularly when the import initiated after setup does differentiate, so they obviously recognize it as something needed, and have code to do it, so why not on the initial import?)
  • On both the initial import and subsequent import, it said it imported passwords successfully. That was a little frightening as it hadn’t asked me for my Firefox password. But looking at the logins it had, it hadn’t actually imported anything. Even if I just import passwords, it reports success without actually doing anything.
  • In Firefox, Bookmark toolbar bookmarks have their own folder. Brave appears to just put the first few bookmarks on the toolbar, so any bookmark on the toolbar appears again in the bookmarks menu. This would be fine if they were at the bottom, but they’re not, so I have to skip over/scroll past those redundant bookmarks when I want some other bookmark.
  • Because Brave doesn’t put the toolbar bookmarks into the toolbar, I figured it would be easy enough to drag the 20 or so I have into the toolbar. That worked for the first few, but then all of a sudden I can’t move folders any more. Neither drag and drop nor copy/cut and paste worked. No idea why. Even creating a new folder and dragging the contents doesn’t work for subfolders, so I’d have to basically duplicate the hierarchy I’m trying to move by hand. Even though it’s a one time thing, I’m not sure I’d want to go to that trouble.
  • The toolbar has an Other Bookmarks item on the right end, taking up space. None of the workarounds I found on the web worked for me, so I have a useless folder taking up valuable toolbar space.

Those are all kind of minor things that I could either get used to or were one time things, but the biggest problem is the adblocking. It’s too coarse-grained. You basically have none, some, or all, with some the default. The problem is, on some pages, some blocks important stuff, and there seems to be no choice but to turn off blocking for that page. As basically every page on the web these days talks to Facebook and Google, that’s not something I’m willing to do. The blockers in Firefox have much finer-grained control, so if I find something’s blocked that I want to see, I can unblock that domain, while leaving all the vast plethora of trackers blocked. That’s a showstopper for me and Brave.

I only worked with Brave a half a day or so, so it’s conceivable I missed some things that would have made it work better for me, but at some point it just wasn’t worth fiddling with.

Thanks for the feedback :blush:

I can’t say I ever used a context menu to open a new window, but look what was just fixed in 85.0.2:

Sounds very similar even if it’s not exactly identical to what I was experiencing. Still hasn’t happened again since the new profile.

Having saved my old profile, I can confirm that 85.0.2 does fix the issue I was having that prompted me to start this thread. I could not make the old profile, which I formerly thought was corrupt, freeze, no matter what I threw at it.

1 Like