Any chance to get DVD shared to Ventura?

I just realized DVD Sharing still works great from an old High Sierra Mac I have lying around, but my modern MBP running Ventura will not offer up that shared DVD. Is there any workaround to allow a Ventura Mac to access a DVD being shared by a much older Mac?

Or by a brand new one with a Superdrive?

I haven’t tried a DVD (Bluray) drive attached to an iMac running Mojave but I do have mixed success accessing any drives on that iMac from a Macbook Air running Ventura. Sometimes it works, other times the wheel spins indefinitely! No pattern to it.
I will try the DVD drive, now that you mention it.
On a related topic, I don’t suppose I can access the DVD from an AppleTV but will experiment.

BTW - Mojave system settings need to be adjusted to allow DVD Player to launch when you insert a DVD. It plays on that iMac but there is no way to share it to other Macs (or an Apple TV).
The iMac also opens CDs, DVDs and Bluray disks that have data, not video. But this does not appear on the IMac drives listed in Finder on the MBA/Ventura. So I have the same issue as you.

Similarly, for Ventura I found you need to plug-in the DVD drive directly (I had to use a USB-A to USB0c adapter), insert a DVD then go to System Settings and choose to open the DVD with DVD Player. Otherwise the CD/DVD choice does not appear. I did this but DVD Player did not open so it seems I cannot play DVDs on my MBA running Ventura! Neither does a a data DVD show up in Finder. That is a concern as I use Bluray disks for critical data.

I suppose this could be due to my USB-A to C adapter but I suspect that support for DVD/Bluray has been overlooked by Apple :face_with_raised_eyebrow:

Updated update: I tried the DVD drive with my adpater and the USB-C port on the iMacv (Mojave) and it also failed to open in Finder. Maybe the DVD drive needs to have a USB-C/Thunderbolt cable to work?

This is new to me. I have a MBP 13" Early 2011 (which is stuck on High Sierra) acting as a server for a lot of drives with movies and all my photography. It has an optical drive built in and shares CDs and DVDs. I have a later (not sure which without starting it up), MBP 15" all set up and ready to replace it when it fails. I can plug in a Superdrive for optical disk sharing, but…looking on this MBA also running Ventura, there is no CD or DVD sharing. There is an option for ‘Media Sharing’ but I expect this is only for items stored in Tunes.
Can a mounted optical disk be set to be a ‘Shared Disk’ and then mounted on a remote Mac?

On my 2012 Mac Mini running Ventura, inserting a DVD brings it up on the Finder and then I open the DVD player to watch. I have an LG Blu-Ray burner USB 3.0 plugged directly into the computer.

There is a setting for CD/DVD sharing in Ventura but I’ve never tried it and I think that’s what the OP was referring to above:

Hmm. I have no trouble accessing data disks using either a Super Drive or a generic OWC Blu-ray player connected to either my M1 Air or M1Mini (both 13.2.1) using a USBA-C adaptor. DVDs might be a different story–none handy, though. If I did have one I’d try using VLC, since I no longer have a copy of DVD Player.

No, other way around.

DVD drive works just fine as is on HS system. Disk shows up and all. Sharing is on and works. To HS or Mojave.

Problem is, Apple says no sharing TO Ventura and that’s the problem here.

I’m wondering if there’s perhaps any 3rd party software or tricks that will preserve that functionality even on modern systems like Ventura/Monterey/BS/Catalina (all excluded according to Apple). See the Apple doc I linked to above.

Again, sharing to, not from. From is fine. Even on modern systems.

I only have a few old PowerPC computers with a disk drive so I shared a DVD from one and accessed it from Ventura and it recognizes it and starts playing but breaks up as I assume the older computer from 2005 can’t process the video fast enough but my 2012 Mini running Ventura can access the shared DVD. Is this what you want to do?

Apple’s doc spells out at the very top that this doesn’t work for 10.15 or later. And indeed on the two Ventura systems I tried, I could not mount the DVD even though the Mojave Mac that DVD was mounted on clearly showed up its other shares.

Note: You can’t access a shared optical drive on a computer with macOS 10.15 or later installed.

1 Like

I read the document and I told you what worked in my experimentation but the OS hosting is 10.5.7 so not usable for most.

Thank you. That doesn’t appear on my MBA M2, but maybe a Superdrive has to be plugged in for it to show?

That’s the case.

That would be correct. This article illustrates the issue:

1 Like

I have a Mac Studio running Ventura. It is true that SuperDrive does not work on this computer, nor does a Firewire DVD burner connected via triple-adapter string (FW400→Thunderbolt2→Thunderbolt3/4). I have to use a 2009 MacPro or 2015 MacBook to grab an image of the disc to external hard drive, then I can work with the files on my Studio. Crazy and terrible loss of an archival storage medium, but I think the planet’s rulers need data to be mutable.

Wait–a SuperDrive doesn’t work at all with a Mac Studio/Ventura? I got a SuperDrive when I got my Mac Studio, and I hadn’t used it until today, when I had problems getting it to import a CD into the Music app. I had assumed it was a bad CD.

If it isn’t going to work, is there some alternative? I did not get all my CDs imported before I got this computer, and I still do occasionally get new CDs, so this is a pretty important use case for me.


Dave, I wasn’t able to get my SuperDrive from work to function, but maybe that was just a problem with the disc I tried. I have recently moved, and hadn’t tried my LaCie external DVD burner. It does in fact work, at least on the commercial disc I just tried in it.
I believe the difficulty with the SuperDrive is in the connection with the Studio. According to some research I had done a few months back, Apple made the SuperDrive require special power? or signals? from the computer to which it’s attached; I think it was something to do with power. And it doesn’t get that power from newer computers.

In principle it should work just fine on any USB port because it requires only 0.45 Amps at 5 V. Nevertheless there have been countless reports of the drive only working when plugged directly into a Mac or using specific adapters.

Apple mentions only 3 USB adapters that they claim work.

Many more details courtesy of @glennf right here:

Mine works just fine attached to my M1 Mini directly or via my Studio Display using either a JSAUX or Anker adapter.

An update: I got a replacement copy of the CD and it imported on the SuperDrive with no problem.

So at least in this case, the problem was with the disc and not with the drive.