Adding Yahoo Mail to Mac Mail

My ISP recently transferred all email accounts to Yahoo. Setting up a Yahoo Mail account worked OK for Web mail but Mac Mail will not enable this account. All different methods to enable Yahoo have been unsuccessful.

Any new ideas to try?

What OS are you using? Did you go to the internet accounts setting under system preferences? IMAP or POP?

OS is Sonoma 14.4.1. Account set up is IMAP.

OK. You need to get an app key which is similar to a security key in order for the account to work with Apple Mail. This link indicates the steps:

I recently went through this but I was setting mine up as a POP account. I didn’t think that IMAP needed the app key but if you can’t get it to work with your regular password, then you need the app key. You start the setup under Internet Accounts under System Settings not in Apple Mail.

Many thanks! I’ll give that a try.

Well, unfortunately that didn’t work. I’ll have to try something else.

Many thanks! I’ll give that a try.

Apple says they have built-in support for Yahoo mail:

If that doesn’t work and you want to manually configure the IMAP/SMTP parameters (via the “Other…” account type), this is Yahoo’s page with the settings:

Note that those instructions ask you to use an app-specific password, since IMAP won’t use Yahoo’s web-based authentication service. This page describes how to create and destroy app-specific passwords:

Best of luck.

1 Like

I’ve tried both of those with no luck.
Several years ago, when I added a G Mail account, it went on with no issues.
Now Cox has dropped e mails and turned everyone over to Yahoo e mail accounts and it hasn’t been smooth.
Both Cox and Yahoo support have been useless. But I’ll keep trying to come up with a solution.

I would try again to get the app key as mentioned in my post and Shamino’s. The other possibility is to try and change your main password but then you would have to reenter it in your other devices. You may still have the Yahoo account on your computer even though it didn’t connect fully so make sure to delete that one first. Then, try to make a new one.

I had similar issues some time ago with my ATT accounts and the only thing that worked was getting the app key/security key using their web page. My main password only worked when getting mail in Safari or other web browser.

I had a problem with Yahoo Mail a few months ago where macOS Mail suddenly stopped connecting with Yahoo Mail accounts.

If I remember correctly, I ended up doing this to reestablish service (this was on either Monterey or Ventura):

  1. Delete the affected Yahoo account using System Settings/Internet Accounts/Yahoo Account Name
  2. In System Settings/Internet, click the “Add Account” button
  3. Click the “Add Other Account…” button
  4. Use the IMAP settings provided by Yahoo, as mentioned earlier in this thread, to add the Yahoo account to macOS (I don’t remember if I had to use an app key).

Thanks. I’ll give that a try.

I tried that a couple of times but still no luck. Yahoo web mail works fine. Yahoo on Mac Mail remains inop.

Did you get an app key?

EDIT: I realized just now that one of my ATT accounts was not loading any emails on two of my devices since yesterday but was working on two other ones for some strange reason. So you might just want to try again since I definitely had some sort of connection issue although I was not getting any error messages but the emails were not downloading.

I have someone from Apple technical Support that is going to call me tomorrow to work on this. (They would have called today but I had to be out.) If I learn anything from them I’ll post it here.


After about an hour with an Apple tech guy, and using a Yahoo app key, I got about 10 Junk Mail items to appear. Nothing else. So still working on it.

Well, the 10th time was a charm. It appears that I’ve finally figured out the Yahoo/Cox swap over roadblock. Mail - Add Account - Other - use old Cox email ddress - be sure to enter - use the special 16 letter pass key (that hadn’t worked until I changed the IMAP and SMTP addresses). So far it seems to be working. I hope that it continues. Glad to try to help any others that have this issue in the future.

1 Like