A Mail oddity - or is it just me?

Here’s the situation.
My workhorse Mac is still running Snow Leopard. It works fine for what I want/need to do. O(run CS3 and AppleWorks)
However, Mail will not send any email. There are 12 accounts; 10@mydomain & 2@otherdomains.

All accounts receive emails without problems but not one account will actually send.

An adjacent Mac has one of the @mydomain accounts and will send mail.
A Macbook Air has a different@mydomain account and sends and receives as expected as does an iPhone and an iPad with the same account.
A separate iPhone has the same 12 accounts as the workhorse and it sends without a single problem
The SMTP settings are identical in every case.
I have another iPad who I do not use for email at all but - if I set up any one of the 12 accounts on it they work as nature intended.
What could possibly be wrong with the workhorse? the iPhones kept sending when the Workhorse suddenly stopped.
The only clue from connection doctor is that the selected SMTP port is incorrect. But as the others are all set to the same port…?
Any help would be appreciated. It’s a bit tedious writing long replies on my phone.

When you say the SMTP settings are identical across your devices, are you referring to both the receive and the send settings? I can’t remember what it looked like in Snow Leopard, but when I have mail send issues, I always check the outgoing mail server settings carefully, and I remember sometimes it wasn’t obvious where they were.

Assuming that’s not the issue, have you tried changing the outgoing mail server setting to one you know works (like iCloud, or Google Mail)? They may not actually transmit the message (depending on their cross-domain settings) but you at least should get a different error message, which might put you a little further along the path to a solution.

Snow Leopard is limited to using older versions of SSL and TLS. Most email providers have stopped supporting the older versions for security reasons. Since you can receive mail your provider may allow the older SSL for receiving but not for sending/SMTP.

Sadly, I gave up using Snow Leopard because of this. FWIW: Mojave on my MacPro4,1 flashed to 5,1 is very reliable.


This is probably the reason. I recently ran into a similar problem with an older 3rd-party email program because it did not support current versions of TLS.

Could this be why my old @me.com email address stopped working for sending emails but I can still receive them (if I reply to these I have to remember to change @me to @icloud)?

Did you ever try to use an older version of the Thunderbird email program? As others have mentioned, protocols have changed but some of those older versions were ahead of Apple Mail so that might be useful in your case. Version 45 was the last Thunderbird release that might work:

I mentioned in another thread the issue I had with ATT (Yahoo) mail when they updated their security protocols and at that point, I couldn’t use Apple Mail on an old PowerPC computer which worked fine until that change:

1 Like