2015 Retina MBP Mojave Boot ROM version

Can somebody with an up to date Mojave installation on a 2015 Retina MBP tell me what the boot ROM version is in System Information?

Mine is MBP114.0182.B00. I replaced my original 512 GB Apple SSD with an OWC Aura Pro X 1 TB last April and it successfully updated through the various combo updaters for High Sierra, the Mojave installer from September last, and the 10.14.x Combo Update installers through 10.14.2.

Tried to install the 10.14.3 Combo Updater today and the updater said that it couldn’t be installed on this disk. OWC told me that I needed to reset the SMC…which I doubted but did it anyway…no ROM update and still no 10.14.3.

I was able to update to 10.14.3 using Software Update in System Preferences…but that didn’t change the boot ROM version either.

I’ve got the original SSD from Apple in an external USB OWC case…it’s still on High Sierra soI’ll try updating it to Mojave and see if that makes any difference…but in the event it doesn’t and the ROM needs updating any idea how to go about it? I would hate to have to put the original SSD back in just to get things right.


I googled your boot ROM version and found that it’s a detail included in Geekbench results, there was even a Mid 2015 MBP with that ROM version running 10.14.2. So then I used google to search Geekbench for macOS 10.14.3 15-inch Retina Mid 2015 and found one result: MacBook Pro (15-inch Retina Mid 2015); its ROM version number is very different, That numbering more like the ROM in my 2016 MBP’s running 10.13.6 (without Security Update 2019-001),

I don’t see why the hardware of your internal drive should matter unless the firmware update is only needed if you have the Apple-provided SSD (i.e. it corrects a problem that doesn’t affect other drives). What if you booted from an external drive running 10.14 and installed 10.14.3 from the App Store? That would give it another chance to check and update the firmware, if necessary.

Oh, the boot ROM number shown by System Information.app is not the “real” number anymore. High Sierra and newer has a tool, eficheck, for checking the Mac’s firmware. There are a few parameters for the tool but the only command anyone should really need is this one:

/usr/libexec/firmwarecheckers/eficheck/eficheck --integrity-check

For My 2016 MBP the output is EFI Version: MBP133.88Z.F000.B00.1809171523.

Which EFI firmware should your Mac be using? (version 3) lists the “EFI firmware versions supported in the last Mojave update 10.14.3, and following installation of the High Sierra Security Update 2019-001 or Sierra Security Update 2019-001,” i.e. has all the updates released so far.

Thanks. I will try a few more ideas I’ve got…but apparently (at least according to OWC), I need to reinstall the original Apple SSD and update it, then out the OWC one back in. I tried updating the App,e SSD in am external USB3 case and it did not update…so apparently there’s some issue with OWC. I’ve asked them as well.

I will check that out as well.

There is an error in the Combo Updater in that the distribution check omitted the 10.14.2 release build number. It doesn’t have anything to do with your boot Rom.

The MAS version distribution is correct, and does contain the Rom Update package, so it should have either updated yours or found it to be current. Also, the EFICheck runs automatically and would alert you if anything was wrong.


1 Like

As @alvarnell says, many people have been unable to install the Combo update, but have successfully installed the Delta update, then successfully used the Combo updater.

FYI my 2015 Retina MBP (original hardware) macOS 10.14.2 reports:
System Info - Boot ROM Version:
Terminal eficheck (using the command quoted by @cwilcox ) - EFI Version: MBP114.88Z.0185.B00.1809171422

Just to finish up…there’s a discussion over on Macintouch about this as well…and installing the delta via System Prefs and then running the Combo afterward said the Combo would install although I didn’t actually do that yet. The Combo updater also failed on on my Mini so apparently there’s something amiss with the Combo Updater. I’m downloading a fresh copy to see if they replaced it.

Running the terminal command Curtis suggested gives me the following:

EFI Version: MBP114.88Z.0182.B00.1802270937

Matching allowlist not found in EFIAllowListShipping. Searching in EFIAllowListAll.

This system does now allow downloading background update data. Canceling.

Primary allowlist version match not found for version MBP114.88Z.0182.B00.1802270937.

I’m not sure exactly what that output means…either there’s a ROM version missing from the Primary allowlist…or mine did not get properly updated somewhere along the line. The EFI version in the first line sort of but not exactly matches what System Information gives me…which is MBP114.0182.B00.

I found an article at https://eclecticlight.co/2018/10/31/which-efi-firmware-should-your-mac-be-using-version-3/ that references what the EFI versions should be but it doesn’t really talk about how to get the most recent version if you don’t have it…perhaps running the Combo after the Delta updater will fix that…I’ll go and check.

Later…nope, the Combo Updater run successfully with 3 or 4 different reboots so I was hoping it would update the EFI but I get the same result from terminal as I did above…and according to the eclecticlight link above I should have MacBookPro11,4 (0185.B00.1809171422).

It would seem the result that I bolded above, is somehow the root cause of your problem. Howard Oakley found that the “EFIAllowListAll” must be dynamically downloaded and checked during the Integrity Check process. It’s posted to the same Software Update catalog as all other MAS updates, but as stated isn’t kept up-to-date on your computer. I suspect that it’s also downloaded and referenced during OS updates (which, as mentioned earlier, always contain appropriate EFI updates now).

So the question is, why isn’t your MBP able to check MAS Software Updates during an OS update? Are you disconnected from the Internet at such times or is something else preventing you from getting necessary EFI information?

And as to your last points, both the delta and combo updates do contain the correct EFI update for your MBP11,4, so not surprising that both gave you the same results. Just need to get to the bottom of why you aren’t able to access the current “EFIAllowListAll”. Check System Preferences->App Store and make sure you have both “Automatically check for updates” and “Install system data files and security updates” enabled.

I’ve normally got internet access…just checked and System Preferences says I’m up to date. I’ve got check for updates, download updates, and install system data files and security updates checked and install macOS updates and install app updates unchecked so I can do those manually…we live full time in our RV and I need to make sure that those only happen when we’re not on our metered MiFi bandwidth and on campground wifi instead.

I used to have download updates unchecked…so I checked it and rebooted and then checked system preferences again.

I agree…but I’m at a loss as to why the EFIAllowListAll check isn’t working correctly.

I do have a 1 TB OWC SSD in the machine…but it was replaced back in April after I updated the original Apple SSD to High Sierra and several point updates past there. I cloned the original SSD to the OWC one before swapping it out. Then the update to Mojave and all the point updates up through .2 worked but .3 combo updater failed…I always download the combo updater since I have 3 machines total to update and limited/slow bandwidth most of the time…been doing it that way for probably 6 or 7 years at least.

I’ve got the latest Mojave installer is 10.14.3 downloaded…maybe I should try reinstalling that over the top of why existing installation to see if it helps.

I’m going to send yet another request to OWC to see if they know the solution as well.

I really hate it when you’re the computer guy and things don’t work right:-)