1Password 8.7.1

Originally published at: 1Password 8.7.1 - TidBITS

Wide range of improvements and bug fixes for the recently upgraded password manager. ($35.88 annual subscription, free update, 2.9 MB, macOS 10.15+)

1 Like

It’s subscription-based annually or monthly?
Also, I hear rumors that vaults are in the cloud not stored on my Mac’s HD. Is that true?

Yes. (Meaning that it can be either; paying monthly pays more, assuming that you use the app for 12 months.)

Also, I hear rumors that vaults are in the cloud not stored on my Mac’s HD. Is that true?

Not really true. Vaults are cached locally, so they work if you are disconnected from the internet. But there is no File | Open command to open a local vault - you must have a subscription to open a vault/multiple vaults.

The last few days, I’ve been working with an AgileBits tech on problems with 1Password for Mac 8.7.1 (the most resent release) not autofilling in Safari Version 15.5 (17613. - the most recent version, in Monterey 12.4 (21F79) - the most recent version. Had this problem as soon as upgrading from 7 to 8.

1 Like

So none of my Macs say v.8 is available for download as an update (all still have 7.x). Are they sandbagging the rollout, or do I have to explicitly go download it from the website?

1 Like

Same. I explicitly downloaded it. In fact, the iMac where I didn’t download it just got another update on Friday to 7.X (7.9.5 IIRC.)

1 Like

Yea, I mean the App Store still has 7.X and no trace of 8.X. Seems almost like they’re still treating it as beta?

1 Like

1Password for Safari?

On another note of confusion, in spite of discussions I’ve had with AgileBits, I still don’t get why they have a separate product “1Password For Safari”:

And then there’s the Safari Extension. When they’ve had me troubleshoot, the steps involved in enabling/disabling and installing/uninstalling has left my head spinning. Not to mention the fact that the 1P when you log in via Safari seems now to be completely disconnected from the app (eg, I may have logged into one, but I’ll still have to log into the other). Seems to just be getting worse with time and they don’t seem to care.

1 Like

And here’s what you have in Chrome:

How do I choose?? And this is after you select 1Password > Install Browser Extensions… which only takes you to Safari. Did it do something for Chrome at the same time? If I do that, do I still have to choose one of the options above, too?

It’s a total cluster of confusion.

Right, and then I copied the URL from Safari and pasted it into the address bar in Chrome (and Firefox) to get the proper extension.

It’s rare when I need the app actually open. I just use the control that shows up in the userID and/or password fields in Safari almost every time.

And that’s the way it’s supposed to work. But very, very often (most of the time?) that is broken. Clicking on it does nothing. I reached out to them a number of times over the years before they finally admitted it was a known and ongoing issue:

The issue you are describing is indeed an ongoing one that we’ve been battling for a long time. Without getting into all the technicals, the issue is rooted in how Safari is supposed to relaunch extensions and re-establish connections with the apps they are associated with, but often doesn’t. We’re working with Apple on this for quite a while now.

The quickest workaround is to restart 1Password itself (and Safari as well if you can), like so:

Right click the little 1Password icon on the top menu bar of your Mac (where the clock is) and select “Quit 1Password Completely”.
Quit Safari by right clicking its icon in the Dock and selecting “Quit”.
Open and unlock 1Password.
Open Safari and test if it is working properly.
No need to restart the computer or uninstall/reinstall the app. A quick restart to the 1Password desktop app and Safari would get them talking again.

They claim 1Password 8 and the Safari Extension are supposed to be better at handling this, so I should probably withhold further judgment until I try that out. But I figured there was a reason they hadn’t pushed it to me yet (or sent an email, or presented it in the App Store, or anything), so I have not explicitly installed it. I don’t need, for example, my password database getting corrupted because there are known issues.

By the way, I could have sworn that early on, 1P provided some type of non-Safari extension management. Either at installation time it detected or asked you to indicate which browsers you used and then helped manage the process to getting their extensions up to date. For some time now, they started this “Safari only” advertising, and you have to do tricks like you described to get Chrome updated, noting the confusion even there that I posted above.

Anyway, I will reach out to them and ask what the story is with 1P 8 and let you know what they say.

Well, when you open preferences in 1Password and click “Get 1Password for your browser”, it just opens your default browser, which is why it is opening Safari for you. When I changed my default to Chrome and clicked the button it definitely opened the link in Chrome.

Not sure what you’re referring to. The closest thing under Preferences is this:

which is not what you describe. Perhaps this “Install Browser Extensions…”?

And that’s what takes me right to Safari, my default browser. But what about Chrome, my “other” browser? It says “extensions”, not “extension”. And like I said, it used to manage setting up 1P in all your browsers, not just your default.

Anyway, waiting on a reply from 1P about 8.X.

I thought you were running 1Password 8 (based on the subject line.) They’ve replaced the “install browser extensions” in the 1Password menu with a setting in the browsers sections of app preferences. But I still have version 7 on my iMac, I just tried the same change of default browser to Chrome, and hitting “install browser extensions” opens the page in Chrome, just like with 1Password 8.

It’s available as a separate download from their site…I don’t see it on either the Mac or iOS app stores though…so no idea how you get it to those devices yet. Not an issue for me as v8 is fundamentally broken for me…removal of several features I require. Like many…I will stay with v7 until it breaks…and at that point I’ll either shift to something else that supplies those features (DropBox, doc attachments and backup/restore capabilities)…currently that’s Enpass as the top choice…or to Passkeys or iCloud Keychain or Apple’s Keychain assuming that they were to add the doc attachment and auto password entering from keychain (not from Safari stored passwords) capabilities.

I would go back to Password Wallet which I eliminated as a 1 man shop, no browser plugin, and their auto fill procedure is horrendous IMO before I went to 1PW v8 in it’s current form…and 1PW the company doesn’t care about the features and capabilities they removed…their long term answer on their forums since September or so has been “true us…our way is better and we’re not giving those features you require back”.


Can you provide a quick summary of what was removed?

So it seems I was right that they’re “staging” 1P 8 rollout which is why it’s not pushed to the App Store, etc. From their Support Team:

I’m sorry that the lack of an update notification was confusing, we’ve announced 1Password 8 through the tech media, social media, on our blog, and on our community forum. We have millions of users and we wanted to make sure that that our support team would be able to help anyone having issues so we’re performing a staged rollout of 1Password 8. We’re working on how to best notify existing customers of the update. You can download 1Password 8 directly through our website:

They say it’s to manage the load on support (but they’re still fielding support requests from 7.X users, so I’m not sure I buy that). More likely, they don’t trust it yet and they’re using early adopters as guinea pigs and hopefully getting things fixed along the way. And maybe they’re trying to add back features they apparently yanked before more people cry fowl after upgrading.

Running 8.X now on one Mac; we’ll see what happens.

Local vaults, standalone license (i.e., subscription only and the stand alone license for v7 was hard to find already), no cloud option other than 1PW servers, and local backup/restore capabilities. Also…at least in the two beta and one released versions I tried…the app didn’t really look like a native macOS app since it is in Electron but I don’t use the app much on macOS so that’s a pretty minor issue at least for me…but beyond the look and feel v8 just didn’t work right…or at least right as I define right.

I could really live with everything else…and I already have a subscription which is one of my many backups of my 1PW data with v7 but would prefer a stand alone license myself…except the no local/user controlled backup/restore routines to a location of their choice and that one is both a deal breaker and something they’ve said on their forums won’t be fixed because their new and improved and better algorithm can’t or won’t do and they aren’t interested (or maybe weren’t interested either then or yet, can’t remember the details exactly). The decryption happens on device in some sort of MySQL or some other database as I understand it…but unless you’re a DB guru then doing a backup or restore from there is a lot of command line stuff that most mortals don’t know how to do. But as a long time IT sysadmin and computer security guy…the idea of having my only backups out somewhere else I have no control over and that they haven’t to my knowledge explained anywhere gives me the heebie-jeebies. With full time sync…a corrupted database on any of my devices or their’s wipes out all the other copies essentially at the same time since corruption in the encrypted blob is just more encrypted blob to the sync engine…and without the capability to restore their own copy of their own data from last night’s backup that just fails the 1, 2, 3 backup scheme that so many security pros including myself believe in.

I’m not going to say v8 is a bad product…just that it’s a bad product for me. If one is willing to live with what I consider as deal breaking issue then I would say go ahead and use it if you want but I advise against it. Others mileage may…and does…vary and at least several posters here are perfectly happy with it…to which I can only respond OK for them.

I’ve been happy as a clam with the product starting with v3 or maybe even v2…but the company has changed and IMO their business model and focus has changed and that’s not a good thing for individual users.

Thanks for those details.

Owning my own data is important to me, too. But jumping ship right now is a massive project that I’m not prepared to tackle right now. Reminds me of when I had to switch from Quicken (and many years later, BACK to Quicken). Weeks of prep I’m not eager to take on. I only recently got 2 of my kids trained on how to use our Families subscription, and that remains a challenge.

I’m hoping in a couple years that TidBITS will have an article showing a much greater adoption of one of the more open solutions as well as a smooth migration strategy to get there from 1P…

1 Like