watchOS 10 upgrade

Snoopy really is a disruptive game changer in all good ways. Like you, in an effort to feature Snoopy, I’m trying to now hide complications under the crown spin. So far, it’s a keeper, even without Shazam :-)

1 Like

At the risk of appearing (accurately) like a Shortcuts neophyte, just how does one create a watch shortcut to open an app that does not have a built-in widget? Is this accomplished on the Watch? On the iPhone? On a Mac?

Shortcuts have always left me mystified, despite 25+ years of using Macs and 10+ years of using iPhones. Early on after shortcuts debuted on macOS, I created a shortcut on my MacBook that launches the macOS Terminal app. Apple seems to think that shortcuts on macOS should get synced to iOS, so that shortcut now appears on my iPhone, where it’s useless.

But back to today’s learning objective, how do I get a shortcut that I can add to watchOS that opens a desired app?

Thanks.

I’m a Shortcut novice, too, but here’s an easy guide for creating a Watch Shortcut to Open an app on the Watch. You do this via the iPhone Shortcuts app.

  1. Tap the ‘+’ sign in the upper right corner to start creating a shortcut.
  2. Tap the Add Action button
  3. In the Categories tab, tap Scripting and select the first button, ‘Open App.’
  4. In the button that appears, select the ‘App’ variable, and you’ll see a list of apps. Note that these are all IOS apps; your Watch app must also have an IOS version)
  5. At the bottom of the screen, tap the circled ‘i’, and turn on the ‘Show on Apple Watch’ switch.
  6. Tap ‘Done’
  7. At the top of the screen, you’ll see a title line, ‘Open App,’ with a downward-facing carat next to it. Tap the carat and select Rename to choose an appropriate name for the shortcut.
  8. if you open the Shortcuts app on your Apple Watch, it should appear in the list.

Note: You reorder Apple Watch shortcuts in the iPhone shortcuts app. Open the app and then tap on the Apple Watch folder. To reposition an app, press and drag it to where you want it.

Hopefully, this helps.

Once you have one app done, you can explore other actions and controls to write more complex shortcuts.

2 Likes

Alan,
Thanks so much for the guide on creating a Watch Shortcut. It was extremely helpful - I doubt I ever would have figured it out using Apple’s documentation. Nor how to re-order the list of shortcuts as displayed on the Watch.

Using your recipe, I proceeded to create a shortcut to launch an app on the Watch, and then added it to the Watch’s 3-item widget. However, it doesn’t quite work (or perhaps it does, but my expectations are too great). When I tap on the shortcut, it displays the name I gave the widget along with the default shortcut icon, with a big RUN button. I then have to tap RUN to get the app to launch. Perhaps that’s a normal limitation launching an app via a shortcut.

Here’s what I found:

If you make a specific shortcut a widget, you must tap RUN after selecting it from the Smart Stack (or the multifunction widget). However, if you put the Shortcut app widget in the Smart Stack or the app in the multi-function widget, then if you tap on the app icon and then the actual shortcut, it will run immediately. This doesn’t save any taps but does allow you to access more actions via the Smart Stack.

AMEN! WatchOS 10 is Apple at its most arrogant, which was already a high bar.

Shortcuts? When I first got my Watch SE a couple of years ago, I attempted to create a very small shortcut, It failed with the message “Registered user not available.” I have yet to see that error message documented or explained, in spite of searching at that time. (I did not post it here. Not worth the trouble.)

I tried adding the desired app directly to the Smart Stack, but the app is not shown in the offered list of all applications on the watch (even though it is installed).
I suppose this means that the app has not been ‘widgetized’ by the developer. Even though it can be configured as a complication, it can’t be a widget.

The previous (V9) UX to access this app was two gestures: swipe-right to get to face #2, then tap the complication.
The V10 process is (1) swipe-up to get the Smart Stack, (2) carefully swipe-up to reveal the shortcut (or fiddle with the Digital Crown), (3) tap to activate the shortcut, then (4) tap RUN to launch the app.

However, after exploring the V10 UX for a few days, I have adapted to the new method to access the control panel, and quite like it.
But the limit of only three items in my SmartStack is overly restrictive

I’ll keep exploring/fiddling with shortcuts, smart stacks, and the multi-function widget and see if I can bend V10 to my will.

Thanks again for the tips.

Remember that there is always “hey siri, open (name of app)” (or, of course,’long-press the crown to activate siri).

And another option is to add the complication to the watch face you use most often and move one of the complications on the watch face that does offer a widget to the Smart Stack.

In my Smart Stack, I have 7 items plus the multi-function widget and the ‘All Apps’ button. You can only add widgets, not apps to the Smart Stack, but if the App is not an iPhone-only app, you can create an ‘Open [App]’ and access it from the Smart Stack as has been discussed previously.

Wow - 7 items??!! I’d be delighted if I could get 7 items in my SmartStack (plus the multi-function widget). That would really change the way I’d deal with faces and complications.
Perhaps my Apple Watch is too old to handle that many. (It’s a Model 5, with only 23 GB of available memory).

I checked the limit, and posts on Reddit and MacRumors indicate that the limit is 4 for series 5 and below and 8 for series 6 and above. I think those numbers include the multi-function widget.

As discussed in this thread, one way to expand the actions available is to create a Shortcut to activate it and then access it from a Shortcuts App widget. It may mean more scrolling and tapping, but in many cases, it’s better than accessing it via the crown.

Alan,
I’ve been poking around and found that the limit on my series is 4 widgets, plus the multi-function widget.
I’m positive it refused to add #4 when I tried last week (“Widget limit reached”), but tonight it let me add the fourth. Maybe I miscounted.

However, I have been unable to add the Shortcuts app widget to the stack, a method you suggested would expand the number of actions available. When I try to add the Shortcuts app widget, I am forced to select one of the shortcuts that I’ve created. So no expansion is achieved. Perhaps that’s another restriction of the older series 5 architecture.

No matter - with your help, I’ve been able to find a setup that seems to meet my needs (more or less), although I still find myself trying to swipe-left to reveal my 2nd watch face and access the complications there. My muscle memory will take a while to dissipate.

After a week or so using watchOS 10, I’d happily go back to V9 if I could. I’ve not found any new features/functions that are compelling, but the reduced battery life is a killer. My watch barely gets through a day any more.

I agree with all of this.

1 Like

I was able to add the Shortcut app and actual Shortcuts as widgets for a time after I upgraded the watch. However, I can’t do that now. What I have done and can still do is add the Shortcut app to the multi-function widget and run individual Shortcuts from there.

If you haven’t installed it yet, install the 10.1.1 update that came out late last week. It fixed battery drain issues that had been plaguing a lot of users.

If you have installed it already, it’s likely that a loss of battery health on a watch as old as Series 4 is giving you the best you’ll get. If you’re below 80% health, Apple will do “battery replacement” for a fee. (They really just exchange the watch for a like-new replacement with a new battery.) But if battery health is really low, it’s likely that staying on watchOS 9 would have led to the same battery performance quite soon anyway.

Weirder and weirder.

Yesterday I was able to add a 4th widget to the Smart Stack (4 widgets, not counting the multi-app widget).
Today, I viewed the stack, and the one I had added yesterday (Weather) had vanished.
Tried to add it again, and encountered “Widget limit reached”. So I’m stuck, again, at three.

I restarted the watch, in case a reboot might clear some caches or reset some flags. No joy.

Then I found that if I deleted one of the entries in the multi-app widget, I could add a 4th to the stack.
And after adding the weather app’s widget to the stack, I was then unable to add another entry (it would have been the third) to the multi-app widget.

It appears that the multi-app widget doesn’t count as one entry against the limit, but as N entries, where N = 1, 2, or 3. If you fill up all three slots on the multi-app widget, you can’t add as many to the main stack.

I think Apple has mis-named this new feature. It’s not smart at all. It’s the stupid PITA stack.

Yep. It’s possible I don’t use enough apps or features to benefit from this new stack but it’s annoying the hell out of me. The previous way was far superior imho.

And so Apple heard me loud and clear :sweat_smile:.

Watch face swiping is back. But perhaps with a twist. It’s an option, because Apple also heard all of us :open_hands:

3 Likes

I’ve also read that the new beta is back to having a separate New workout button to the left side of the workout screen, rather than bury it under the End workout button. So with watchOS 10 until this, if you were doing, say, triathlon training and wanted to switch from swim to bike, or bike to run, you’d have to swipe right, tap End, then New Workout, then chose the new workout. And when you are done with a workout, you have to tap End, and then End Workout on the next screen - though double-tapping the first “End” button was an undocumented shortcut. Before watchOS 10 there were separate End and New buttons on that screen. I do this several times a week.

1 Like

After doing the latest update I can anecdotally say the battery usage on my Series 6 has improved. I’m back to getting what I was with earlier WatchOSes.

2 Likes