Ventura, external drives, ownership

I got a new Mini running Ventura and a new big external drive, that I want to use as a file server. I created a non-admin account on the Mini, went to the external drive, created a folder, and then tried to change ownership of that folder to the new non-admin account. When I do get-info on that folder, I get a spinning pizza wheel for the new owner.

When I go to Terminal, the owner is shown as the admin account that created the folder. If i do “sudo chown non-admin folder” - nothing happens. No error return, but no change to the folder ownership.

This used to work -just fine- on previous versions of Mac OS X (dating back to the original version), it appears to me some sort of new “security feature” has messed this up. Has anyone else seen this? Is there any sort of fix?

(The great strength of Mac OS X was its Unix underpinnings that allowed a root account to fix things that were broken in the file system. It looks like Ventura is moving away from Superuser, but is not providing any alternative!)

I just did a test (Apple Silicon MacBook Pro, latest Ventura, zsh).

Logged in to admin account, created file in admin folder (using sudo), changed ownership to non-admin owner (using sudo). Operation failed silently.

Tried again, but created the file in the non-admin folder, changed ownership to non-admin owner (using sudo). Then the operation succeeded.

So even using sudo doesn’t allow the admin user to mess with another user’s directory?? :person_shrugging:t2:

I hope this helps!


What file system is the external drive formatted with?

APFS (encrypted). Didn’t have this problem with APFS under earlier OS.

Assuming you are booting from a volume other than the external drive, select the external drive in the Finder, do Get Info, and tick the checkbox “Ignore ownership on this volume”.

I second that that advice. If I remember correctly, the defaults for a volume mounted on an external drive are to ignore permissions.

You used to be able to enable the root user and assign a password in Directory Utility (at least I think that was where it was)…and root worked from terminal but you couldn’t login to the GUI as root unless you switched to the type in the username screen. Don’t know if that is still there…but probably.

My Ventura Studio is also my home file server…I leave it logged in with screen saver protecting it as the admin user…and the account names and passwords are the same as our laptops. Once the share was added…it’s under /Users/Shared now rather than at the drive root because it got relocated by macOS) I did a get info amd added perms for Everybody, the non admin share mounting account, and the group containing that account, added Guest access…all with RW and propagated through the hierarchy. The perms were gradually added because in whatever moved the share to Users version that kinda broke file sharing…and I don’t remember exactly which of them actually fixed it. Wife and I are the only 2 users anyway and we have no folders we aren’t willing to share.

I think I tried it both ways, with and without ‘permissions enabled’ on the volume. No change. But I’ll try that again to be sure.

One thing to try from experience on Windows that is sometimes successful these days on Macs: reboot.

I just did that when Photos refused to open because its library was “in use by another program”. The library wasn’t in use, and reboot cured the issue.