Ventura: Are you feeling adventurous?

So Ventura has been released today. Are you brave and adventurous enough to install it? Or, are you going to wait until the next dot release? :grinning:

I installed on my iMac Pro and on my MacBook Pro. It took a while (as always) but I encountered no issues that I am aware of.

1 Like

I’m holding back for now. The folks at Rogue Amoeba have confirmed initial Ventura support for all their apps but advise not upgrading your production systems just yet. And the developer of Hazel is working on a permissions issue under Ventura. I’ll update to Monterey 12.6.1 tomorrow, so far no reports of any problems on that front. And I’ll wait until the Christmas break to move to Ventura on my iMac.

I’m definitely adventurous and nearly always update everything the day of release. I have never had any problems with updates until updating to macOS 13 Ventura yesterday. Once the update was completed, i had no internet access on my Mac Studio. Everything else in my house - 2 iPhones, 2 iPads, 2 ATVs, 2 Rokus, several different smart devices - had internet access as usual. I restarted my Mac and my router and modem with no change. I browsed around in Settings, changed TCP/IP to Automatic, inactivated and reactivated both Ethernet and Wi-Fi, restarted a couple more times, then resorted to reinstalling Ventura from the Restore menu after connecting my Mac Studio to the internet via my iPhone’s hotspot. All with no luck.
I was pretty much resigned to calling Apple Support but went poking around Settings. Somewhere in there I noticed a listing for LittleSnitch and that it was active. This was totally unexpected since it was LittleSnitch 4 that I had turned off several months ago and not upgraded to version 5. I turned off LittleSnitch and immediately my internet access was restored! My next move was to delete LittleSnitch and all traces of it I could find.
Why was an outdated version of an app that had been turned off for months activated by an OS upgrade?? I have read about OS upgrades activating programs but never experienced it before.

How did you turn Little Snitch “off”?

A few weeks ago, I rebooted my MacBook Pro, and in doing so I watched the booting progression bar move to about 70%, and then stop. I waited a bit, and then I got the black screen of death, and the computer rebooted. After several attempts at booting,I couldn’t get past the 70% mark. I booted into Safe Mode, and all was well. Rebooted normally, and it failed. Reinstalled the OS, and it wouldn’t boot past the 70% point. I moved Little Snitch 5 to the Trash, but didn’t Empty, and then rebooted and all was well! Put Little Snitch back, and rebooted … 70% and crash. Removed Little Snitch, Emptied the trash, rebooted and all was great. Downloaded Little Snitch and reinstalled, rebooted and crash!

I then booted into Verbose mode, and watched the boot process. In doing so, I noticed that there were some repeated disks reads that kept failing. I then noticed that my 2TB drive was down to about 60 GB, so I deleted a bunch of stuff, and rebooted. All was fine. I reinstalled Little Snitch, rebooted and all was fine!

Very f’ing weird!

I probably won’t have a choice but to install it on my production machine soon since my 2016 MacBook Pro isn’t supported.

I turned it Off in Preference and also removed it from my login items.

1 Like

I installed yesterday. Lots of changes: About this Mac, System Settings is the new name of System Preferences (and it’s more iPaddish).
Did have a problem with A Better Finder Rename droplets, that on clicking gave a “is damaged and can’t be opened. You should move it to the Trash.
Searching I found this explanation by the developer and what to do: https://www.youtube.com/watch?v=6w0AhNNXrus

2 Likes

thanks for the link to that Youtube, it was quite informative, and will probably save me aggravation when I start installing Ventura in a month or two…

Finder in Ventura will read from MS-DOS format SD cards, but will not write to them. Pathfinder and Preview will both write to the cards.

I have installed Ventura on all three Macs I own (MBP16, macStudio - both M1, and an intel iMac 24 that my wife uses) without any initial problems. What I have seen is a Mail bug - when you select the command to empty the deleted email, the email in the folder just get labeled “Unknown Sender” and don’t delete. I have to exit Mail and restart to get the deleted emails to actually delete. Seems like something this obvious would have been noticed.

1 Like

I updated yesterday. So far it corrected a couple annoying bugs, and introduced a few more. Nothing critical for me so far.

  • The Photos Info window has been problematic since the app was introduced years back. This time they seem to have fixed the problem where while typing in the Caption or Location field focus would suddenly shift to the main photos window.

  • At the same time they introduced a couple new bugs with the Photos Info window: while typing in text a forward delete key press is interpreted to mean delete the current photo. This could be quite challenging if you do lots of text work and use forward delete. In my case I fixed with Keyboard Maestro until Apple fixes it.

  • The other Photos Info window bug is that moving the insertion point up or down out of view in the caption will not result in the text automatically scrolling.

  • The year-old scrolling issue in Music playlists when using View as Songs has been fixed.

  • Search was broken at first, at least in Mail and the new System Settings, but that is just Apple’s love of nebulous asynchronous processes, in this case, updating the Spotlight indexes I presume. It seems to be working for me now.

Mail.app crashing for me (I started a separate thread.)

If you have a large Mail folder, DO NOT INSTALL!

I did install it on one machine. I was going to wait, but decided to try it out. So far everything is working fine for me. I’m trying out Stage Manager. It’s not terrible; I’ll give it at least a week, but I may just go back to not using it.

I installed Ventura on release day. I’ve run across a few instances where I clicked on a button and nothing happened or some information didn’t load and display in a window. Rebooting the system seemed to clear up at least one of these.

The one bug I noted is that Safari doesn’t appear as an application in LaunchBar. I reindexed and also tried rebuilding the Launch Services database, but neither fixed the problem. Enabling LaunchBar to use Spotlight when indexing finally got Safari to show up, but its icon is that of an alias.

Not sure what you mean by large. In total, I have over 360k messages (going back 28 years) spread over numerous folders, some in iCloud and some stored locally on my desktop Mac. My iCloud inbox with about 30K messages is probably the largest. I’ve had no problems.

Your actual messages are probably OK, but your indexes are screwed up. Take Adam’s suggestion to attempt a re-index, and certainly check with Apple Support if that doesn’t work.

I have several tens of thousands of messages going back 20 years, about 80gb work. (Or at least that’s what I -had- before I removed most of the older messages from the library’s mail folder.)

Update: after uninstalling Pathfinder, the last non-subscription version, Finder handles MS-DOS formatted USB sticks and SD cards correctly.

For those of you already on Ventura, does Ventura Mail finally remember user specified column width settings again?

I’m pretty sure it did, but then I backed it out last night for egregious sins. First Calendar sync (USB) wrought havoc I’ve never seen in two decades plus of Mac. And it broke file sharing. Restoring Monterey fixed it all. NONE of the settings for any of the system or app preferences were change between the two OS’s. Wake me when it’s ready for prime time. Still amazed I had no significant data loss. Two days work, yes.