Unwanted window in Mail

My wife presents me with a new problem. In Mail, an unwanted window appears a couple of seconds after opening the app. It sits in front of the Viewer, and cannot be closed with either cmd-W or by clicking the close red button. It looks like a window for composing a new e-mail, except there is no address, CC or BCC fields visible. All the buttons in the window’s toolbar are greyed out except for ‘Photos.’ ‘Save As…’ in the File menu is also greyed out so I can’t save it as a draft and delete it. Here’s a screenshot of it:

Malwarebytes says her MBA (13" 2018, running Ventura 13.5.2) is clean. Any thoughts on how to get rid of it?


Tried restarting the machine and got a message that a login item from an unidentified developer, Philip Stokes, was installed. I switched it off in SysPref>General>Login Items. As far as I know, Phil Stokes is a respected developer of DetectX Swift, so that probably happened when I ran it to help ascertain the issue. I’ll switch it on again.
I should add that she uses Stage Manager (being one of those people who never move files off the Desktop, or attempt to organise them there—Grrr!) but switching it off still makes no difference to the mystery Untitled window.

Does the unwanted window appear in Mail’s Window menu? If so, what is its name?

Yes, it does. “Untitled.”

It does: “Untitled.”

Truly strange. Have you seen this article? It was the only thing I found that described a similar problem to yours.


I just read it, and tried the fix—there were two e-mails in the Outbox that had not been sent. I deleted them and quit and re-opened Mail. No mystery window!
Thank you very much!



Glad that helped. I’ve never heard of such a thing before, but apparently it crops up from time to time.