Trouble scanning with Ventura

I’ve got an HP all-in-one that I’ve had for more than a few years (HP MFP M127fn). I’ve been using it with the HP Smart app. I don’t scan a lot, but often enough.

I’m running a MacBook Air 16GB of memory running Ventura 13.5.2. I tried to scan the other day and had much grief. The app doesn’t resemble what it used to look like (that could be my failing memory) but getting the app to finally run was a royal pain and slow. It also did not recognize the document feeder.

Has anything changed?

Is there another option?

I tried using the info online about scanning from Preview but I could not get it to work.

Anyone have any ideas?



I’ve always had better success using the Preview app to do scanning rather than the scanner software branded driver.
Preview —> File —> Import from ScannerName.
Might need to make some window adjustments to size and the default settings to what’s required for output.
If you’ve used Preview and not getting the result you want, can you give details of where it’s failing?

Unfortunately, Preview -->File–> Import from Phone is the onlylt thing available. No Import from Scanner. Which DOES show in System Preferences–> Printers and Scanners–>HP Lasertjet MFP M127fn–>Open Scanner---->Nothing

Two options:

  • try using Image Capture, which does a fair job with many scanners
  • try using VueScan from, which is excellent if you want to do high quality image scans. I use it for scanning negatives in a Nikon LS5000ED.

Thanks to all for the help. In the end a new version of HP Easy Scan (and a router reboot) took care of the problem. All (at least so far) seems well.

I’ve found that VueScan beats the pants off any other scanning software, especially if you have an older scanner that the vendor & Apple refuse to support.

I ran into a problem finding my Epson Perfection V330 Photo scanner after installing Ventura 13.5.2 my Mac. The problem turned out to be caused by accidentally disconnecting the scanner, but figuring out what was wrong was made much more difficult because of changes from the old Monterey interface. The About this Mac page dumped me into the System Settings file, and it took some guessing to figure out that the General setting led to the old About this Mac information on what peripherals were connected to the Mac. Those changes were far from intuitive and made troubleshooting more difficult.