Time Machine changes in macOS 13 Ventura

We recently bought a MacBook Air (M2) for my wife with a more generous internal SSD (1T). At the same time my Seagate 4T drive that hosted my TimeMachine developed problems, so we decided to get 4T SSD’s (SunDisk) and mover our backups to a safer, more spacious place. The idea was to copy over the “history” from the old TimeMachine to the new SSD; a process I have last done about 3 years ago when my previous HD ran out of space. I refreshed my memory via several posted articles (e.g., Transfer your Time Machine backups to a new drive with this guide - AppleToolBox) and attempted to move my wife’s ™ -currently on a 2T WD magnetic drive- to the ScanDisk SSD. After 2 days of trying (unsuccessfully) we called Apple support (her machine is still under apple care). The 1st level customer care tried everything I have --unsuccessfully. You cannot copy or paste those newer -TimeMachine files by any of the previously available means. The next level tech first tried to talk me out of moving the old time machine files, later seemed surprised that TimeMachine file structure has changed in OS 13 (the snapshots are no longer in the backups.backupdb folder but located “naked” at root level). After a long and somewhat adversarial discussion -he did not see the reason why I would not just start a new TM- he looked up an internal Apple memo that said the the TimeMachine files are no longer copyable or movable from OS 13 onwards.
Has this information been made available to the Apple community? Does anyone knows the reason for this unfortunate move (after all TimeMachine is about preserving history!) or a workaround?

This no longer works with TM based on APFS since that relies on snapshots rather than copying and hard links as it did on HFS+. I thought this was already introduced with Big Sur.

Howard Oakley has all the details.

Changing the backup store
We have already debated this scenario to death. Because there’s currently no way to copy the snapshots that Time Machine relies on, except by low-level disk duplication, there’s no way to transfer existing TMA backups to a fresh disk. If you therefore back up to a single store, or use multiple rotating backups, you can’t retain their existing backups as the basis for additions.
Currently, the only practical solution here is to set aside your existing backups as an archive, and start a new backup set on the replacement backup store. This is a major disadvantage to TMA, as TM backups to HFS+ can be copied to a fresh disk, allowing you to increase the size of the store and continue to back up to the same set.

And comments at the bottom of this article:

I think this happened a lot earlier than Ventura. My direct connected TM drives have had them at root level for at least the last few OSes.

My understanding is that the backups.backupdb folder is still used for network connected backup drives (Time capsule and NAS) but I can’t find confirmation of this.

1 Like

I have a Time Capsule and Synology NAS I use for Time Machine backups, and at the root level of the Time Capsule and the Time Machine volume on the NAS is just a bunch of sparse bundles, one per machine. Some of the backups are quite old (my server mac mini, which I don’t keep anything on except config, is running El Capitan and Time Machine’s oldest backup is March 29, 2009!)

And if you open a sparsebundle I think it will contain the backups.backupdb folder. In any case you are not seeing the snapshots at directly at root level, as I and @horvath see with direct connected TM drives.

To: electric company & Simon: sorry to bring up an issue “already debated to death”; Customer support folks @ Apple (even at the second level) were not initially ware of the implications of the move to “TMA”. (by way of excusing myself for bringing dead issues to the table)
Moreover, my own TM - the one reporting inability to back up & subsequently resumed operation for unknown reasons- definitely has a Backups.backupdb folder with nested subfolders within and I am on OS 12.6.5. However trying to copy & paste the Backups.backupdb folder (1M+ items) failed for " lack of permission"
At the end, I will have to start with a new TM container (as suggested) and this new container appears to be formatted by TM as APFS.

Nope. The sparsebundle’s all look like this:

$ ls -a1F /Volumes/Backups/iMac.sparsebundle

except for the one created by Monterey which also has a mapped folder and a lock file. If I do a Show Package Contents… in the Finder, it shows the same thing (except for . and .., as expected). If I mount one of the sparsebundles and open it, then I see the individual snapshots.

Correct, although I was just responding to the comment about the backups.backupdb folder on network connected TM volumes (and I do see snapshots at root level if I mount one of the sparsebundles).

1 Like

It’s eclectic light company https://eclecticlight.co/.

Apologies (auto correct ;-(