Thunderbolt suddenly doesn't work anymore

Somewhat suddenly Thunderbolt gives me trouble on a client’s iMac Retina (5K, 27” Late 2015), BigSur 11.7.2

The iMac has two Thunderbolt-2 ports.
There is a G-Drive HDD and a LG Display, both feature Thunderbolt-3 (USB-C) ports.

Both G-Drive and LG Display don’t start in the following combinations. Please note that we need to use Thunderbolt-2 to Thunderbolt-3 adapters, the original type from Apple. This has worked without problem for many months.

The following combos don’t work, including swapping from right to left port,

iMac TB2 port —> TB Cable —> Adapter —> G-Drive
iMac TB2 port —> TB Cable —> Adapter —> LG

iMac TB2 port —> TB Cable —> Adapter —> G-Drive —> LG
iMac TB2 port —> TB Cable —> Adapter —> LG —> G-Drive

I know that the adapter is bidirectional.

On my own MBP (Retina, 15-inch, Mid 2015) all of the above combos do work. Monitor, G-Drive, adapters, and cable are therefore OK.

Logically you’d conclude that the iMac is at fault, but what could possibly be faulty on both of these ports?

We upgraded to BigSur to be sure that it is not a strange TB driver issue, but no luck.

Any idea very welcome.


Does Apple Hardware Test mention anything? A busted TB controller would affect both ports.

Also, do you see the same issues when booting in safe mode?

1 Like

Also try an SMC reset:

I found this worked when my Retina Macbook USB-C port failed to connect an external drive.

1 Like

Thanks guys. The problem is now solved. I should like to think that I’m a reasonably seasoned and experienced Mac man, only since 1984, I hasten to add, but I ran into a trap that only reasonably seasoned and experienced Mac men can run into.

  • Apple Diag didn’t show any problems,
  • Safe mode made no diff,
  • SMS reset made no diff.

I tried PRAM reset because the was nothing else to try, and lo and behold, we were back in business. Why did I not even think about this in the first place? Because I could not imagine that the PRAM might have any influence whatsoever on the TB chipset or TB ports.

My own thinking was just a tiny little bit full of “I know what I’m doing”. As it turns out, I didn’t. I should have followed the usual script. Just do it, it can’t harm, even if said step won’t lead to anything, you never know.

Thanks for reading my request for help.

1 Like