Temporary Blacklisting Comcast Mail

Been using Adguard from Setapp to block trash mail etc. Also, Lulu by Objective-See. Using Cloudflare DNS translation. Now intermittently getting notices in Apple Mail Comcast Xfinity IMAP of Temporary Blacklisting. Dr Google shows folks ascribing it to Cloudflare and others to having ANY VPN. (I did not know Adguard functioned like a VPN but that is how it shows up in Network Preferences.). Any thoughts appreciated as I’m out of my league here when I was trying to be secure and do the right thing. Best, Patrick
Comcast Mail
TMobile Home Internet, unfortunately.

Patrick, I read my email with Comcast OX App. I have Cloudflare enabled and I am not blacklisted (to my knowledge). I do get upwards of 15-20 spam every day! I keep reporting them to Comcast, but it doesn’t seem to do any good!

(The Sam’s Club/Walmart spam —they want you to take a screen shot and send it to them and not forward. I did it a few times and decided that it is too much work!)

1 Like

Thank you, Jane. Same here. 45-65 spam emails per day. Switched from Cloudflare to another DNS server Q9 or something like that. Things are still glitchy. I’ll let you know after a few days. Best, Patrick
I report phishing to reportphishing@apwg.org. Don’t know if it has ever helped.

Progress Report: Day TWO of not using Cloudflare settings. No blacklisting of ISP in Apple Mail. Yay. Best,Patrick

Unfortunately, even without using Cloudlfare, I am today getting the ‘temporary blacklisting’ messages. Have no idea unless it is from Comcast / Xfinity or something. Just a progress report. Best, Patrick

Can you share a screenshot of this? I can’t tell what you’re seeing.

Do you mean AdLock? AdGuard isn’t in Setapp. And AdLock won’t have any effect on email, I don’t believe. But yes, if you’re using something that runs all your traffic through a VPN, that could cause trouble. Turn it off.

Lulu is the most likely culprit, given that it’s a firewall. I’d turn it off as well.

The other variable that could cause confusion is iCloud Private Relay. Turn that off if it’s on.

Once you turn all this network-related software off, you might be able to get some clean tests by turning one thing back on at a time.

Thank you, Adam
I made an error: it is AdGuard. And that is not what is causing it.
I don’t use iClooud Private Relay. I don’t use a standard VPN but have been trying out Lulu.
I have tried with Lulu enabled then disabled:no help.
I have tried it with my Apple Firewall off and on, no help.
I think it is Comcast / Xfinity.
Sometimes I reset the modem and it works.
Best, Patrick

It could be related to the T-Mobile Home Internet. I wonder if you might be getting different IP numbers at different times.

Thank you Adam. Maybe so and I don’t know. Best Patrick