Strange disk volume unmounting

I’ve got a Late 2014 Mac Mini that has been upgraded to Big Sur. It has an attached Seagate Backup Plus USB drive that was formatted HFS+ with two volumes…one for Time Machine on the Mini and the other for remote backups of our two laptops. Time Machine Server has never worked reliably for me so a year or so back I disabled Time Machine on the laptops and have Carbon Copy Cloner jobs setup to clone /Users on the laptops to a folder on the second partition on the Seagate. The CCC jobs are setup to run periodically using the Remote Mac destination setup in CCC.

This worked fine until the upgrade to Big Sur. Now…the Mini Time Machine volume on the Seagate stays mounted nicely but the other one that is the destination for the CCC laptop jobs keeps dismounting itself on the Mini and hence the CCC job fails.

Has anybody seen this…and more importantly know of a solution? Although APFS doesn’t work as well on spinning drives speed really isn’t an issue for either Time Machine on the Mini or the CCC jobs as they happen over wifi.

I had originally setup the two partitions just to keep the Mini TM and the network CCC volumes separate…but I don’t guess there’s really any reason to not have them on a single volume if that might solve the problem as the TM volume remains mounted when the CCC network destination volume dismounts.

Should I just reformat the Seagate as a single APFS volume and then select it for both local Mini TM and share the two folders that are the CCC network destinations separately?

Strangely enough…my iMac (although it’s still on Catalina) has a similarly configured set of CCC network volume destinations and those happily stay mounted…although the OWC Thunderbay Mini RAID it has attached periodically dismounts itself but not nearly as much as the one on the Mini.