Strange Audio Issue, Mac Pro + Monterey

I think this is a fun or interesting error that the community will enjoy for its oddness. (I do not enjoy it!) I do not think there is a solution (but I don’t understand the problem fully).

I accidentally upgraded to macOS 12 (meant to do 11) on my ancient trashcan Mac Pro (I love this machine, I am in the minority on that). That coincided with a difficult audio problem: a lot of audio is sped up by about 10%, and voice streaming (Zoom, Google whatever) is often unusable (loud clipping).

It isn’t entirely straightforward, and I haven’t tested it extensively, but here are some details:
After the computer sleeps and then wakes up, Safari and Apple’s Music app will play everything about 10% too fast (there is a pitch shift but yes I also have paid attention to the timing). If I restart either app, they play fine until the next time the computer sleeps. However, Firefox does not have this problem (interesting, it uses some different… something? its own codec?), so I use Firefox for Pandora.

More specifically:
Apple’s Music app: the issue happens with music, I haven’t tried movies.
Safari: YouTube, Pandora. (I discovered that some YouTube videos have one long soundtrack and other ones have the sound chopped into shorter bits that you don’t notice if playback is normal.) So, with YouTube videos, the video plays back at a normal rate, but the soundtrack is 10% too fast, so it rather quickly becomes out of sync, so spoken parts eventually come far before the person speaking them is on screen.
Firefox: not affected with Pandora.
Both Zoom and Google (hangouts? meetups?) have had horribly loud clipping sounds, Zoom in the native app (but not all the time) and Google I just used once in Safari. They are both completely unusable, and it is painfully loud even with the computer volume down very low. I would go so far as to call it somewhat insane.
The Google meeting-thing, I think I tried it in Firefox (after trying it in Safari) and it didn’t work (I ended up using my laptop). I don’t quite recall, I was in a rush to get on the call (making something work quickly was my focus, not diagnosis).

It is an old machine, possibly some hardware is failing (I think one of the video cards went south but I changed the ports the monitors are on and that fixed things and I haven’t tested it beyond that). But it did coincide with the system upgrade (although that was a while ago, I’ve been living with this issue since then).

So, I don’t feel too confident there is a fix, but I find it curious that Firefox is not impacted at all (outside of maybe Google meetups), while Safari is. (I think this is probably some clue about the issue, just I don’t know enough to know what this suggests.) I imagine the rest of the TidBITS community will also find it interesting! (I have tried Googling the problem but if there is a discussion about it, I missed it.) I think it is likely that there are knowledgeable TidBITS readers who will know why Safari is affected but Firefox isn’t (I am not one of those people at the moment but would love to become one).

I forgot, if I try to use the computer to handle a phone call from my iPhone, the horrible clipping sound happens then too.

Fascinating! If you use any Rogue Amoeba software that shows it happening, perhaps ask their support team. They probably know more about audio than anyone else in the Mac world.

The number 10% jumps out at me here.

I suspect I’ve seen similar issues in the past, when using various audio interfaces. 10% is roughly the difference between 44.1kHz and 48Hz.

Audio on a conventional music CD has a sample rate of 44.1kHz. However, audio intended for use with video is often at a sample rate of 48kHz. (I think - I have more audio experience than video.)

If you play material recorded at 44.1kHz through an interface actually sending data at 48kHz, without any sample rate conversion enabled (“SRC”, which can be implemented in hardware or software), the results will be like the ones you describe, I think… the data is played out faster than intended (it’ll sound a little faster and higher), and there will be drop outs (short periods of silence) or other problems when the buffers have been emptied sooner than expected.

As a first step, I’d suggest opening /Applications/Utilities/Audio MIDI, look in the Audio Devices window (use Window > Show Audio Devices to open it if necessary), find the settings for your speaker outputs, and try a few different sample rates (in the Format drop-down menu).

If that doesn’t fix the issue, or reveal anything interesting… hmmm. Does the trashcan Mac Pro have a 3.5mm audio jack output, and are you using it, or something else? I’d consider trying a different audio interface, if you can, just as an experiment. Eg perhaps you might have access to headphones that use a USB connector (thus avoiding the built-in 3.5mm jack)? This would test the idea that something is wrong with the built-in audio system (hardware and associated software configuration).

As to why some applications are affected, and others not… from what I’ve read, Core Audio (low level framework for audio on the Mac) is a long established and complex beast, and I suspect different applications use it in different ways - perhaps certain “play this audio” APIs would reveal a sample rate mismatch problem, and others would work around it (eg by enabling SRC when necessary).


Oh that’s genius!

3.5mm audio jack output, and are you using it…

Yes and yes (to some speakers). The MIDI Setup looks normal I guess, “built-in line output” is set to 48.0 kHz at the moment and Apple’s Music app is playing normally.

I have some more weird data points:
The sound was fine, I slept the machine using the Apple Menu > Sleep, the problem didn’t occur when I woke it up, but later it slept on its own then then the problem did happen (so, maybe length of time in some way?).
But what was interesting was that I had Pandora playing at the correct speed via Firefox and at the same time I played the which was going too fast, both using the same output (the speakers via line out), that was really weird. (It actually sounded like the music in Music was playing back faster than 10% faster, but the progress bar wasn’t aligning with the actual seconds, it was doing 0%-100% but showing what the seconds should have been.) So, two different songs playing at the same time via the same output.
Even weirder was that Music is now (later) playing back at the correct speed (I did not restart Music, this is very strange, although I left the Audio MIDI Setup app open in the background and I have never done that before).

I do have an old headset with USB-A, I will see if I can find it and if that does anything interesting when I can test it.