Sonoma file zip compression / permission bug

I just tried to compress 15,000 files into a zip archive when Sonoma aborted zipping with this error message: “The file “XYZ” couldn’t be opened because you don’t have permission to view it.”.

However, I can compress subsets up to around 2,000 files (including the aforementioned culprit) without problems. If I select more than ~2300, I get the error with one file selected as having no permission. With each batch a different file XYZ is singled out. This seems to be a file number issue, not a size issue. I haven’t figured out the exact limits but fewer than ~2000 files always worked and ~ >2,500 gave me the error. The archive sizes didn’t matter, with the zip archives being from about 60 MB to 1.3 GB.

I had this problem with Sonoma 14.1 and it persisted after upgrading to v14.2.1 and restarting. Not sure if this problem was present in previous OS versions.

Anybody having this problem too? Any fixes?

Perhaps try the command line or BetterZip?

1 Like