Solving the "Failure to Personalize" error when updating macOS

Hello TidBits

This entry contains my saga in resolving a software error called “Failure to Personalize” that showed up every time I tried to update my system software from 13.6.0 to .2, .4, .5, .7 and then 14.5.

My 2023 M2 16” MBP refused all attempts to update system software.
I could not update it via System Settings, an external USB stick, nor recovery mode.

The local Apple Store also did not know what to do except to perform a “reset,” erase the SDD and all contents, and re-install new software.

That was done to get the machine from 13.6.0 to .2, and .4 but did not fix the problem. The machine continues to exhibit the “Failure to Personalize” error message when trying to update system software.

It took nearly 11 phone calls with Apple, including senior engineers, experts from the Business Group, and from Countries including the USA, Ireland, and Portugal to come up with a resolution.

Every Tech support person kept telling me that the “Failure to Personalize” was because my internet connection was not being able to reach a specific Apple Server during system update.

This turned out not to be correct in my case.

I was able to update my 2020 MB Air from 13.6.4 to 13.6.7 and ultimately to 14.5 using my home wifi connection. But not my 2023 MBPro.

On 24 May, in talking with a VERY senior engineer named Paul from the USA, when I identified this, and said that the problem is not between my home wifi and apple, but between my home wifi and the MBPro, a lightbulb came on.

It took a few hours but he suggested by email that I try this terminal command:

sudo softwareupdate -i -a -R

He said that he was able to get it to work on his HOME machine.

I did and it looked like the MBPro was updating but that it would take 3-4 hours.
I went to bed confident that the problem had been resolved.
Got up the next morning and found the “Failure to Personalize” error message again.

On Sunday, more more more phone calls.

Sunday night, Bruno from Apple Portugal called and said that the consensus among the senior engineers was that I need to download Apple Configurator2 app from the App Store on to my MB Air, connect the two computers together and run the RESTORE command in Apple Configurator2.

On Monday, I tried. Apple Configurator2 would not download to a machine running 13.6.x so I first had to update the MB air to 14.5. Then I downloaded it. Then I connected the two Macs.

Tried to put the MB Pro into the appropriate mode but could not.

More phone calls to Apple. Monday evening, Diana from Ireland called to tell me that I need to use the power cable that came with my MB Air to connect the two Macs together.

Tried that. Could not get the MB Pro into the correct mode. She suggested that I visit my local Apple Store and see if THEY could get the MB Pro into the correct mode.

Tuesday, made the very very long trek to an Apple Store and after tinkering with the machines for an hour plus, the technician there called someone. Thirty minutes later, he comes back with a cable:

APPLE 240 W USB­C Charge Cable 2m MU2G3ZM/A

Connect the two machines and the MB Pro enters the required mode.

I return home and using my home WIFI network, I connect the two machines and restore the MB Pro.

The problem “Failure to Personalize” is because during the update, the Mac’s firmware cannot be updated. This “Restore” command does not update the current firmware, but writes new updated firmware.

The firmware on my MB Pro running 13.6.4 was
System Firmware Version: 10151.41.12

On the same machine running 14.5 it is:
System Firmware Version: 10151.121.1

(If you hold down the option key while clicking on the Apple Icon in the upper left corning, you see the menu change to “System Information” and that is where one can see this inf.)

I sure hope that NO-ONE has to go thru process but if you do, the above worked for me.

Apple publishes a tech Support article named “How to revive or restore Mac firmware”

I was emailed a copy.

Bruno from Portugal said that this article addresses such a “niche” problem that only senior Apple repair people in Apple stores know about it.

I have attached a copy to this.

Thanks for listening.

Hope this helps someone.

Lee
How to revive or restore Mac firmware - Apple Support.pdf (445.4 KB)

7 Likes

I think by now it’s quite widely known how to wipe an Apple Silicon Mac entirely (“flash” it) and set it up from scratch, including “firmware” (DFU Restore). But I gather the really interesting part about your report is that apparently folks need to remember that “Failure to Personalize” means firmware problem. Not at all obvious.

But once that is known, then the path forward should be simple.

  1. Back up the problem Mac either using TM or SD/CCC (verify backup, ideally have a safety net, i.e. 2nd backup)
  2. Using Apple Configurator 2 on a 2nd Mac flash the problem Mac so it gets brand new fresh firmware (with the latest Sonoma you don’t even need Configurator2 anymore and instead you can do it right from Finder)
  3. When setting up the flashed Mac from scratch, use MA to restore everything from your recent backup

The result should be a Mac with up-to-date firmware and macOS, but all apps, docs, and settings restored. Might take a few hrs and does requiree access to a 2nd Mac (or an Apple Store will help), but otherwise this should be smooth. :+1:

Thanks for reporting. :slightly_smiling_face: :pray: The error message by itself does not at all make it obvious what the underlying problem is.

2 Likes

Simon,

Hi!

One needs Configurator2 to update the firmware on the offending mac if the system update fails.

And, in my many hours of talking with the apple help desk, nearly all of the senior people were focusing on my machine not being to get to an apple server via the internet during the update process. It was only after I told them that I was able to update a Mac to 13.6.7 on the same wifi node as the offending mac was on did they finally start shifting their thinking.

Ergo, why I reported it………

1 Like

If the Mac you’re using to do the DFU restore (“flash”) is running Sonoma it can do it straight out of Finder. Configurator 2 comes with a nice handbook as Howard Oakley keeps pointing out, but these days macOS will do the DFU restore straight from Finder.

A search on Google with ‘“Failure to Personalize” “firmware” mac’ gets only one hit, this thread. Thank you for the hands up!

Simon, I am sorry to show my ignorance, but what does <(“flash” it)> mean?

I put it in quotes because lots of people refer to it that way - flashing the firmware. Apple calls it DFU Restore. Where DFU stands for Device Firmware Upgrade.

This used to appear very simple. Macs had internal disks where the system was installed. Macs booted from ROMs with some host defaults settable via battery-buffered PRAM. Later with EFI and Intel and yada yada, “firmware” arrived which took over part of that functionality (to this day there is still “ROM”, it’s just much smaller and simpler), but this firmware was not read-only — it was non-volatile memory (think like a very small SSD, flash memory, likely why people started using the term “flashing”) that could be written to by special software or restored (“flashed”). It held only basic instructions like how to find a bootable system so the Mac could boot. But the system and the firmware were two entirely separate entities (and in fact in full detail it’s even more complicated because there was not just one firmware) even though each relied on the other to work properly. Then came Apple Silicon and here is where it got muddy. Now instead of dedicated flash to hold the firmware, Apple realized that their internal disks were already flash memory that was perfectly up to the task so why bother with two separate entities? Instead just set aside a separate part of the Mac’s internal flash to hold what used to be the firmware (now all the way from the Low Level Bootloader (LLB) to what Apple these days terms “iBoot”) and use the rest of the internal flash as the disk (what we tend to think of as the Mac’s internal SSD). So this means that the internal flash now holds both what we think of as the system (macOS) and the “firmware”. The latter still requires special tools to install/restore and it’s still required for the former to work at all. But the interesting quirk is that this means the Mac’s internal “disk” always needs to be around and functional for anything to work, even when you’re booting macOS from an external drive — this is very different from how Macs used to work. It also means there is no dedicated flash chip on the board that can be “flashed” or updated. It’s all part of the same set of flash memory the Mac holds internally. And it gets “flashed” with Configurator 2 (or Finder starting with Sonoma), but macOS updaters can update it too. And they often do, even on .x updates.

So next time you think this has all gotten complicated and there’s a gazillion terms being thrown around, rest assured it’s not you. It’s just things have changed a lot and the words we often use originate from times when things looked and worked differently.

6 Likes

Hi! There been some discussion that I could have updated my firmware directly from my MB Air running 14,5 without having to download Apple’s Configurator2 app from the app store.

So, Paul, the very senior engineer that provided the terminal command to update software, and also ultimately told me that my path to success was using the Configurator2 app, told me yesterday that one can “Flash” the firmware using a connected computer running Sonoma without the Configurator2 app.

BUT in this PARTICULAR case, when one is suffering from a “failure to personalize” error, only the restore command within the Configurator2 app can resolve the error.

I trust this adds some clarity to my original post.

2 Likes