Router Woes - TP-LINK Archer C7 V4 blocking access to my domain

I have a account with WestHost and have been a customer for years. Three days ago something strange happened. I could no longer reach any of my domains. I called them and they could get to tehm, So I called my daughter three houses up the street and she could get to them! But no computer at my house could (tried multiple computers)

After messing around for a while, I unplugged the routerand pluggen in my old Airport Extreme base station, rebooted the router and ??? it worked.

Ok, it must be a setting with the router so I plugged it back in, rebooted the cable modem (comcast) and still couldn’t connect so I reset the Archer back to the factory settings and I still can’t connect.

I’m at a loss…Does anyone have any suggestions I could try?


Are your domains hosted at the same servers? Might they have fallen into some blacklist somewhere that the Archer uses by default?
Check default routing, DNS server, and any security settings on the Archer router.

@markwmsn Ahhh, I did a traceroute and it got all the way to my host and hung. I called them up and gave them my domain and IP and they discovered they were blocking me for some reason.

But at least I have access again.

Thanks Mark for yor suggestions.