Redownload Archived macOS Installers to Address Expired Certificates

With a newly imaged MacBook Pro running Mavericks I downloaded El Capitan from the App Store. From that download I created a bootable flash drive. When I used that flash drive on another laptop I got the error message relating to expired certificates ("No packages were eligible…)

Why can I not download the El Capitan installer with the new unexpired certificates?

1 Like

I’m not sure, but I am replying to say that I created a bootable flash drive from the newly downloaded El Capitan installer about 10 days ago and it worked fine (which was good, because I couldn’t install El Cap on the old iMac from the Recovery partition on its drive.) I was getting ready to send an old 2007 iMac to Apple for recycling and I wanted to do a fresh install over my old drive, and the bootable drive worked fine.

Ok, so i went to install mojave on my macbook air and it gave me the old certificate or cant install mojave because of damaged install package blah blah. i read a ton of ideas and how to’s. heres what i did which was ridiculously easy…no bootable drive, no hocus pokus. went to applications and deleted the mojave installer. emptied the trash bin. rebooted the computer. downloaded mojave installer again and poof it worked…i’m using it as we speak.

Yes, it should be just that simple now. The discussions we have been having here involve a variety of issues:

  • Early problem with the Apple mirror sites not being updated with the new installers.
  • Desire to create a bootable drive for a variety of reasons.
  • Complete inability to create a bootable drive with the new Sierra installer (that will apparently always be an issue)

If all you want to do is install a new macOS, your method is the way to go.

I had exactly the same thing happen to me despite downloading a brand new Mojave installer. Then I realized, the problem is launching the installer off an external HDD. As soon as I moved it back onto my internal boot SSD, it launched just fine.

Does this make any sense?

Also, assuming this can’t be remedied, it indicates I cannot use this copy on an external drive as a rescue installer. Perhaps its only use to me is to make a bootable USB stick that I in an emergency would use to boot from and install. Kind of a bummer.

It seems that Apple certifies their operating systems for a certain period of time and when that time has expired, error messages appear, like the one above.
Try this:

  1. Reboot while holding the option key, then select the install disk you are trying to install.
  2. Once the installer has loaded, disable WIFI.
  3. Click on Utilities>Terminal.
  4. Once the Terminal window appears, type the line of text below and then hit return.
    date 1010101019
    This will set the date and time on to the 10th of October 2019 at 10:10. Try doing the installation again and if that date/time doesn’t work, set the date even further back, like 1010101018 or older.

I really don’t think this is a certificate/date issue. The exact same installer ran just fine off the internal boot SSD. The error only showed when running it from an externally attached HDD.

Out of curiosity, if you made a bootable installer (DVD or thumb drive) using the createinstallmedia script before the certificate expired, does that installer also fail to install after expiration?

Good question. No something I can try out I’m afraid. I trashed the old installer and downloaded a fresh one form apple.com. It’s that fresh installer that runs fine from the internal boot SSD, but throws the error when launched from an external HDD.

I can answer that from experience with a definite yes. The drive boots, but the installer that is on it is identical to the one previously downloaded, so it’s certificate will also have expired. I had to redo all such drives when that occurred.

1 Like

I still use the old installers. I just launch the Terminal and use the date command to reset the Mac’s internal clock to the same day but in 2018. Be sure networking is off, BTW. Then exit Terminal and continue with the installation. Simple.

Example:
date mmddhhmmyyyy
…so for May 4th, 8:15am, 2018 you’d use:
date 050408152018

2 Likes

Or disconnect networking and set back the clock in System Preferences

I just wanted to add this bit of information. I have a new 2020 MBP that shipped with Catalina. I still wanted to download Mojave and HS installers to use for new VMs. Neither the command line download commands nor the App Store links from Apple’s KB articles worked. Command line returned errors (“Install failed with error: Update not found”) and App Store claimed this version could not be downloaded. I actually had to get out my old 2013 MBP (running Mojave) to download Mojave and HS. That worked just fine though.

I guess Apple does not allow downloading an installer to a newer Mac that never support that OS version. In light of VMs or people supporting others that appears silly. It’s not as if a too old installer would actually run on new hardware, you’d always get an error.

2 Likes

That’s annoying. I can see why Apple does it, but it just seems unnecessary. Why prevent a download when you’re already preventing installation?

1 Like

I don’t think any of Apple’s App Stores allow downloading software that cannot run on the current device. Yes, macOS installers are not like other software but they haven’t made an exception.

If you don’t have an older working Mac to download an older macOS to use within a VM, here’s an alternate idea: Download a macOS that’s not in the App Store, like Sierra, install it in the VM, then inside the VM download and upgrade it to the macOS you want (or just download it and use the installer to make a “clean” VM instance).

2 Likes

To have access to all the OS downloads, one must maintain a park of Macs which have native access to all the OS. It’s also important to maintain bootable drives which might be eligible for those installs as sometimes it’s hard to download an older OS on a newer OS even on an eligible computer. I can download any MacOS X version under the sun at this point – thank you Apple – but I need at least three different Macs to be able to do so.

What worries me more is that the T2 chip seems to make an install Mac specific, just like in the bad old days of Microsoft attaching Windows installs to a specific piece of hardware. This is going backwards and not in a good way. Perhaps someone running several T2 computers (a single one wouldn’t give away this issue) might be able to shed some light on their experience of backups from failed hardware and moving hard drives from one T2 Mac to another.

Mac-specific installs are a really bad idea. It’s one of those things that traditionally had Macs ahead of everything else, Win or Linux. There’s no reason to sacrifice unique key advantages of the platform such as this.

That said, I have to admit it’s not immediately clear to me what T2 has to do that.