Problem Getting Cellular Service on Apple Watch

I have an iPhone SE3 and Watch S9 with Cellular, but every attempt to add phone service to the watch freezes near the end with: Attwearablesproxy59100: Unknown Attwearablesproxyerror (Create E911 Address failed). My E911 address is totally correct. Long consultations with the carrier (Consumer Celllular/ATT) and a check with Apple, plus numerous device resets and setting changes, have not achieved any fix. There are also a lot of reports on the internet about people with similar problems, but I haven’t found any solution there either. Has anyone here run into this?

Update: On the 26th attempt I finally got past the E911 error, but the watch still has no service, so am still repeating the procedure to try and turn that on…

I wish I could say that I could help, but I’m on Verizon and every time I’ve activated a watch on my account it worked perfectly for me.

My guess is that this is troubleshooting that the carrier may need to do for you. I’d continue talking to them and see if you can find somebody who has troubleshooted Apple Watch activations before.

Shot in the dark, but given that you’re a Unicode specialist, could you have some unusual character in your E911 address that might not be expected?

Barring that, I wonder if Apple could let you return that watch and try a different one.

The carriers seems to have trouble with logically joining the iPhone’s cell number with your Watch cell number. My wife’s watch activated instantly, but I had to spend an hour on the phone with 3rd level tech support to get mine working. Same carrier (AT&T) and same Wach/iPhone models. The carrier rep who solved the problem said it was something to do with the way my cell number was provisioned when I moved it from T-Mobile to AT&T, years ago.

I seem to be hung up now on “pending esim installation”. Will have to try to get carrier to try to fix it. Everything i’ve read so far indicates it’s not a watch problem, but finding the right person at the carrier who knows what to do.

1 Like

Update: After 7 days of fiddling with phone and watch settings and the umpteenth re-pairing operation, my watch suddenly got connected. No idea what did the trick, or whether my carrier just takes 7 days to activate these things.