Problem caused by forcing HTTPS for website loads

I got an Error 404 when I tried to follow the link.

Works okay for me.

Interesting. It’s still broken for me.

Opens fine with Safari 15.6.1 and Firefox 114.0.2.

EDIT: I just noticed that you have https in the address but the site is not secure so just use http.

1 Like

Strange. It’s working for me (Firefox 114.0.1):

Maybe the Columbia server is acting twitchy.

Maybe your browser has cached the error page. See if an ignore-cache refresh changes anything.

Otherwise, there’s some weird network issue involved. Maybe there’s a VPN or Proxy that isn’t playing nice with the site.

Maybe try a different browser, although that really shouldn’t matter for a page as simple as this one. (The page’s source looks like this is hand-written HTML. Or he’s using an editor that produces incredibly minimal markup.)

Good catch. An HTTPS URL doesn’t work on that server (didn’t work for me either).

If your browser has some add-on or configuration to automatically replace HTTP links with HTTPS links, you’ll need to disable/override it for this site.

1 Like

That was the problem. Not only did I have an extension named something like “HTTPS everywhere” enabled, I also had Firefox’s HTTPS-Only Mode set for all windows. Thanks.


There is at least one HTTP site that I have visited regularly for months. Why had it loaded without complaint* for months (and continues to do so) but I got the 404 error for the web page at Columbia that led to the creation of this thread?

*The first time after I restart Firefox, I get a warning that the site is not HTTPS, but I can click through and get to the site. Site visits on subsequent days simply load the page.

I suspect it is due to the way one of your force-HTTPS extensions works. It may be unable to detect that Columbia doesn’t have an HTTPS version of that page, so it can’t present the alert page or fall-back.

I would suggest that you don’t use two such extensions. Either use the one built-in to Firefox, or the HTTPS Everywhere extension, but not both. If that doesn’t fix the problem, then I would just add Columbia to its exception list.

See also HTTPS Everywhere FAQ | Electronic Frontier Foundation

Thanks, @Shamino. I agree. I hadn’t realized Firefox had its HTTPS-only mode (when did that appear?) and so hadn’t realized that I was using two methods to avoid HTTP when possible. When I did realize it (about the time of the start of this thread), I disabled both (to see the Columbia page) and subsequently only re-enabled the Firefox method.

With the Firefox method enabled, the Columbia page is blocked (but at least one other HTTP page is not, and it’s not in the exception list, hence my follow-on question). If I expected to visit the Columbia page again, I would add it to the exception list.

It was introduced in version 83 (November 2020). See also:

Wow. That’s a bunch of versions ago. Thanks.