Posting via email

I’m hoping somebody can tell me what I’m doing wrong. I have Discourse prefs set for individual emails for every post on Tidbits-Talk and those come through fine. I can reply to posts and they successfully make it to the list.

What doesn’t work is starting a new topic…if I create an email to and send it it never shows up on the list so whatever question I had never gets answered.

Am I doing something incorrectly…or do new topics need to be started via the Discourse web interface? Maybe I’m in Discourse Jail or something.

Hi! I have the same problem although it bounces back to me with invalid address. Apple Mail has my Tidbits email attached to a users name, so that’s what I have to type in. Yes, I’ve edited it and it still happens.

I usually give up and just post an initial comment via the web.


Neil, are you getting a bounce of any sort? I’m not seeing anything in the logs that indicates failures from you.

Diane, you had no trouble posting this topic via email from what I can see in the logs:

You do have to send from the address that matches your account on the site; otherwise the message will be dropped on the floor as coming from an unknown sender (ie, spammer).

Nope, no bounces. I’m sending from the same email that works when I reply to an existing post and that is listed in preferences on Discourse. Sent 2 new posts today…to, one at 1256 subject Online Backup and a second at 1314 Portable Home Directories. Neither shows up either in Mail or on Discourse for me…they just went into the ether somewhere.

I replied to another one at 1643 Fast way for file transfers…that one also went to but that’s what makes the threading work. That one showed up in Mail and in Discourse.

I’ll go ahead and post the two that disappeared via Discourse so they’ll show up…but it would be nice it if worked from Mail.

OK, I’ve looked into a bit more and what is almost certainly going on is that the spam filter that sits in front of incoming email must be eating your messages. We ran into this back in June, and my friend at easyDNS had to open a ticket with Roaring Penguin so I could view the quarantine, but the loop was never closed. I’m checking back with him.

You are correct, I can reply fine. It’s new messages that are more difficult.


Ok. Let us know if I can do more to help troubleshoot.

My friend at easyDNS has whitelisted you in the spam filter, Neil, so it shouldn’t be an issue for you anymore. He’s still trying to figure out how to get me the appropriate admin access.

Diane, there were no quarantined messages from you in the spam filter. I don’t know if it has a time limit after which it deletes said messages.

Thanks Adam…I posted a test email post…once it shows up I’ll delete it as it’s unnecessary.

Seems to be working now. Not sure why it was blocked but whitelisting cures a lot of things.

Thanks Adam.

It’s been awhile since I tried it. I just sent a test under a different subject. Usually they bounce back quickly and I haven’t gotten anything yet - fingers crossed!

Thanks Adam, Happy New Year :slight_smile: