POST in macOS 12.7.5 very slow to chime

on my i7 '18 mini. Anyone else experiencing this?
Like nearly a minute between power button and bong.
Once the bong goes, start-up time seems OK.
Ran DFA and Onyx. Did an SMC reset.
Will try a Safe boot next.

My i9 ‘19 iMac is the same. I had attributed it to it booting off an external SSD and requiring that tine to orient itself. The SSD is very fast and startup is normal after the chime.

That delay between power-on and the startup chime is when the hardware is running its POST (power-on self test). The chime means it passed the tests and is starting to boot.

Depending on your hardware, it might take a bit of time. Especially things like RAM testing if you have a lot (a 2018 mini can go up to 64GB). I think it also takes this time to discover bootable storage devices in order to select one, if your Startup Disk preference doesn’t refer to a currently-connected device.

One quick and easy thing to try: Go to System Settings → General → Startup Disk. Make sure it is set to the device you normally boot from. If not, select it.

If your system lost its Startup Disk setting (maybe because you zapped PRAM), that could easily make the boot sequence take longer, since it will wait a short time for all your storage devices to come on-line (hard drives and USB devices may take a bit of time, so the BootROM code waits for them), identify which are bootable, and then make an educated guess about which one you want to boot from.

But once you have a Startup Disk setting saved in NVRAM/PRAM, it won’t wait. It will look for that device and start booting as soon as it becomes available.

2 Likes

it is a 64G i7 '18 mini, but it never took this long to POST until the 12.7.5 update.
The start-up disc is still right, but I toggled to be sure.
Time will tell.

toggle seems to have fixed that.

harrumph!. back again.
I ran Onyx and that fixed it … for now.

What procedure did you run with Onyx?

nope, no fix, still doing it. grrrrr

it is searching for the start-up disc every time.
just tried selecting it after start-up was complete and it spins a while in search of it then shows it.
then I restarted again after setting it. This time the chime came up followed by the Apple immediately, but it takes a minute to begin the start-up sequence after the Apple
The only other drive attached is an ext storage drive with no OS on it.

Ran diagnostics on it, came up NP.
Disconnected UA Apollo I/O and start up was normal.
Been having an issue with the I/O since UA 11 shortly after MacOS 12.7.3.
Could a Tbolt2 cable cause this? My I/O is Tbolt 2 and connected to the 2018 via an Apple Tbolt2/3 adapter (USB-c).

That’s a possibility. I would assume that the POST is going to send commands telling external peripherals to test themselves. If the Apollo is taking a while to complete its self-tests, that would definitely do it.

I don’t think a bad cable would cause this. If the cable was bad, you’d find flaky behavior with the Apollo all the time, not just during bootup.

I do know that Thunderbolt 2-3 adapters do not provide power to connected peripherals. So make sure your Apollo is plugged into its own power brick and that it is powered on when you power-on the Mac. Otherwise, macOS might be trying and failing to power it on during the POST. Even if you turn it on later (when you are using it), that won’t help during the boot sequence.

If the problem happened after an Apollo firmware update, then there may be a bug. See if UA has an updated firmware you could install. If it happened after a macOS upgrade, there may be a bug there that UA needs to fix.

In general, I see that most pro audio users hold back on macOS updates until suppliers of necessary hardware and software certify their products for use with the new OS, in order to avoid problems that might adversely affect recording schedules. If UA doesn’t officially support your equipment with macOS 12, you might want to see if you can downgrade it until UA provides support (possibly with an upgrade to their software/firmware).

I’m not sure how much this is helpful, but hopefully it will help a bit.

The I/O is powered, won’t turn on without. Normally, I never disconnect or turn off the I/O, just out of habit. The Mac is on a scheduled shut down.
Had a few emails with UA, they say it’s not them. I just dl’d an update, haven’t installed it yet.
My I/O is supported with my config.
I usually wait to update anything until my friends at Lucasfilm say their stable.
It could be the Tbolt card in the I/O. Weird.