Phone number missing from Messages


(Jeremy Roussak) #1

I had a problem with my iPhone 6s: Bluetooth stopped working. I got in touch with Apple’s chat support and was given advice on how to fix it. The advice was to “reset all settings” on the phone, advice rivalled in its cretinous stupidity only by my idiocy in following it (it made no difference to Bluetooth, of course, and a later advisor, who bothered to run some diagnostics on my phone, tells me the problem lies with the battery - but that’s another matter).

Anyway, after a very long time spent restoring all my settings, I find that the phone no longer appears in Messages on my MacBook; Messages preferences lists email addresses but no phone number. Texts sent from the phone don’t appear on my Mac, and all messages sent from the Mac seem to come from my mac.com address, not my phone, and they don’t appear on the phone.

I’ve tried signing out of the Messages account and signing back in, but it makes no difference. In “Internet accounts”, my phone is shown as a listed device.

Any ideas on how to restore the link between my phone and Messages?

Jeremy


(Simon) #2

Have you checked in Settings > Messages > Send & Receive that your Apple ID appears at the top, that your iPhone’s phone number appears in both lists below, and that there’s a checkmark next to that number in the bottom list?

IIRC only texts sent through iMessage will show up seamlessly on all your other iCloud devices. When you write a text on your iPhone, does it get a blue bubble (iMessage) or green (SMS)?


(Doug Miller) #3

On the iPhone I’d check settings / messages / text message forwarding to ensure that your Mac is listed.


(Jeremy Roussak) #4

Yes, I’d checked all of those, thanks. I think I have fixed the problem by signing out of iCloud on every device and signing back in. It’s the equivalent of turning it off and on again.

Jeremy