Mojave Shutdown Cause

So…my 2015 rMBP running up to date Mojave periodically is shut down when I pick it up in the morning. The power supply is plugged into a power strip that is turned off at night and every 4th or 5th time I pick it up it’s off; rebooting then gives me the standard improper shutdown dialog when it finishes booting. It’s a stock machine but with a 1 TB OWC SSD instead of the Apple one…back in March I put the original Apple SSD back in temporarily for the Combo Update application so that the firmware would get properly updated along with the OS. It’s connected to the AC adapter almost all the time although there is no power to it at night when the power strip is off.

My serial number is one of those affected by the recent battery recall…but since we’re on the road traveling for the summer in our RV I will likely not be able to send it in for replacement until we get back to FL in October.

One thing I’ve noticed…and I think that this is new with Mojave, anyway it started then I think…the charging indicator on the menu bar says charging but the green light on the Magsafe connector does not come on. Pulling and replacing the connector sometimes gets the green light and sometimes not. Leaving the connector out for awhile to run the battery down below 100% and then replugging gives me the orange light followed by the green light. I do condition the battery every couple of months by running it down until shutoff.

I googled shutdown cause and found some old articles using the "log show —predicate” command but that obviously predates Mojave since I get a Cannot open local log store complaint in terminal. Adding Mojave to the search criteria in google didn’t reveal a better command.

So…what can I look at to try and figure out what the cause is? I’ve got 8 or 10 login items but nothing has been added since this started…so I can’t really point to one of them being the culprit. I suspect that it might be LaunchBar which is trying to index my network drive which may or not be either running or connected on any given day…I stopped those index items yesterday and it hasn’t crashed yet…but it’s only been a day.

Howard Oakley’s Consolation lets you look at logs and might shed some light on the situation. He talks about using it to figure out crashes here:

Thanks Adam…I will check Consolation out.

This has been happening to my MacBookPro (2017) as well. Not every morning, but a few times a month.
This morning I got this error code. Can anyone shed light on what this might mean?

Stackshot Reason: Wake transition timed out after 180 seconds while calling power state change callbacks. 
Suspected bundle: Thread 0x12b63d.
Failure code:: 0x00000002 00000027

Seth…that means nothing to me but in the interest of trying to figure out what it was I killed a few startup items to see if that might help. CopyClip was one, also turned off iStat Menus. I also looked through my LaunchBar index and disabled anything that scans my normally mounted network shared volume…that volume sometimes dismounts itself overnight and I thought that perhaps LaunchBar trying to scan a non connected network volume might be the cause.

My laptop hasn’t crashed since I did those 4 or 5 days back…so maybe that has something to do with it. I downloaded Consolation per Adam’s suggestion and if/when it crashes again I’ll follow the guidance in the article he linked to see if I can find anything.

hmm, I don’t have any of those installed. My startup items are all apps with the exception of “Audio Hijack Schedule Helper”.

One other oddity is that despite being connected to power (via an OWC USB-C Dock), when this happens (and it didn’t happen today), my laptop is completely drained of battery power, or at least in the lower percentage range (5% remaining for instance).

I haven’t yet had a chance to look at Consolation 3.

It is no longer possible to determine all startup items by simply looking at your user Login Items. They can also be self contained within the app itself or use a LanchAgent/Daemon to activate.

interesting point. How does one check what is launched without user intervention? Besides Apple processes of course.

I checked in /Library/LaunchAgents/
and I have 2 Little Snitch .plist files
in ~/Library/LaunchAgents/
I have a SpamSieve entry.

DetectX Swift (free trial) should be able to do that for you.

When you launch, it will probably automatically do a scan, but after that finishes, use the “<” button to go back to the main window and click on “Profile”. Scroll down until you see “User Login Items:”. You may also find some of the other information shown to be useful here, but I’ll harken back to what @ace said about using your log entries to narrow things down.


I had exactly the same problem and it sounds like I have very similar hardware too (MacBookPro11,2 with a 1TB OWC SSD). Before the OWC SSD, perfect behaviour. After the OWC SSD, weird things around sleep/wake needing force-power-off to cure and I also had a couple of kernel panics.

Turns out there’s an easy solution to both problems - given to me by the excellent folks at OWC when I pointed out the connection (the panics were triggered by IONVMeController). Fire up Terminal and:

  • Run “pmset -g” and look for the “standby” parameter. Its value is probably 1 which is the default.

  • Change it via “sudo pmset -a standby 0”. The “-a” flag applies the change for both on-battery and on-mains power modes.

  • Check that the change has stuck by re-running “pmset -g”.

This change does not seem to affect the normal operation of the machine so I have no idea what the difference is between standby=1 vs standby=0. But the change has definitely solved both problems. No more sleep/wake hassles and no more kernel panics. Officially, OWC says that they are waiting on Apple to address some underlying cause, at which point we can go back to standby=1. I don’t think the problem is confined to OWC-supplied SSDs. I think it’s more general than that.

As to your green charge indicator light, I’ve occasionally had that problem too but it has always been either accumulated dust and grime in either the magsafe plug and/or socket on the laptop, or the magsafe simply not seated properly. What I do when I attach the magsafe and either the orange or green LED does not come on immediately is to simply rotate the magsafe through 180°. If and only if that doesn’t cure the problem do I run a Q-tip dipped in isopropyl alcohol over both the plug and socket.

Worst case with magsafes is something that happened on my wife’s laptop where the magsafe connector became noticeably hot (almost too hot to touch) even though the orange/green LEDs still came on and the laptop seemed to charge properly. Getting a new power supply was the cure for that.

1 Like

Thanks Phil…I reset the standby parameter to 0…according to google this will disable hibernation but since the machine is pretty much always plugged in that’s not a real issue. I will see if that resolves the issue…although it hasn’t happened since I disabled iStat Menus and turned off everything in Launchbar that tries to scan my AppleShare data volume.

The strange thing about the indicator light on the MagSafe connector is that even when it’s out the menubar still indicates charging and the battery level does not go down…so it’s probably not dirt in the connector. I had already tried cleaning both the connector on both the cable and machine…nothing changes there. I do have one of those little metal things installed in the port on the computer…sorry, can’t remember the name…that makes the MagSafe 2 connector stay as tight as the MagSafe 1 did…but it’s been on there for years and the symptoms only started in the past 6 months or so.

I’ll try cleaning the connector again and see if that helps but it hasn’t in the past. I will also try swapping power supplies and using my wife’s MBA one instead…although it won’t keep the battery fully charged while the machine is in use since it’s a smaller capacity supply but it should at least help eliminate or point to the power supply as being the culprit. If that doesn’t work…I’ll try taking the metal insert out of the laptop connector and see if that helps, although I already removed and cleaned it when I did the port the last time and verified the connector isn’t bent. The fact that it still charges is strange though with the light out.

Maybe it’s the power supply or something in the green/orange light circuitry and it needs a new power supply.

I have three power supplies for my MacBookPro. One came with it and has a MagSafe2 connector. The others are for a previous-generation MacBookPro and I use Apple’s MagSafe-to-MagSafe2 adapters for those. The non-LEDs problem is intermittent and mainly occurs on one of the older supplies with a MagSafe-to-MagSafe2 adapter. I have never seen the problem on the supply that came with the laptop but that might be because it is sort of permanently plumbed-in, in the sense that the cable is velcro-cable-tied to adapters (Ethernet & FireWire) that plug into the Thunderbolt ports, with the whole three-cable assembly then passing through a nylon cable-tie which is anchored to my desk. What I mean by that is that the MagSafe2 adapter is never going to be under any stress and is probably never even going to wiggle. Conversely, the MagSafe-to-MagSafe2 adapters tend to be used in positions where they could easily tug and pull as I use the laptop. Those adapters are also more likely to be left lying on the carpet when not in use, which is why I suspect grease/grime/dust/fluff/whatever.

Having said all that, I have not yet experienced the situation where the neither the orange or green LED is on BUT the laptop still indicates it is connected to power. In fact it is usually me noticing something other than 100% that alerts me to the fact that the connector is not in place.

While on this topic of power-supply oddities, the supply that came with the laptop is rated at 20V, 4.25A while the older supplies are rated 18.5V, 4.6A. In Watts, those are 85 and 85.1, respectively. I will often have a bus-powered USB3 drive connected to one of the ports and then connect my iPad to the other. If the supply that came with the laptop is driving the show, the iPad will usually start grizzling that it is not getting enough power. This doesn’t happen when the laptop is using one of the older supplies or is running on batteries. I can’t figure out why this problem should only manifest with the “genuine” supply. It might make a little more sense if the iPad grizzed when the laptop was on batteries - you could argue that that extra tenth of a Watt was kicking it over the line. One day I might get around to sticking one of those USB passthrough devices that measures power utilisation in between the various USB devices to see what they actually draw under various conditions (actual hard facts being a great alternative to mere supposition).

Do the older power supplies provide the correct amp/voltage? As I recall they were different.


I made this change in Terminal July 24th, and haven’t had an issue since. So a big hearty thank you, @pmk.46j06 and OWC!

I notice that Mac OS 10.14.6 Supplemental includes
" • Resolves an issue that may cause certain Mac notebooks to shut down during sleep"

but since I performed the above mentioned Terminal command, I haven’t had a problem.

As I recall, that issue only involved T2 equipped MBP’s and your Security chip is at most a T1.