Messages on iPad

Have a new iPad 10, replaced my iPad 8. Transferred the settings & thought all was working fine. Today I tried to send a text to 2 people, one w/an iPhone, one w/another phone. Have been group texting w/both of them for years.
Today when I tried to send a message, the one w/o the iPhone shows up in red print w/an error message: this # is not registered w/Messages. I can’t find anything in Settings to fix this.
I gave up & sent the same message to the same 2 people from my iPhone, went thru perfectly. All responses from both people are showing up on my iPhone, none of it is showing on my iPad.
Has there been a recent iPad iOS change that I don’t know about? Why can’t I use Messages for a non-iPhone # when I used to do it all the time?
Please help. Thank you.

On your iPhone, go into Settings / Messages. Tap “Text Message Forwarding” and turn on the setting for your new iPad.


Thank you, that solved the problem immediately. Is this a new change? Or is it an older setting that I forgot to look at?

This group is great, always appreciate my TidBits membership!

Thanks very much!

Alas, it is a long-standing requirement that you have to turn that setting on for new devices. I wrote about it happening with a new Mac a few years ago.

Thanks for the answer, @ddmiller!

1 Like

Thanks very much, guess it’s been awhile since I had a new device & had to think about this. Now that I see your article dated Sept 2020, I realize the last time I had to migrate a device was early 2020, before your article.

Gotta love TidBits! Thank you!