Mail in Ventura

I have several email accounts. I select the mail box I want to send from and when I type in an email address Mail changes the account I want to send from to another account. This is totally annoying. Previously it would stay with the account I chose.


Check the Mail Settings > Composing and make sure Send new messages from: is set to Automatically select best account:

If that’s already set then you may need to retrain Mail to associate a specific email account with a certain recipient by manually selecting it?