Mail attachments "downloading" forever

This is making me crazy, sure hope someone has an idea – I have not found any help by Googling or searching Apple’s discussions.

Attachments to Apple Mac Mail messages show as “downloading” forever. Looks like this:


It’s intermittent – frequent for mail from Google Groups, only occasional for other email. I tried Rebuilding mailboxes, seemed to work one place, not for others.

It’s Mac Mojave, 10.14.6

Any ideas? TIA…

That occurs to me when the attachments are zip-compressed. Perhaps it occurs only when the sender is using Microsoft Outlook?

1 Like

Have you tried reading the message via iCloud web mail and downloading in the browser?

Just a stab in the dark here. Is the sender sending you links to files from a Microsoft SharePoint (or OneDrive, which is mostly the same thing) server?

When sharing SharePoint files with Outlook, it is possible to either embed the entire document in the mail message or just send a link to the server-side copy. Both appear the same (at least when I see them in Outlook), but they behave very differently. When the file is embedded in the mail message, it is quick and easy to save it to the file system. When the file is a link to the server, then that save operation involves a remote download, which can be slow (depending on available bandwidth) and may run afoul of an overly-aggressive firewall.

1 Like

Hmmmm, good stab. I am pretty sure these are conventional attachments but some might be from SharePoint or OneDrive. It’s a good hint because I do think some failed interaction with a server (Google Groups or maybe SharePoint) might be hanging this up. Started a couple of months ago and I cannot figure out what changed.

Yes. When there is a server-based email available, I can fetch the file there. For the Google Groups, that group has archiving off (meaning it doesn’t store messages, it just sends them), so server copy is not available.