macOS 12 Monterey Upgrade Issues

If you don’t have any apps that require Monterey (I can’t think of any at this time), then there’s no rush. Take your time and upgrade when you feel it is stable.

At minimum, I’d wait until reading that the current issues (especially the bricked system problem) have been solved and that no other critical bugs have surfaced. I have no idea what the version number will be at that time, but that’s what I’d wait for.

Sure, Apple would like everybody to upgrade immediately, but your primary goal is (I assume) a stable platform for your apps, not a showcase for Apple’s latest OS.

1 Like

I am just a simple end-user. Non-techy but non-idiot also. but… I’m terrified to upgrade. I have a Mac Book Pro 2020 running Big Sur 11.6. I have no problems. Should I wait until the next iteration is available?

I have the same question about my iphone and 15.1 (I have 14.8.1)

Thank you, David. I’ll wait.

Thanks for the info. It seems I could upgrade to Monterey as I performed the upgrade from Catalina to Big Sur before I switched the NVME SSD’s.
Or am I wrong?
Anyway! I’ll wait till at least 12.1 to take the leap.

Me too. Gonna wait.

4 posts were merged into an existing topic: Apple Releases macOS 12 Monterey with iOS 15.1, iPadOS 15.1, watchOS 8.1, tvOS 15.1, and HomePod Software 15.1

I have a system running Monterey 12.1 Beta, (just fine) and/but still waiting before allowing the official release kick in

… but I’m an admitted worry-wort


I’ve never opened a MBPro past iteration 2015.
Did you have to solder in a new drive in the 2017?

Well, jmhbpc, not as much of a worry wort as I am… I’m waiting till 12.1 is official b/f doing anything. I come by the worry honestly tho. As I’m sure you do also… (A bit off topic, I know).

I got a new 4TB USB-C backup drive for my M1 Max (1TB storage, 850gb used) machine. I partitioned it into a pair of 2TB partitions, one for TimeMachine. Then I pointed TimeMachine to that partition. TimeMachine ran quite quickly (compared to the previous machine and its FW800 backup drive.) But it didn’t complete. The message was “not enough storage” and DiskUtility showed 1.8tb used on the backup device. I ran DiskUtility->Repair on the drive, just in case, and restarted backups. Same message. So then I started excluding stuff from backups. Eventually TimeMachine completed, the storage was reset down from 1.8tb down to the expected 600gb. I re-enabled the rest of my files, and now TimeMachine is behaving as expected. A bit more than 1TB is shown in use on the backup partition.

1 Like

Time Machine on Monterey seems to be a bit buggy as well. I discovered this last night when I enabled Time Machine on my new MBP, opting to start from scratch. A few hours later, Time Machine was no longer running, but it said it was still waiting to complete the first backup. I’ve restarted Time Machine multiple times, but Time Machine never finishes the first backup.

I searched the web this morning and found others that have encountered this seemingly common problem with Monterey, so if you rely on Time Machine as your main backup, you have another reason to hold off on upgrading.

Apple is reportedly aware of the issue and working on a fix. (Supposedly, this is yet another bug first reported during beta testing that somehow escaped Apple’s attention.)

Does anyone have any knowledge on how much space one needs for an in-place Monterey install ? - here’s a situation - A customer with Mojave has a MBP with a 256g ssd in it. - She had about 12 g left of Freespace with the Monterey Install downloaded already - We dug around her drive and removed about 40 gig and at reboot it appeared to have about 79 g free. Run Monterey installer and everything seems groovy - but at the last bit - it reports an error and presents less than 9 gig available. Also, the Main Drive (after subsequent reruns) gets its name appended by .drive with each retry. Of course, by now, i’m nuking and repaving, but this experience reminds me of Leopard (which was the worst! ). Anyone know what is actually needed “freewise” or will it all be Nuke and Pave for these close quarters.(clearly, i don’t trust the OS reporting-) As a side comment - do you think Next Year’s OS will be OS13? or OS12.1?

So, can anyone help me. I upgraded my two computers to OS 12.01. The difference is that one was a clean install. Problem is that I cannot for the life of me get my old HP Laserjet 1020 to work on the clean install machine. I tried copying the driver from the laptop with the same OS but no luck. I spent way too long searching how to hack this but I rarely use Terminal so wasn’t so successful. Does anyone have a suggestion??? I’ve gotten a work around to set the printer on the laptop to be shared on the network but I’d like to print directly from the Desktop.

I take it you tried the straightforward Add Printer steps in System Preferences?

well…of course. This isn’t my first computer!

1 Like

Might Gutenprint help? I have no sense of what official drivers might be available, or why the various ones like Generic PostScript Printer wouldn’t work.

I’m still very much of the opinion that Monterey is a work in progress. Last night I was using Capture One 21 and tried to import some images from an SD card (using the built in card reader in the new M1 MBP). C1 displayed about a dozen images before freezing. I force quit C1 and opened the card in the Finder to find there were no images available (disturbing given these were photos of my son’s graduation). I tried importing into Photos without success, Pathfinder displayed no images and my favourite photo recovery tool crashed trying to launch.

After restarting the machine I was able to open the card in the Finder, all the images were there, and Capture One was able to import everything normally. I was going to blame C1 for the issue but I can’t get past the Finder/Pathfinder not being able to recognise images on the card.

I also see considerable lags between files copied across servers, disks, devices and iCloud - the machine never seems to be ‘in proper sync’ (if that makes sense). There’s clearly still some issues with Monterey (or APFS) - I just hope there’s some updates coming soon which may help sort them out.

I agree. Monterey is not fully baked yet. Quite a few issues.

Update. I got fed up with 30 minute logins. I read someone who suspected that Monterey problems with SSD drives might be caused by drives formatted HFS+ instead of APFS. Having insufficient faith in Time Machine, I bought a new 2TB SanDisk Extreme SSD, same make and model as my old one, formatted it APFS, and cloned my old home directory onto it. Happily, this fixed the problem completely, either because of the new drive or the new format.


For those members in Australia, has anyone else have problems with viewing the Bureau of Meteorology (BOM) radar pages on both Safari and Firefox, on a mbp14? Safari initially displays only the observations if you had previously had any of the ‘Map features’ check boxes selected, I don’t get to see the radar images. If I clear all the check boxes before closing the site, and them selecting the site again the radar images display and the check boxes will now work as normal, until the next time I goes back to the site. Firefox won’t even access the BOM site at all irrespective of turning https on or off. Everything works fine on my iPad (15.2) and other macs not running Monterey.

There is also a problem NT News digital print editions page.

I agree with trilo and tommy it will take a while for things to settle down.