MacBook Pro First impressions

Finally my new baby arrived and like a new parent I’m already attached. It’s not perfect but here are a few observations:

It’s truly beautiful, just stylish.

Monterey required an update (2.x GB) and installed without issue. Updated all Apps from App Store and retrieved all my documents from the cloud. It took a couple of hours to download local versions but it’s working fine.

On the topic of speakers, I can ‘sort of’ understand the mentions from Doug. They are quite good but there’s a sort of spacial gap that makes spoken word on youtube sound not quite perfect. I’m sitting hear listening to Pearl Jam’s Black and it sounds fantastic. I’ll try a movie later and see but I think they’re fine.

1Password is a problem. I loaded my previous version (6.8.9 I think) and synced via iCloud. It wouldn’t fill in bank account details and the Extension for Safari doesn’t seem to be available anywhere. I downloaded version 7 as a test and it has crashed every time. It will open, I can find the password I want to use but as soon as I try to open the page it crashes. Very disappointing. I’d love to see Apple have a crack at doing a proper Password Manager. Notes and Reminders look really nice but in my eyes there not as important as security.

My AdBlock Plus stopped working but I downloaded 1Blocker and I’m back to youtube with no ads.

The trackpad is a little strange compared to my 2015 model. On my old girl I could very lightly touch two fingers into the trackpad to initiate a right click - with the new machine I have to actually Press two fingers down for the same effect. It’s a small thing but given I do it probably a hundred times a day it’s taking a bit to get used to.

Performance seems good although I’m yet to do anything to test it properly. The disk reads/write are crazy good and the monitor is just superb, the blacks and truly black and I haven’t noticed any ghosting.

The backlit keyboard is fine. I can see a fine line of light from underneath but I can easily turn it down if to bothers me (it doesn’t).

The keyboard itself is great, tremendous feel with just the right amount of spring back and a very precise feedback. I’m a lousy typist but it just feels like a quality keyboard with no ‘wobble’ in the keys.

Mail has been a little flaky, already crashed a couple of times and it took me a while to find how to get it into my preferred ‘Classic’ view - it’s not where it used to be.

I had trouble getting a couple of existing bank cards into my Wallet. They were recognised and available but as soon as I entered the CVV it just errored out and said to contact the Bank. I’ll just wait and hope it resolves itself with time.

Touch ID is nice but limited to 3 fingerprints - weirdly I’d like 4…

I setup two printers - a Brother which was simple and works and an Epson which seemed to fail but actually succeeded (yet to test as it’s my wife’s).

The facetime camera is excellent, way better than my old machine.

On Apps, I clicked an Affinity Publisher document and it opened it in Affinity Photo, I’ll need to look into that further and see what’s going on. On trying to open a document I had to navigate several “allow access” dialogs before I could start.

I’ll stop now as it’s already too long but I’m looking forward to getting to know it better.

4 Likes

Make sure that ‘Tap to Click’ is checked on the first page of our Trackpad Preferences. I find on almost every major system upgrade or machine migration, some setting of mine is reset.

2 Likes

And if that doesn’t fix it, maybe you’re also suffering from “missing taps syndrome”.

Specs, trilo, specs! We want all the technical details. Also, what machine are you coming from?

(I’m currently running a 13 inch MBP and am debating between a 14 and 16 for the upgrade so people’s experiences in both directions would be really useful).

The settings for trackpad seem correct. It’s definitely possible it’s ‘missing tap syndrome’ but hopefully this will be a software issue. It still works fine, it just requires a much firmer press than my muscle memory is used to,

Ah yes, specs. 14" M1 Max with 32GB Ram and 24 GPU cores, 1TB. I’m moving from a 2015, 15" MBP (16GB, 1TB). I was a little concerned about dropping down in screen size but there’s not TOO big a difference with the reduced bezel sizes. I’m enjoying the slightly smaller size and lower weight and it will be much easier to travel with.

There is a HUGE difference between heat and fan operation between the old and new. The new one is silent, I’m yet to hear the fans spin (although they may have) and it runs very cool.

Quick thumbs up for the charger with its very long braided cable. I’ve lost count of the number of chargers I’ve bought over the years due to poor cable/connectors.

1 Like

Thanks! Very helpful.

Same here. By all indication this is indeed a bug with Monterrey. Hopefully 12.0.2 or 12.1 will have it ironed out.

1 Like

Good point. I need to run Apple Diagnostics. I just realize, despite working on it for a week now, I have not once (to my knowledge) heard my 14" spin up its fans. :slight_smile:

24 hours in and my delight has turned to massive frustration. The machine is great (although I believe Monterey is a little underdone) but the biggest issue is Password Management. 1PW continues to crash on EVERY attempt to autofill information. I’ve tried versions 6.8.9 and version 7 with no luck. I’ve also downloaded and extensively tried: BitWarden, mSecure 5, Lastpass, RoboForm and Minimalist.

None of them can successfully fill in a simple login form for my bank. Some will do some sites but none can do my banking site. Most manage the passwords OK but won’t autofill.

I’m also bothered that every App I looked at on the App store required an account to operate. Why can’t I have a simple password manager with a local ‘vault’ storage which I’m responsible for backing up?

It sounds crazy to be sending full login information to some remote server with zero knowledge of who’s at the other end. How does anyone know if anything is encrypted other than marketing spin?

Maybe I’ll write my own and see if I can use Shortcuts to populate the web pages.

1 Like

Assuming you can compare the functionality between new machine and old one, running same OS and same builds of 1PW…if it works on the Intel Mac then it would sure seem to be something 1PW would be aware of?

Please let us know what you find out; the inability to auto-fill across multiple apps is what is really mysterious.

Would be interesting to know if auto-fill works in another browser – have you tried with Chrome?

The NY Times tech columnist Farhad Manjoo is renown for being aggressively critical about just about everything Apple does. But in today’s NYT, he waxes rapturously poetic in adoration of the new M1 Max MacBook Pro. I think it’s a heartwarming read for dedicated Apple fans, and there’s a rapidly growing list of very interesting commentary:

I had a similar issue myself but not with the M1 MBP, it was a Monterey or 1PW update/1PW extension updateissue I think…the Safari toolbar icon didn’t give me choices and my previously addressable via LaunchBar login items no longer loaded the page and logged me in.

I got the following from support and it solved both issues…give it a try.

Quit Safari after disabling the 1PW extension.
Completely quit 1PW via the menu item.
Relaunch 1PW and update it…then completely quit again.
Launch 1PW and login with master password
Launch Safari, reenable the extension, relaunch Safari and see if it works.

That solved both problems for me. Their next recommendation was to delete and redownload 1PW v7 and then submit a report from the app…if you put in a ticket via the help menu they’ll give you a number and instructions on how to submit the report if needed.

Hey Neil, thanks or you continued input.

Yesterday I deleted all trace of 1PW and started afresh with the App store version before importing my previous passwords. I don’t have an account setup and I’m wondering if that might be causing a silent fail. I’m finding their whole separate plugin vs 1PW for Safari vs Integrated plugin a little confusing.

A quick update - this morning I deleted everything again, went to the AgileBits site and downloaded the free trial. As required with the site version, I also created an account. I have imported my previous passwords and it’s now autofilling without crashing. This makes my suspicion even greater it may have been related to not having an account.

Yep…1PW v7, the App Store version as I have both a Family subscription and local DropBox primary vault. Not using the separate plugin 1PW for Safari…just the one included in the app…it gets auto installed into Safari when the app is launched but needs to be activated in Safari Preferenes as well.

My old laptop (until yesterday) was a 2015 rMBP which was upgraded continually all the way to Monterey…the last time it got a clean install was 4 years ago probably. The new M1 model arrived yesterday and I Migration Assistant migrated it from a CCC clone since that’s faster than over wifi and I didn’t have the USB C ethernet adapter for the M1.

I think the important thing is to deactivate the extension in Safari after completely quitting 1PW…then killing Safari and either downloading a new copy of 1PW from the App Store or just relaunching, updating, quitting and relaunching as necessary to get it up to date…the completely quit seems to be the issue and the installed extension in Safari apparently doesn’t work if it’s not the correct version with the current version of 1PW.

I’m n to sure what the secret cause was that got it working but at least I’m content I can now switch totally to the new machine. It does seem to ask twice on opening websites sometimes. A dialog asking for Fingerprint ID will appear, I place my finger than it asks me to unlock with the master password. It’s weird because I just dismiss the second dialog and it logs me in fine.

Following on from the catharsis of starting from a clean machine I’m going to eventually replace ALL my old passwords. There are so many which have been reused (or flagged as compromised) it’s probably worth the effort. Now I’ve retired I have the time…

My MBP arrived yesterday, so I spent the day messing around with it and setting it up.

The experience actually started off kind of rocky. As I was going through the initial set up, I selected the wifi network, entered the password, and then clicked Next. It seemed to connect to the wifi network based on the icon in the menubar, but then nothing else happened. So I waited. Still nothing. As I was clicking around and trying random things, Setup Assistant abruptly went to the next screen.

Later, I wanted to see how fast I could transfer data over from my old computer using a Thunderbolt cable. With both computers booted, I started a file copy using Finder, and that seemed to be going pretty fast. Finder said it would take a few minutes to copy a 100 GB file. I aborted that and put my old computer into Target Disk Mode. The new computer asked for the password to access the encrypted disk. I entered it, and then boom! kernel panic. I tried it again. The disk mounted, but copying the same file was painfully slow. This time Finder said it would take a few hours. I aborted that.

I copied my music library over (using file sharing), but for some reason, the Music app wouldn’t recognize it. So I renamed the folder, relaunched Music so it would create a new library, and then imported all of my music. Then I couldn’t get iTunes Match to turn on. It turns out Music seemed to be in a half logged-in state but not really logged into my account. Once I signed in again, that seemed to clear up most problems, though iTunes Match still thinks I need to download all of the files that are already on the computer.

Overall, the experience so far was leaving me with a not very good impression of Apple’s software quality. But after that, it’s been pretty much smooth sailing.

The screen is great. It’s easier for me to read than the 2019 MBP’s screen. I didn’t even see the notch until perhaps an hour or two in.

The speakers are wonderful, just like on the 2018 and 2019 MBPs I’ve used. It doesn’t sound muffled or too boomy to me.

The keyboard feels better than the 2019 MBP’s. I like the bigger power/Touch ID button. I think the smaller trackpad on the 14" compared to the 16" helps with my typing accuracy.

Software-wise, things were generally good. Most apps I use have been updated to be universal. The two major exceptions are Dropbox and Adobe Creative Cloud, both of which I’ll probably just not bother installing on the new computer. 1Password worked fine.

The look of the computer reminds me of my 2008 MBP. I have to say it looks kind of ugly to me. I wish Apple had stuck with the more modern look. The HDMI port and SD card slot are worthless to me, and I could live without MagSafe if I had to.

1 Like

I like it, but I’ve noticed it’s taken me some getting used to putting my finger in the right place. I’m used to the smaller one and tend to put my finger at the top in the gap between the key and laptop top.

Dropbox isn’t native yet, which sucks, and it uses way too much RAM, but seems to work fine. I did once see it was using 79GB of RAM and seemed to be stuck. I forced it to quit, relaunched it, and it synced and is using 1GB.

(I still hate the direction the company is going, though. 99% of the new features I don’t need and regular old syncing has been going downhill. Can anyone recommend a Dropbox-like syncing service that actually works well?)

Most of Adobe Creative Cloud seems to be native and works really well. I just did a project in InDesign and it’s fluid and smooth and I couldn’t believe how quickly I accomplished stuff. Really sweet.

Really the only software issue I’ve had is the Finder quitting on me 3 times when I renamed a file. It relaunched with everything just about the same so it’s not a huge deal, but very odd. I have been organizing my files since getting the new computer and I was doing a ton of renaming, so it was weird that one out of 100 renames caused Finder to crash.

I thought that at first, as it was so boxy, but the reality is the subtly-curved edges feel wonderful in my hands and everything seems stronger and better-built. I don’t look at the computer that much, so the feel and function matter more than the appearance.

1 Like

I have no use for the new ports either. I would have been fine with 4x TB4.

I think the 2020 13" looked better overall due to its sleek appearance. Those tapered edges made it look far slimmer than it was. That said, once opened up the 2021 14" is clearly sexier. The keyboard and screen are both far nicer than before. The thin bezels are far more elegant than what we used to have. Bottom line for me, if the boxy case it what it takes to get great battery life and zero fan noise, I’m all for it.

1 Like

I fully agree. But I also note that this is true of so much software these days. Lots of new functionality is a solution in search of a problem at best and outright bloat at worst, meanwhile core functionality becomes less stable, slower, or just less usable overall.

I blame this on software releases having become less of an engineering prerogative and more of a marketing hoopla. New whiz bang gizmo has to come out because, well sales. Add the push for frequent updates to justify subscription services and constant revenue streams and we end up where we are today. IMHO it’s time skilled engineers take back the reigns and push the hoards of marketing folks and other ballast out the door so they’re forced to find something productive to do, where ideally, they’d also stop annoying the rest of the world. Talk about the 21st century version of the 80s used car salesman or the 90s lawyer.

1 Like