Mac App Store Malfunction on Mojave

After installing Mojave Security Update 2020-004 (not the latest 005, haven’t installed that one yet), Mac App Store shows that I have a number of software updates as it often does. When I click the “update” button for any update, the progress wheel spins for 10 - 20 seconds and then just stops. Nothing downloads.

I can download any software except for updates without problems on the Mac App Store. If I delete the update and search for it manually and download it, it works fine.

Anyone else having this problem? I’ve tried everything I can find on the net to resolve the problem to no avail. My first post, at wits end, been to TidBITS many times over the years.

Had same problem last week around when iOS 14 was released. My guess is a problem on Apple’s end. This week it’s been ok.

mas worked for me last week. It’s a command line app that interacts with the Mac App Store. Even then, i needed to run it a few times.

Thanks kindly, much appreciated.

That unfortunately didn’t work.

I see others are having these issues, I tried everything on this page with no success:

You are not alone. Your comment above is the only step that worked for me - delete the App which is requesting the update and download a fresh copy. Pretty frustrating.

I still can’t figure out if it was the installation of Safari 14 or if it was the installation of Mojave Security Update 2020-004 that caused my Mac App Store to malfunction when trying to download updates. I did these two updates a few days apart (the security update first and then Safari).

As I noted in my first post, luckily I did not install the latest Mojave 2020-005 Security Update. It no longer shows in Software Update and I see that it has been pulled ("page you’re looking for can’t be found):

Any others out there unable to download updates using the Mac App Store, progress wheel just spinning for 10 - 20 seconds and then stopping?

Yes, I thought this is a known symptom of the 005 security update?

I didn’t realize it was that widespread.

You should see that there has been another macOS Supplemental Update 10.14.6 made available late tonight. This includes a Safari 14 update which may or may not replace your current version. After installing the latest Supplement, you should see a new posting of Security Update 2020-005 appear. You may want to wait awhile before trying that as nobody I’ve been following has done that yet.

Thanks for letting me know, I thought this Supplemental Update included Security Update 2020-005. I will wait and see how others make out first (see if there are as many “bricks” this time around).

Yes, the Security Update 2020-005 is not included in the Supplemental Update and I was wrong about not being able to see the former until you installed the latter. Turns out I told Software Update to ignore the Security Update. When I cleared that it did appear for me.

There’s a posting by Mr. Macintosh that appears to cover all scenarios

Thanks for clarifying.

Hi in response to this older thread - I have Mojave V10.14.6 I have been having issues updating apps via App Store for months now occasionally it will work but usually it looks like it is downloading but nothing happens then it drops back to Update again. I found a workaround this morning. Download a free application from the app store then try updating and it seems to work fine. Hope this helps others.

I’ll give that a try because this morning, February 22, 2021 9AM, updates have completely stopped showing up in the Mac App Store for me once again – just out of the blue. First time in 6 months (the problem just seemed to fix itself on its own the last time this happened but it took a while).

G’day Folks
Likewise, updates via the App Store are again refusing to download to any computer running Mojave (my own, plus 7 at work).

Cheers, Gobit

It seems that people are having success by force quitting appstoreagent

1 Like

That was working last week, but no longer.

I posted something very similar back in September of 2020:

Still running Mojave 10.14.6. For no reason at all, out of the blue on Feb. 22, 2021, the Mac App Store suddeny shows “no updates” even though I have seven updates (when I select the update tab on the left to view the updates, I see a blank white screen).

When I try to download a “known” update (or any software for that matter) by typing it in manually in the Mac App Store search and click on the download button, the wheel spins and spins and…

Force quitting appstoreagent in Activity Monitor solves the problem but when I quit the Mac App Store, the problem returns.

Nothing new has been installed for months so I decided to install Mojave 10.14.6 Security Update 2021-002 today, did a safe boot, SMC reset, PRAM reset, logged in and out of my account on the Mac App Store numerous times. None of this has helped.

Is anyone else experiencing this? It seems to me that the last time this happened, it had something to do with Apple’s trust certificates on their end because the problem did eventually fix itself on its own even though I tried a dozen things to try and resolve it.

Same here, except I installed Security Update 2021-002 when several days ago. Starting Tuesday, none of the things that used to work helped at all. Updates page is blank, when I go to a know out-of-date app there’s a download cloud, but clicking it results in a spin for a short time and then back to the cloud.

1 Like

yes, chiming in with a “yep”, 10.14.6 and Mac App Store is stuck on 9 updates available, but I cannot seem to get the apps to update (unless I force quit appstoreagent, which just worked).