iTunes (Version Restore dimmed

iMac Retina late 2015, 16 GB RAM
Mojave 10.14.6 (18G6020) [Skipping Catalina and waiting for SuperDuper to work with Big Sur]

I’m still using iTunes, Version, to manage my iPhone & iPad. Mostly I use iTunes for managing backups and installing software. I don’t do much media library management.

Two issues occurred today when I tried to use iTunes to manage/install iOS/iPadOS 14:

First: I followed the usual steps (copied from Help):

  1. Connect …
  2. In the iTunes app on your Mac, click the Device button …
  3. Click Summary.
  4. Click Check for Update.
  5. To install an available update, click Update.

But on my screen there is no longer any option to ‘Check for Update’ and no ‘Update’ button either. I’m sure I followed this process for my most recent iOS/iPadOs update.

Second: Before updating I wanted to be sure I had iCloud and computer backups. In iTunes I selected a device, then clicked the ‘Backup Now’ button once for ‘iCloud’ and once for ‘This Computer’. When the process completed iTunes showed the ‘Latest Backups’ correctly. Being cautious I thought, what if I wanted to actually restore from my backups. I looked under ‘Manually Backup and Restore’ and found the ‘Restore Backup’ button grayed out for both devices. The ‘Restore’ option is also grayed out in the ‘File > Devices’ submenu.

Have I installed an iTunes update that no longer allows me to manage updating or restoring? And, if so, why does Help still provide instructions for doing so? (I guess I can still backup but now I can’t use the backups to restore?) Do I have to finally give up on iTunes and use iMazing or something similar to manage my devices?

Thanks for your thoughts.

There is an updated piece of software required to sync iTunes (and backup etc.). It doesn’t have a name that I’m aware of, but when I first attached my iPad after iOS 14, iTunes gave me a prompt to download this addition.

iTunes sync update
So, to answer your question, yes it is possible to use iTunes still (thankfully), but I don’t know how to trigger the required iTunes update.

Maybe quit and relaunch?

Same iTunes in Mojave and had no problem updating my iPhone 7 to iOS 14.0 last Wednesday when it was released. I did get that same prompt that Seth mentioned and installed the Mobile Devise update before the “Check for Update” button worked.

1 Like

I believe it’s called Mobile Device Updater. I ran into it just recently when trying to test Apple Configurator 2.

1 Like

OP here. It seems my problems were because I hadn’t plugged the devices directly in to the iMac. I had ignored iTunes’ warning under the OS version saying “Connect this ixxx using a USB cable in order to update or restore its software.” (I don’t usually charge devices through the iMac and I have both a charging cable and a cable connected to the iMac on my desk, so I just assumed I was connected. Just goes to show, don’t assume.)

When I attached my iPhone via cable the Mobile Device Updater appeared. After install and restart of iTunes all buttons have reappeared and are no longer grayed out.

Thanks for your help.


My MBP is still running High Sierra. When I’ve gotten that message — i.e., A software update is required to connect to iPhone XS, I’ve assumed that it was prompting me to download and install either Mojave or Catalina in order for my MBP to fully interact with my iPhone XS and have just clicked “Not Now”. Why in the world would Apple be so secretive or cryptic about what software needs to be installed or updated? Grrrrr!

"Why in the world would Apple be so secretive or cryptic about what software needs to be installed or updated? Grrrrr!

Adam says NO WHINING when it comes to Apple. If you have any criticisms of Apple, please go to or write to Tim Cook directly.

The best way to get something changed at Apple is indeed to submit feedback and write to Tim Cook.

I commented on the Mobile Device Updater dialog just this week while writing about Apple Configurator 2.

When you first launch it with your iPhone connected via USB, you may get one of those inscrutable Mobile Device Updater dialogs that indicates your Mac lacks the software necessary to communicate with the version of iOS on your device. Unfortunately, Apple’s support note is useless, apart from confirming that it is an official alert and that there’s no problem with installing.

It’s a poorly designed system, but belaboring the point here achieves nothing.


What kind of cable did you have connecting your iPhone/iPad to your Mac which wouldn’t allow you to update your mobile software?

The cable wasn’t the issue. It was what the USB end of the cable was attached to. On my desk I have one cable attached directly to a charger and another to the computer. The problem was caused because I hadn’t realized the iDevice was attached to the charger. When attached correctly the problem was solved. It was a case of my jumping to a conclusion about the effects of a software installation, when it was my fault for not connecting directly to the computer.

Got it - I thought they were both connected to the iMac.

I don’t have any cables connected to charging bricks - my USB hub is a 3.1 gen 1 10 port hub which has 10 ports each with 5v 2.1a (so all the ports are charging ports) - though none with mutated Qualcomm or Samsung fast charging which can damage delicate electronic devices like Nitecore digital chargers or C.Crane digital radios.

My other external USB ports are on a (currently) Cable Matters Thunderbolt 3 dock which features various USB 5v USB ports with amperages up to 2.1a (but again, no high voltage or high amperage ports).

  • iMac (Retina 5K, 27-inch, 2017)
    – macOS 10.14.6 (18G6032)
    – 32 GB RAM

  • iPhone 7 plus
    – iOS 14.0.1

  • iTunes Version

Not sure whether my persisting problem is related …

Usually the iPhone is connected to the Mac ~16 hours per day, via USB cable, no hub etc. in between.

Now, ever since upgrading the iPhone to iOS 14 (and later to 14.1), every time I connect the iPhone to the Mac I get a message on the Mac:
A software update is required to connect to [my iPhone name].
and when I try to download it, it ALWAYS times out because of a network problem—but my other downloads, browsing, Mail, App Store, Discord, Slack, Telegram, etc., work just fine, and iTunes connects to the iPhone also.

(NOTE: My iPhone is named “dreiFon” b/c I’m German and it’s my 3rd iPhone :wink: )

Does there exist a standalone installer for this software? If not, is there anything I should (and could) do about this?

Tom in Germany

No, there is not. I might be able to give you an alternate way to obtain that update, but don’t have time at the moment to research and test it, so will try to get back to you later on.


OK, I’ve had a chance to find the appropriate installers and tried them out. My setup is very close to yours with a 16GB iMac18,3 macOS 10.14.6 (18G6032), iTunes, but iPhone 7 with iOS 14.0.1.

  1. Make a backup first!
  2. Download then double click the Mobile Device Bundle installer package
  3. Download then double click the Mobile Device On Demand installer package

You might need to cut and paste these links in a new browser tab

You’ll need your admin password for each installation

Each installation requires additional time to run scripts and optimize the OS.

I had previously installed this update on my Mac, but with the issues surrounding Safari 14 I had reverted back to macOS 10.14.6 reinstall, Safari 13 and Security Update 2020-004, so can’t be positive that it was still there before accomplishing the above.

Had no problem connecting the iPhone to the iMac after.

Good Luck



I believe you meant “and later to 14.0.1” as nobody I know of (including developers and beta testers) has ever seen an iOS 14.1. Might show up on an iPhone 12 soon, but I doubt even that.

1 Like

THANKS a lot for those links, @alvarnell, muchly appreciated! :heart:

I’ll try that tomorrow and will give feedback here.

And yes, iOS 14.0.1 of course :sweat_smile: corrected that above.

Took me longer than intended … Real Life interfered.

@alvarnell, thanks again, worked like a charm!
Didn’t even force me to restart the machine (but I did anyway). Also, no more hanging updates in the SW update pane of Sys Prefs.