Is there a way to turn off Spaces entirely?

Although I use virtual desktops on my Linux systems, on macOS I never use Spaces. I don’t mind it, I just never use it. I’ve noticed though that lately when I try and throw a window up against the menu bar, instead of bumping up against the menu bar (so I can drop it there for top alignment), Spaces butts in, I guess trying to offer me the option to throw that window onto another space.

Is there any way to turn this off entirely? I can’t find anything in Settings or with TinkerTool.

Check the “Hot Corners” in System Preferences / Mission Control? Uncheck everything? A couple of the checkboxes look like they could do your described problem. The Keyboard and Mouse Shortcuts too.

Yes, “Mission Control” is a funny name for Spaces Preferences.

Thanks. Yeah, I checked that. Nothing such selected in hot corners.

one thing that would complicate eliminating Spaces is that Full Screen views are implemented as Spaces. If you make a window full-screen and then access Mission Control, you’ll see the full-screen window is a separate space.

1 Like

Looking at what you’re trying to accomplish from another perspective, have you tried auto-hiding the menu bar? Putting a window at the top of the screen doesn’t open Spaces. And, if you want the menu bar, just move the mouse to the top of the window. In a lot of cases, using the controls at the top of a window that’s sitting at the top of the monitor won’t force the menu to be displayed
For long time Mac users, hiding the menu bar behavior is very weird and almost sacrilegious, but it grew on me.

I also am finding (at least on Ventura) how quickly you move a window toward the top of the screen (even with menu bar hiding enabled) can influence whether Spaces get invoked or not. If I drag a window slowly toward the top of the screen, it stops just below either the menu bar or the top of the screen. No Spaces. Dragging it quickly (almost like I’m trying to drag the window off the top of the screen) causes the Spaces behavior to go active.

At least for me on Ventura, hiding menu bar or not has zero effect on my issue.

I don’t really care about Spaces or hiding/eliminating Spaces. I just want this silly pop-up (that shows one active space labeled “Desktop”, duh) to stop whenever I push something to the top of the screen. It’s undesired and it’s redundant.

Hmmm. I personally don’t recall seeing that behavior, and attempting to recreate it now, I still don’t see it. I grabbed a couple different windows and dragged them at various speeds upward, but they always stopped at the bottom of the menu bar, and no Spaces indicators appeared. Other than a possible OS variation (I’m running Monterey 12.6), I’m wondering if the fact that you’re not using Spaces is the culprit here? I use Spaces a lot, and have several defined. It sounds like you have none. I wonder if you create one will the behavior you’re seeing persist?

I do use Spaces and se the behavior Simon is describing on both my Macs running Ventura (13.0.1).

Drag the window towards the top. It stops moving at the menu bar, but if you keep dragging up (try to push the pointer above the top of the screen), macOS will rearrange the screen, presenting you with a list of spaces to drop the window on.

Here’s a quick screen recording I made showing it:

OK. A mystery indeed. Here’s the same test on my Mac. (Sorry, no YouTube account–hope this works.) Apparently some setting on my Mac is preventing the behavior you and @aforkosh are seeing, but I’m at a loss to guess what it is.

That’s exactly the behavior I’d like to get. I’m hoping to find out what magical setting you have that prevents the stupid Spaces selector from showing.

The other day, I was about to post almost exactly the message Jeff Fischer posted: I use Spaces constantly, and I had never seen this behavior. And I was unable to reproduce it — to the extent that I wondered if I misunderstood the actions that cause it, even though they seemed clearly enough described.

But then Technogeezer mentioned that it depends on the speed at which you move the window. So I tried flicking a window quickly against the menu bar. Sure enough, that works.

This is very useful to me. I often have reason to move a window from one Desktop to another. There are a number of ways to do that, but they usually feel clumsy. This method works well. Now that I know how to do it, I can do it reliably, simply by flicking the window quickly. And I can just as easily avoid it by moving the window at, what feels to me, a normal speed for dragging something.

I guess the only suggestion I have for Simon is … slow down?

Just trying it out, it isn’t so much the speed at which the window-dragging cursor hits the menu bar, it is that it carries on over it to the top of the screen in one movement. Should you pause when the window stops moving as it hits up against the menu bar, or pause the cursor on the menu bar, you will not see the offer of Spaces.

Well, despite the observations of @jajvj1 and @drmoss_ca , I still can’t make it happen. Slow or fast, pause or no pause, doesn’t matter. What I observe is that the window and arrow pointer move together vertically until the top of the window meets the bottom of the menu bar. At that point, the window stops and the pointer continues moving upward (briefly) until it meets the top of the menu bar.

I found little on the web about this, but apparently it is a thing (there are others with the same desire as @Simon). Unfortunately, there is scant advice on how to make it stop (a couple shell incantations, with varying reports of success). I think if that gesture was invoking Spaces on my machine, I’d want it to stop too. But unfortunately, turning it off is not something I did consciously, nor can I guess what setting/combination of settings/third-party software present on my machine is responsible. Happy to answer any questions, though, if anyone has a theory.

Edit for clarity: To stop Spaces from butting in when dragging windows to the top, uncheck “Displays have separate Spaces” at the bottom of the Desktop & Dock section of System Settings, then log out and in. This worked for me on Ventura.

7 Likes

That was it. Confirmed on my Mac!

“mission control” in monterey (and probably earlier).

Thank you. That’s where I found it in Big Sur.